(address . bug-guix@gnu.org)
I've been trying to improve the Haskell tooling we have here on Guix, but
I ran into this problem: if I try to do ~guix import hackage
cabal-helper~ it fails with:
Syntax error: unexpected token : common (at line 76, column 0)
Syntax error: unexpected end of input
guix import: error: failed to download cabal file for package 'cabal-helper'
If I import ghc-mod (which depends on cabal-helper) recursively, I get this:
Syntax error: unexpected token : common (at line 76, column 0)
Syntax error: unexpected end of input
Backtrace:
13 (primitive-load "/home/brown/.config/guix/current/bin/g…")
In guix/ui.scm:
1806:12 12 (run-guix-command _ . _)
In guix/scripts/import.scm:
116:11 11 (guix-import . _)
In guix/scripts/import/hackage.scm:
132:26 10 (guix-import-hackage . _)
In guix/import/utils.scm:
425:7 9 (recursive-import _ _ #:repo->guix-package _ #:guix-name …)
397:31 8 (topological-sort _ #<procedure 7f74ceff4ed0 at guix/i…> …)
In srfi/srfi-1.scm:
592:29 7 (map1 _)
592:29 6 (map1 _)
592:29 5 (map1 _)
592:29 4 (map1 _)
592:29 3 (map1 ("monad-journal" "pipes" "cabal-helper"))
592:29 2 (map1 ("pipes" "cabal-helper"))
592:17 1 (map1 ("cabal-helper"))
In guix/import/utils.scm:
421:36 0 (lookup-node "cabal-helper")
guix/import/utils.scm:421:36: In procedure lookup-node:
Throw to key `vm-error' with args `(vm-run "Wrong number of values
returned to continuation (expected ~a)" (2))'.