(address . guix-patches@gnu.org)
Hey Guix!
I have for a while wanted to write an importer for MELPA packages
that reads from the MELPA recipe and constructs a Guix package.
This is primarily because the ELPA importer uses source tarballs,
which we can't rely on for MELPA because they remove old tarballs
and upload new ones whenever they rebuild the package.
So, here is my importer!
Probably the most controversial decision here is to always import
the current head that MELPA would build. This means that when you
run "guix import melpa" it gives you a package definition that
should correspond to what MELPA currently has. This may not
correspond to a release of the package, so we cannot easily give
it a version, and thus I put the current date into the version
string.
I imagine it would be possible to combine this importer with the
current ELPA one in some way, to use all the metadata provided by
the ELPA importer, but then generate an origin based on the MELPA
recipe, but that seemed more daunting to me than writing a new
importer.
Carlo