(address . guix-patches@gnu.org)
Hi Guix,
when linting, I recognized that the archival linter was repeatedly
sending packages to the SWH, despite that the package was already
archived.
With some investigations, I noticed they changed the API. Here's a
patch that fixes it.
I have not communicated with SWH about that, especially I have not asked
SWH why they broke the API without updating the version number.
Björn
From a5ada85d168b45d517d8faf0d79ad5beccc26911 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bj=C3=B6rn=20H=C3=B6fling?=
<bjoern.hoefling@bjoernhoefling.de>
Date: Sun, 15 Dec 2019 22:00:56 +0100
Subject: [PATCH] swh: Fix API call for getting origin.
When using the archival linter, git origins already in the archive where
not recognized due to an API change and where repeatedly asked for archival.
This is fixed here.
* guix/swh.scm (lookup-origin): Fix API URI for getting origin.
(<origin>): Fix comment with API URI example.
---
guix/swh.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
Toggle diff (24 lines)
diff --git a/guix/swh.scm b/guix/swh.scm
index 7acad05928..372e4c84d1 100644
--- a/guix/swh.scm
+++ b/guix/swh.scm
@@ -244,7 +244,7 @@ FALSE-IF-404? is true, return #f upon 404 responses."
docstring
(call (swh-url components ...) json->value)))))
-;; <https://archive.softwareheritage.org/api/1/origin/git/url/https://github.com/guix-mirror/guix/>
+;; <https://archive.softwareheritage.org/api/1/origin//https://github.com/guix-mirror/guix/get>
(define-json-mapping <origin> make-origin origin?
json->origin
(id origin-id)
@@ -365,7 +365,7 @@ FALSE-IF-404? is true, return #f upon 404 responses."
(define-query (lookup-origin url)
"Return an origin for URL."
- (path "/api/1/origin/git/url" url)
+ (path "/api/1/origin" url "get")
json->origin)
(define-query (lookup-content hash type)
--
2.23.0
-----BEGIN PGP SIGNATURE-----
iF0EARECAB0WIQQiGUP0np8nb5SZM4K/KGy2WT5f/QUCXfam6QAKCRC/KGy2WT5f
/fenAJ9bGb6G8EjV7iP6S4BMKtD2zH5jfQCbBYi4fjTU290htYpCOSewZiFv5Jk=
=JIMw
-----END PGP SIGNATURE-----