[PATCH 0/1] Update rust-cbindgen

  • Done
  • quality assurance status badge
Details
2 participants
  • Jakub K?dzio?ka
  • Martin Becze
Owner
unassigned
Submitted by
Martin Becze
Severity
normal
M
M
Martin Becze wrote on 3 Dec 2019 02:05
(address . guix-patches@gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
cover.1575334658.git.mjbecze@riseup.net
Hello Guix ,
This patch updates rust-cbindgen to the latest version using the semver aware importer in patch 38408 (https://issues.guix.gnu.org/issue/38408).There are two other reasons for this patch 1) I wanted to test the output of 38408 and 2) I wanted to readd the rust libs in format that prevents top level packages having to specify their trasnitive dependcies. Also I tested icecat... and it should work!

-Martin


Martin Becze (1):
gnu: rust-cbindgen: updated cbindgen and its dependencies

gnu/packages/crates-io.scm | 7529 +++++++++++++++++++-------------
gnu/packages/rust-cbindgen.scm | 67 +-
2 files changed, 4522 insertions(+), 3074 deletions(-)

--
2.24.0
M
M
Martin Becze wrote on 3 Dec 2019 02:33
[PATCH 1/1] gnu: rust-cbindgen: updated cbindgen and its dependencies
(address . 38465@debbugs.gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
ad76c79084f3fc4ecfb8ea2e0f4edd4f3272dc26.1575334658.git.mjbecze@riseup.net
* gnu/packages/rust-cbindgen.scm (rust-cbindgen) updated to 0.10.0
* gnu/packages/crate-io.scm (*) updated all of rust-cbindgen dependencies
---
gnu/packages/crates-io.scm | 7529 +++++++++++++++++++-------------
gnu/packages/rust-cbindgen.scm | 67 +-
2 files changed, 4522 insertions(+), 3074 deletions(-)

Toggle diff (544 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b4bb599dcc..ce82bc3918 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -30,2306 +30,3161 @@
;;; Please: Try to add new module packages in alphabetic order.
;;;
-(define-public rust-adler32-1.0
+(define-public rust-addr2line
(package
- (name "rust-adler32")
- (version "1.0.3")
+ (name "rust-addr2line")
+ (version "0.10.0")
(source
(origin
(method url-fetch)
- (uri (crate-uri "adler32" version))
+ (uri (crate-uri "addr2line" version))
(file-name
(string-append name "-" version ".crate"))
(sha256
(base32
- "0p7fxlnks9l7p7rwfqi7aqgnk2bps5zc0rjiw00mdw19nnbjjlky"))))
+ "1daaxrzk6fmfzaqi06y704hcw0rjz199l0n9214ybfm3m3jnmc4m"))))
(build-system cargo-build-system)
- (home-page "https://github.com/remram44/adler32-rs")
- (synopsis "Implementation of the Adler32 rolling hash algorithm")
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-cpp-demangle" ,rust-cpp-demangle)
+ ("rust-fallible-iterator"
+ ,rust-fallible-iterator)
+ ("rust-gimli" ,rust-gimli)
+ ("rust-intervaltree" ,rust-intervaltree)
+ ("rust-lazycell" ,rust-lazycell)
+ ("rust-object-0.12.0" ,rust-object-0.12.0)
+ ("rust-rustc-demangle" ,rust-rustc-demangle)
+ ("rust-smallvec-0.6.13" ,rust-smallvec-0.6.13))))
+ (home-page
+ "https://github.com/gimli-rs/addr2line")
+ (synopsis
+ "A cross-platform symbolication library written in Rust, using `gimli`")
(description
- "This library is an implementation of the Adler32 rolling hash algorithm in
-the Rust programming language.")
- (properties '((hidden? . #t)))
- (license (list license:bsd-3
- license:zlib))))
+ "This package provides a cross-platform symbolication library written in Rust, using `gimli`")
+ (license #f)))
-(define-public rust-ansi-term-0.11
+(define-public rust-adler32
(package
- (name "rust-ansi-term")
- (version "0.11.0")
+ (name "rust-adler32")
+ (version "1.0.4")
(source
(origin
(method url-fetch)
- (uri (crate-uri "ansi_term" version))
- (file-name (string-append name "-" version ".crate"))
+ (uri (crate-uri "adler32" version))
+ (file-name
+ (string-append name "-" version ".crate"))
(sha256
- (base32
- "16wpvrghvd0353584i1idnsgm0r3vchg8fyrm0x8ayv1rgvbljgf"))))
+ (base32
+ "1hnan4fgmnidgn2k84hh2i67c3wp2c5iwd5hs61yi7gwwx1p6bjx"))))
(build-system cargo-build-system)
- (home-page "https://github.com/ogham/rust-ansi-term")
- (synopsis "Library for ANSI terminal colours and styles")
+ (arguments `(#:skip-build? #t))
+ (home-page
+ "https://github.com/remram44/adler32-rs")
+ (synopsis
+ "Minimal Adler32 implementation for Rust.")
(description
- "This is a library for controlling colours and formatting, such as red bold
-text or blue underlined text, on ANSI terminals.")
- (properties '((hidden? . #t)))
- (license license:expat)))
+ "Minimal Adler32 implementation for Rust.")
+ (license license:zlib)))
-(define-public rust-antidote-1.0
+(define-public rust-afl
(package
- (name "rust-antidote")
- (version "1.0.0")
+ (name "rust-afl")
+ (version "0.5.2")
(source
(origin
(method url-fetch)
- (uri (crate-uri "antidote" version))
- (file-name (string-append name "-" version ".crate"))
+ (uri (crate-uri "afl" version))
+ (file-name
+ (string-append name "-" version ".crate"))
(sha256
- (base32
- "19g2sw2qa2ibnh4x7j1snk46593jgx6y7rnvva496ynq61af5z9l"))))
+ (base32
+ "0azpi917l8nhvx25n2v670nvkxkrhcwmddfi85qnr6kchmi6y946"))))
(build-system cargo-build-system)
- (home-page "https://github.com/sfackler/rust-antidote")
- (synopsis "Poison-free Mutex and RwLock types")
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-cc" ,rust-cc)
+ ("rust-clap" ,rust-clap)
+ ("rust-rustc-version" ,rust-rustc-version)
+ ("rust-rustc-version" ,rust-rustc-version)
+ ("rust-xdg" ,rust-xdg)
+ ("rust-xdg" ,rust-xdg))))
+ (home-page "https://github.com/rust-fuzz/afl.rs")
+ (synopsis
+ "Fuzzing Rust code with american-fuzzy-lop")
(description
- "These types expose identical APIs to the standard library @code{Mutex} and
-@code{RwLock} except that they do not return @code{PoisonError}s.")
- (properties '((hidden? . #t)))
- (license (list license:asl2.0
- license:expat))))
+ "Fuzzing Rust code with american-fuzzy-lop")
+ (license license:asl2.0)))
-(define-public rust-atty-0.2
+(define-public rust-aho-corasick
(package
- (name "rust-atty")
- (version "0.2.13")
+ (name "rust-aho-corasick")
+ (version "0.7.6")
(source
(origin
(method url-fetch)
- (uri (crate-uri "atty" version))
- (file-name (string-append name "-" version ".crate"))
+ (uri (crate-uri "aho-corasick" version))
+ (file-name
+ (string-append name "-" version ".crate"))
(sha256
- (base32
- "140sswp1bwqwc4zk80bxkbnfb3g936hgrb77g9g0k1zcld3wc0qq"))))
+ (base32
+ "0b8dh20fhdc59dhhnfi89n2bi80a8zbagzd5c122hf1vv2amxysq"))))
(build-system cargo-build-system)
- (home-page "https://github.com/softprops/atty")
- (synopsis "A simple interface for querying atty")
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-memchr" ,rust-memchr))))
+ (home-page
+ "https://github.com/BurntSushi/aho-corasick")
+ (synopsis "Fast multiple substring searching.")
(description
- "This package provides a simple interface for querying atty.")
- (properties '((hidden? . #t)))
- (license license:expat)))
+ "Fast multiple substring searching.")
+ (license #f)))
-(define-public rust-autocfg-0.1
+(define-public rust-ansi-term-0.11.0
(package
- (name "rust-autocfg")
- (version "0.1.7")
+ (name "rust-ansi-term")
+ (version "0.11.0")
(source
(origin
(method url-fetch)
- (uri (crate-uri "autocfg" version))
- (file-name (string-append name "-" version ".crate"))
+ (uri (crate-uri "ansi_term" version))
+ (file-name
+ (string-append name "-" version ".crate"))
(sha256
- (base32
- "1chwgimpx5z7xbag7krr9d8asxfqbh683qhgl9kn3hxk2l0djj8x"))))
+ (base32
+ "16wpvrghvd0353584i1idnsgm0r3vchg8fyrm0x8ayv1rgvbljgf"))))
(build-system cargo-build-system)
- (home-page "https://github.com/cuviper/autocfg")
- (synopsis "Automatic cfg for Rust compiler features")
- (description "Rust library for build scripts to automatically configure
-code based on compiler support. Code snippets are dynamically tested to see
-if the @code{rustc} will accept them, rather than hard-coding specific version
-support.")
- (properties '((hidden? . #t)))
- (license (list license:asl2.0
- license:expat))))
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-winapi" ,rust-winapi))))
+ (home-page
+ "https://github.com/ogham/rust-ansi-term")
+ (synopsis
+ "Library for ANSI terminal colours and styles (bold, underline)")
+ (description
+ "Library for ANSI terminal colours and styles (bold, underline)")
+ (license license:expat)))
-(define-public rust-backtrace-sys-0.1
+(define-public rust-arrayref
(package
- (name "rust-backtrace-sys")
- (version "0.1.31")
+ (name "rust-arrayref")
+ (version "0.3.5")
(source
(origin
(method url-fetch)
- (uri (crate-uri "backtrace-sys" version))
- (file-name (string-append name "-" version ".crate"))
+ (uri (crate-uri "arrayref" version))
+ (file-name
+ (string-append name "-" version ".crate"))
(sha256
- (base32
- "0as2pk77br4br04daywhivpi1ixxb8y2c7f726kj849dxys31a42"))))
+ (base32
+ "1vphy316jbgmgckk4z7m8csvlyc8hih9w95iyq48h8077xc2wf0d"))))
(build-system cargo-build-system)
- (home-page "https://github.com/rust-lang/backtrace-rs")
- (synopsis "Bindings to the libbacktrace gcc library")
+ (arguments `(#:skip-build? #t))
+ (home-page "https://github.com/droundy/arrayref")
+ (synopsis
+ "Macros to take array references of slices")
(description
- "This package provides bindings to the libbacktrace gcc library.")
- (properties '((hidden? . #t)))
- (license (list license:asl2.0
- license:expat))))
+ "Macros to take array references of slices")
+ (license #f)))
-(define-public rust-base-x-0.2
+(define-public rust-arrayvec
(package
- (name "rust-base-x")
- (version "0.2.5")
+ (name "rust-arrayvec")
+ (version "0.5.1")
(source
(origin
(method url-fetch)
- (uri (crate-uri "base-x" version))
- (file-name (string-append name "-" version ".crate"))
+ (uri (crate-uri "arrayvec" version))
+ (file-name
+ (string-append name "-" version ".crate"))
(sha256
- (base32
- "0hv4y5cdhv6bk0ghk2434clw8v4mmk5cc9lsh6qrpri92zlfmx3n"))))
+ (base32
+ "1f5mca8kiiwhvhxd1mbnq68j6v6rk139sch567zwwzl6hs37vxyg"))))
(build-system cargo-build-system)
- (home-page "https://github.com/OrKoN/base-x-rs")
- (synopsis "Encode/decode any base")
- (description "This library provides for encoding and decoding any base.")
- (properties '((hidden? . #t)))
- (license license:expat)))
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-serde" ,rust-serde))))
+ (home-page "https://github.com/bluss/arrayvec")
+ (synopsis
+ "A vector with fixed capacity, backed by an array (it can be stored on the stack too). Implements fixed capacity ArrayVec and ArrayString.")
+ (description
+ "This package provides a vector with fixed capacity, backed by an array (it can be stored on the stack too). Implements fixed capacity ArrayVec and ArrayString.")
+ (license #f)))
-(define-public rust-bencher-0.1
+(define-public rust-arrayvec-0.4.12
(package
- (name "rust-bencher")
- (version "0.1.5")
+ (name "rust-arrayvec")
+ (version "0.4.12")
(source
(origin
(method url-fetch)
- (uri (crate-uri "bencher" version))
- (file-name (string-append name "-" version ".crate"))
+ (uri (crate-uri "arrayvec" version))
+ (file-name
+ (string-append name "-" version ".crate"))
(sha256
- (base32
- "1x8p2xblgqssay8cdykp5pkfc0np0jk5bs5cx4f5av097aav9zbx"))))
+ (base32
+ "1fdiv5m627gh6flp4mpmi1mh647imm9x423licsr11psz97d97yd"))))
(build-system cargo-build-system)
- (home-page "https://github.com/bluss/bencher/")
- (synopsis "Port of the libtest benchmark runner to Rust stable")
- (description "This package provides a port of the libtest (unstable Rust)
-benchmark runner to Rust stable releases. Supports running benchmarks and
-filtering based on the name. Benchmark execution works exactly the same way
-and no more (caveat: black_box is still missing!).")
- (properties '((hidden? . #t)))
- (license (list license:asl2.0
- license:expat))))
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-nodrop" ,rust-nodrop)
+ ("rust-serde" ,rust-serde))))
+ (home-page "https://github.com/bluss/arrayvec")
+ (synopsis
+ "A vector with fixed capacity, backed by an array (it can be stored on the stack too). Implements fixed capacity ArrayVec and ArrayString.")
+ (description
+ "This package provides a vector with fixed capacity, backed by an array (it can be stored on the stack too). Implements fixed capacity ArrayVec and ArrayString.")
+ (license #f)))
-(define-public rust-bitflags-1
+(define-public rust-atlatl
(package
- (name "rust-bitflags")
- (version "1.1.0")
+ (name "rust-atlatl")
+ (version "0.1.2")
(source
(origin
(method url-fetch)
- (uri (crate-uri "bitflags" version))
- (file-name (string-append name "-" version ".crate"))
+ (uri (crate-uri "atlatl" version))
+ (file-name
+ (string-append name "-" version ".crate"))
(sha256
- (base32
- "1zc1qb1hwsnl2d8rhzicsv9kqd5b2hwbrscrcfw5as4sfr35659x"))))
+ (base32
+ "18kyvdm56fdb52b1sryi80xgs3nkjdylynsv324aiqnj85l1bfrj"))))
(build-system cargo-build-system)
- (home-page "https://github.com/bitflags/bitflags")
- (synopsis "Macro to generate structures which behave like bitflags")
- (description "This package provides a macro to generate structures which
-behave like a set of bitflags.")
- (properties '((hidden? . #t)))
- (license (list license:asl2.0
- license:expat))))
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-fnv" ,rust-fnv)
+ ("rust-num-traits" ,rust-num-traits)
+ ("rust-serde" ,rust-serde))))
+ (home-page
+ "https://github.com/tapeinosyne/atlatl")
+ (synopsis "Double-array tries.")
+ (description "Double-array tries.")
+ (license #f)))
-(define-public rust-blas-sys-0.7
+(define-public rust-atlatl
(package
- (name "rust-blas-sys")
- (version "0.7.1")
+ (name "rust-atlatl")
+ (version "0.1.2")
(source
(origin
(method url-fetch)
- (uri (crate-uri "blas-sys" version))
- (file-name (string-append name "-" version ".crate"))
+ (uri (crate-uri "atlatl" version))
+ (file-name
+ (string-append name "-" version ".crate"))
(sha256
- (base32
- "0h14zjycwc76v15h8qll9z1xiryvmpvsb5gam97pqpdjrrwv5c8k"))))
+ (base32
+ "18kyvdm56fdb52b1sryi80xgs3nkjdylynsv324aiqnj85l1bfrj"))))
(build-system cargo-build-system)
- (home-page "https://github.com/blas-lapack-rs/blas-sys")
- (synopsis "Bindings to BLAS (Fortran)")
- (description
- "Ths package provides bindings to BLAS (Fortran).")
- (properties '((hidden? . #t)))
- (license (list license:asl2.0
- license:expat))))
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-fnv" ,rust-fnv)
+ ("rust-num-traits" ,rust-num-traits)
+ ("rust-serde" ,rust-serde))))
+ (home-page
+ "https://github.com/tapeinosyne/atlatl")
+ (synopsis "Double-array tries.")
+ (description "Double-array tries.")
+ (license #f)))
-(define-public rust-cargon-0.0
+(define-public rust-atty
(package
- (name "rust-cargon")
- (version "0.0.1")
+ (name "rust-atty")
+ (version "0.2.13")
(source
(origin
(method url-fetch)
- (uri (crate-uri "cargon" version))
- (file-name (string-append name "-" version ".crate"))
+ (uri (crate-uri "atty" version))
+ (file-name
+ (string-append name "-" version ".crate"))
(sha256
- (base32
- "1cszlab7jk736p0lb50ag4l9nv72m7j41bwrmygl0lr4iz0350w2"))))
+ (base32
+ "140sswp1bwqwc4zk80bxkbnfb3g936hgrb77g9g0k1zcld3wc0qq"))))
(build-system cargo-build-system)
- (home-page "https://github.com/bryant/argon2rs")
- (synopsis "Thin wrapper around the Argon2 C library")
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-libc" ,rust-libc)
+ ("rust-winapi" ,rust-winapi))))
+ (home-page "https://github.com/softprops/atty")
+ (synopsis "A simple interface for querying atty")
(description
- "This package provides a thin wrapper around the Argon2 C library. It is
-used in argon2rs' bench suite.")
- (properties '((hidden? . #t)))
- (license license:wtfpl2)))
+ "This package provides a simple interface for querying atty")
+ (license license:expat)))
-(define-public rust-cblas-sys-0.1
+(define-public rust-autocfg
(package
- (name "rust-cblas-sys")
- (version "0.1.4")
+ (name "rust-autocfg")
+ (version "0.1.7")
(source
(origin
(method url-fetch)
- (uri (crate-uri "cblas-sys" version))
- (file-name (string-append name "-" version ".crate"))
+ (uri (crate-uri "autocfg" version))
+ (file-name
+ (string-append name "-" version ".crate"))
(sha256
- (base32
- "0rgsn3klhhh09d8qf3b87zl4rwk93l2g0qzh9hhb0lff5kcfrzmn"))))
+ (base32
+ "1chwgimpx5z7xbag7krr9d8asxfqbh683qhgl9kn3hxk2l0djj8x"))))
(build-system cargo-build-system)
- (home-page "https://github.com/blas-lapack-rs/cblas-sys")
- (synopsis "Bindings to CBLAS (C)")
+ (arguments `(#:skip-build? #t))
+ (home-page "https://github.com/cuviper/autocfg")
+ (synopsis
+ "Automatic cfg for Rust compiler features")
(description
- "The package provides bindings to CBLAS (C).")
- (properties '((hidden? . #t)))
- (license (list license:asl2.0
- license:expat))))
+ "Automatic cfg for Rust compiler features")
+ (license #f)))
-(define-public rust-cc-1.0
+(define-public rust-backtrace
(package
- (name "rust-cc")
- (version "1.0.41")
+ (name "rust-backtrace")
+ (version "0.3.40")
(source
(origin
(method url-fetch)
- (uri (crate-uri "cc" version))
- (file-name (string-append name "-" version ".crate"))
+ (uri (crate-uri "backtrace" version))
+ (file-name
+ (string-append name "-" version ".crate"))
(sha256
- (base32
- "1zxzd559dbbf1iwdzmkj7czapzccs17kqqmsj9ayijpdix5rrbld"))))
+ (base32
+ "1skpshz0gszhpmj51p35ci9nf4nmd79s899cfrfs570dgxcpck4j"))))
(build-system cargo-build-system)
- (home-page "https://github.com/alexcrichton/cc-rs")
- (synopsis "Invoke the native C compiler")
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-addr2line" ,rust-addr2line)
+ ("rust-backtrace-sys" ,rust-backtrace-sys)
+ ("rust-cfg-if" ,rust-cfg-if)
+ ("rust-compiler-builtins"
+ ,rust-compiler-builtins)
+ ("rust-cpp-demangle" ,rust-cpp-demangle)
+ ("rust-findshlibs" ,rust-findshlibs)
+ ("rust-goblin-0.0.24" ,rust-goblin-0.0.24)
+ ("rust-libc" ,rust-libc)
+ ("rust-memmap" ,rust-memmap)
+ ("rust-rustc-demangle" ,rust-rustc-demangle)
+ ("rust-rustc-serialize" ,rust-rustc-serialize)
+ ("rust-rustc-std-workspace-core"
+ ,rust-rustc-std-workspace-core)
+ ("rust-serde" ,rust-serde)
+ ("rust-winapi" ,rust-winapi))))
+ (home-page
+ "https://github.com/rust-lang/backtrace-rs")
+ (synopsis
+ "A library to acquire a stack trace (backtrace) at runtime in a Rust program.
+")
(description
- "This package provides a build-time dependency for Cargo build scripts to
-assist in invoking the native C compiler to compile native C code into a static
-archive to be linked into Rustcode.")
- (properties '((hidden? . #t)))
- (license (list license:asl2.0
- license
This message was truncated. Download the full message here.
M
M
Martin Becze wrote on 6 Dec 2019 01:29
close
(address . 38465@debbugs.gnu.org)
db542181b1d5ef46272df59b9dfcf755@riseup.net
close
J
J
Jakub K?dzio?ka wrote on 22 Feb 2020 20:41
close 38465
(address . control@debbugs.gnu.org)
20200222194149.qjlhx7eve3fzdvvq@gravity
close 38465
thanks
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl5Rg/kACgkQ4xWnWEYT
FWT/WA//cRjcchl9cw8YvsvfQ8mOEHSh0Yyq17tWt2syA3aT5aBI/qvbKv7/2wDL
rKvkTpPGuOXnD2tsq7IX6CEu6GJdXyLUexlyw9sjWzXcIO6KIc8XO4WYFoLMYP2G
e2yw/mDEdPzmkfHKKkwMKHD3vqx8esYyEH9x2YmWBb0NizPtt5oUGSKKeoB6/qwt
uiTsMYVeGBUseFEOdal7jWF5ZkjTDyEgHc/HhqtbhA1cfE5/CDgZulDFSkeomk/2
M9B4W8PRuJ9Dv0F3Xwg0if5nw4jdKpE9XY5U3ucqEC6XjA7SyPXQlVJ4HHhv+z19
yLOKPdTPFj+r4HDEamr/SrvCoj4cKwM2+7dwZ/5Pgp4gkUx6lUojTPLNaAtdJ9mY
9uiElcnfm/n69pUO9I24k0U+5iqidbBA6zzXJCwJ+5Pk4lsCUSdoIbwm2bOPhahU
HlyDCYQC+zx1StDjVLGRqoUgGFLArnLRXZ3Obd5E/odg67amOzB0CYfrCBBnaqVm
CqzQA3+fiVoJlZlmgJMirANoRrD8MFMiBa0U9O2XP27zYgpu/9quNoi6ga6o5GNA
zPx5rOvFGl92AY+omIg0jkcSCHBD/alDXHpS6P8QQhHsQQM43goKo0sHnrB5NuCt
hvqu9oTvlNNqgwrEiRPS48HWzNO9y6ZMOvG8kPxv09EQNtCEsUE=
=XK6j
-----END PGP SIGNATURE-----


?