[PATCH 0/9] Update Jami to 20111101

  • Done
  • quality assurance status badge
Details
3 participants
  • Arun Isaac
  • Pierre Neidhardt
  • Jan
Owner
unassigned
Submitted by
Pierre Neidhardt
Severity
normal
P
P
Pierre Neidhardt wrote on 14 Nov 2019 19:04
(address . guix-patches@gnu.org)
20191114180422.5592-1-mail@ambrevar.xyz
I believe this patchset to be mostly finished.
When I start Jami however, I get the tray icon but I cannot bring up the main interface, it does not show anything.

The console output is the following:


Toggle quote (23 lines)
> (jami-gnome:4326): libnotify-WARNING **: 19:01:21.432: Failed to connect to proxy
>
> (jami-gnome:4326): Gtk-WARNING **: 19:01:21.432: Child name 'calls' not found in GtkStack
>
> (jami-gnome:4326): Gtk-CRITICAL **: 19:01:21.631: gtk_scrolled_window_add: assertion 'child_widget == NULL' failed
>
> (jami-gnome:4326): dconf-WARNING **: 19:01:21.653: failed to commit changes to dconf: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name ca.desrt.dconf was not provided by any .service files
>
> (jami-gnome:4326): dconf-WARNING **: 19:01:21.680: failed to commit changes to dconf: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name ca.desrt.dconf was not provided by any .service files
>
> (jami-gnome:4326): dconf-WARNING **: 19:01:21.680: failed to commit changes to dconf: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name ca.desrt.dconf was not provided by any .service files
>
> (jami-gnome:4326): dconf-WARNING **: 19:01:21.684: failed to commit changes to dconf: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name ca.desrt.dconf was not provided by any .service files
>
> (jami-gnome:4326): dconf-WARNING **: 19:01:21.684: failed to commit changes to dconf: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name ca.desrt.dconf was not provided by any .service files
> lookup name NOT FOUND: "" "35f9fe00a5e52f6c"
>
> (jami-gnome:4326): dconf-WARNING **: 19:01:21.701: failed to commit changes to dconf: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name ca.desrt.dconf was not provided by any .service files
> lookup name NOT FOUND: "" "35f9fe00a5e52f6c"
>
> (jami-gnome:4326): dconf-WARNING **: 19:01:21.701: failed to commit changes to dconf: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name ca.desrt.dconf was not provided by any .service files


Note that I have this issue with the non-update package as well, so I don't think this is related to the update in this patch.

Maybe because I'm on EXWM? It used to work a couple months ago though.

We might have something broken in our GTK / GNOME / dconf.
Can anyone test if Jami works on GNOME?

Jan Wielkiewicz (3):
gnu: Add resample.
gnu: Add sobjectizer.
gnu: opendht: Update to 2.0.0beta2.

Pierre Neidhardt (6):
gnu: Add restinio.
gnu: pjproject: Update to 2.9.
gnu: jami: Update to 20191101.3.67671e7.
gnu: pjproject-jami: Update to 2.9
gnu: libring: Update to 20191101.
gnu: jami: Fix wrapper.

gnu/packages/audio.scm | 24 ++++++++++
gnu/packages/cpp.scm | 32 ++++++++++++++
gnu/packages/networking.scm | 79 +++++++++++++++++++++++++++++----
gnu/packages/telephony.scm | 87 +++++++++++++++++++++++--------------
4 files changed, 180 insertions(+), 42 deletions(-)

--
2.23.0
P
P
Pierre Neidhardt wrote on 14 Nov 2019 19:06
[PATCH 2/9] gnu: Add sobjectizer.
(address . 38211@debbugs.gnu.org)
20191114180627.6593-2-mail@ambrevar.xyz
From: Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>

* gnu/packages/cpp.scm (sobjectizer): New variable.
---
gnu/packages/cpp.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 12e766761f..97b6073705 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2019 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -350,3 +351,34 @@ tools:
@item CPU checker.
@end itemize\n")
(license license:bsd-3)))
+
+(define-public sobjectizer
+ (package
+ (name "sobjectizer")
+ (version "5.6.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Stiffstream/sobjectizer.git")
+ (commit (string-append "v." version))))
+ (sha256
+ (base32 "0jfai7sqxnnjkms38krm7mssj5l79nb3pllkbyj4j581a7l5j6l5"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'change-directory
+ (lambda _
+ (chdir "dev")
+ #t)))))
+ (home-page "https://stiffstream.com/en/products/sobjectizer.html")
+ (synopsis "Cross-platform actor framework for C++")
+ (description
+ "SObjectizer is a cross-platform \"actor frameworks\" for C++.
+SObjectizer supports not only the Actor Model but also the Publish-Subscribe
+Model and CSP-like channels. The goal of SObjectizer is to simplify
+development of concurrent and multithreaded applications in C++.")
+ (license license:bsd-3)))
--
2.23.0
P
P
Pierre Neidhardt wrote on 14 Nov 2019 19:06
[PATCH 1/9] gnu: Add resample.
(address . 38211@debbugs.gnu.org)
20191114180627.6593-1-mail@ambrevar.xyz
From: Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>

* gnu/packages/audio.scm (resample): New variable.
---
gnu/packages/audio.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 15ba454edd..c59161a080 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
+;;; Copyright © 2019 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2299,6 +2300,29 @@ aimed at audio/musical applications.")
(base32
"04fajrass3ymr72flx5js5vxc601ccrmx8ny8scp0rw7j0igyjdr")))))))
+(define-public resample
+ (package
+ (name "resample")
+ (version "1.8.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ccrma.stanford.edu/~jos/gz/resample-"
+ version
+ ".tar.gz"))
+ (sha256 (base32
+ "074zj8ydp05yy1hjcglfv3hkvj4cm50f9nralka1992pm6yf8yvy"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("libtool" ,libtool)))
+ (synopsis "Real-time library for sampling rate conversion")
+ (description "The @command{resample} software package contains free
+sampling-rate conversion and filter design utilities.")
+ (home-page "https://ccrma.stanford.edu/~jos/resample/Free_Resampling_Software.html")
+ (license license:lgpl2.1+)))
+
(define-public rubberband
(package
(name "rubberband")
--
2.23.0
P
P
Pierre Neidhardt wrote on 14 Nov 2019 19:07
[PATCH 3/9] gnu: Add restinio.
(address . 38211@debbugs.gnu.org)
20191114180708.6942-1-mail@ambrevar.xyz
* gnu/packages/networking.scm (restinio): New variable.
---
gnu/packages/networking.scm | 51 +++++++++++++++++++++++++++++++++++++
1 file changed, 51 insertions(+)

Toggle diff (85 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 87cabee645..53822c427e 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2019 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2019 Tonton <tonton@riseup.net>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2019 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -72,6 +73,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages code)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cpp)
#:use-module (gnu packages crypto)
#:use-module (gnu packages curl)
#:use-module (gnu packages dejagnu)
@@ -95,6 +97,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages pretty-print)
#:use-module (gnu packages python)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
@@ -2520,6 +2523,54 @@ communication over HTTP.")
(home-page "https://github.com/Corvusoft/restbed")
(license license:agpl3+))))
+(define fmt-restinio
+ (package
+ (inherit fmt)
+ (arguments
+ '(#:configure-flags '("-DCMAKE_CXX_FLAGS=-fPIC")))))
+
+(define-public restinio
+ (package
+ (name "restinio")
+ (version "0.6.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Stiffstream/restinio.git")
+ (commit (string-append "v." version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1c25kpx652nng8m1sqf5an2c3c4g3k6zj85mkkaxzk88iwfzq1s8"))))
+ (build-system cmake-build-system)
+ (inputs ; TODO: Need to force-keep references on some inputs, e.g. boost.
+ `(("zlib" ,zlib)
+ ("catch2" ,catch-framework2)
+ ("openssl" ,openssl)
+ ("boost" ,boost)
+ ("pcre" ,pcre)
+ ("pcre2" ,pcre2)
+ ("sobjectizer" ,sobjectizer)))
+ (propagated-inputs
+ `(("asio", asio)
+ ("fmt" ,fmt-restinio)
+ ("http-parser", http-parser)))
+ (arguments
+ `(#:configure-flags '("-DRESTINIO_INSTALL=on")
+ #:tests? #f ; TODO: The tests are called from the root CMakelist, need RESTINIO_TEST=on.
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'change-directory
+ (lambda _
+ (chdir "dev/restinio")
+ #t)))))
+ (home-page "https://stiffstream.com/en/products/restinio.html")
+ (synopsis "C++14 library that gives you an embedded HTTP/Websocket server")
+ (description "RESTinio is a header-only C++14 library that gives you an embedded
+HTTP/Websocket server. It is based on standalone version of ASIO
+and targeted primarily for asynchronous processing of HTTP-requests.")
+ (license license:bsd-3)))
+
(define-public opendht
(package
(name "opendht")
--
2.23.0
P
P
Pierre Neidhardt wrote on 14 Nov 2019 19:07
[PATCH 4/9] gnu: opendht: Update to 2.0.0beta2.
(address . 38211@debbugs.gnu.org)
20191114180708.6942-2-mail@ambrevar.xyz
From: Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>

* gnu/packages/networking.scm (opendht): Update to 2.0.0beta2.
---
gnu/packages/networking.scm | 28 +++++++++++++++++++---------
1 file changed, 19 insertions(+), 9 deletions(-)

Toggle diff (60 lines)
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 53822c427e..ba48b8c6a6 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2574,7 +2574,7 @@ and targeted primarily for asynchronous processing of HTTP-requests.")
(define-public opendht
(package
(name "opendht")
- (version "1.8.1")
+ (version "2.0.0beta2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2583,26 +2583,36 @@ and targeted primarily for asynchronous processing of HTTP-requests.")
(file-name (git-file-name name version))
(sha256
(base32
- "0vninb5mak27wigajslyvr05vq7wbrwqhbr4wzl2nmqcb20wmlq2"))))
- (build-system gnu-build-system)
+ "02ix0rvvyhq22gd5djcq84qz08ji7ln93faf23b27zjzni2klzv5"))))
+ ;; Since 2.0, the gnu-build-system does not seem to work anymore, upstream bug?
+ (build-system cmake-build-system)
(inputs
`(("gnutls" ,gnutls)
("nettle" ,nettle)
("readline" ,readline)
("jsoncpp" ,jsoncpp)
- ("restbed" ,restbed)))
+ ("openssl" ,openssl)
+ ("fmt" ,fmt-restinio)))
(propagated-inputs
- `(("argon2" ,argon2) ; TODO: Needed for the pkg-config .pc file to work?
+ `(("argon2" ,argon2) ; TODO: Needed for the pkg-config .pc file to work?
("msgpack" ,msgpack))) ;included in several installed headers
(native-inputs
`(("autoconf" ,autoconf)
("pkg-config" ,pkg-config)
+ ("restinio" ,restinio)
("automake" ,automake)
- ("libtool" ,libtool)))
+ ("libtool" ,libtool)
+ ("cppunit" ,cppunit)))
(arguments
- `(#:configure-flags '("--disable-tools"
- "--disable-python"
- "--with-argon2")))
+ `(#:tests? #f ; Tests require network connection.
+ #:configure-flags
+ '(;; "-DOPENDHT_TESTS=on"
+ "-DOPENDHT_TOOLS=off"
+ "-DOPENDHT_PYTHON=off"
+ "-DOPENDHT_PROXY_SERVER=on"
+ "-DOPENDHT_PUSH_NOTIFICATIONS=on"
+ "-DOPENDHT_PROXY_SERVER_IDENTITY=on"
+ "-DOPENDHT_PROXY_CLIENT=on")))
(home-page "https://github.com/savoirfairelinux/opendht/")
(synopsis "Distributed Hash Table (DHT) library")
(description "OpenDHT is a Distributed Hash Table (DHT) library. It may
--
2.23.0
P
P
Pierre Neidhardt wrote on 14 Nov 2019 19:07
[PATCH 8/9] gnu: libring: Update to 20191101.
(address . 38211@debbugs.gnu.org)
20191114180708.6942-6-mail@ambrevar.xyz
* gnu/packages/telephony.scm (libring)[inputs]: Replace restbed with restinio,
add asio.
---
gnu/packages/telephony.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 2d6e5b2154..a3bc18f6f7 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -792,8 +792,9 @@ Initiation Protocol (SIP) and a multimedia framework.")
("libsecp256k1" ,libsecp256k1)
("python" ,python)
("python-wrapper" ,python-wrapper)
- ("restbed" ,restbed)
+ ("restinio" ,restinio)
("libx11" ,libx11)
+ ("asio" ,asio)
;; TODO: Upstream seems to rely on a custom pjproject (a.k.a. pjsip) version.
;; See https://git.jami.net/savoirfairelinux/ring-daemon/issues/24.
("pjproject" ,pjproject-jami)))
--
2.23.0
P
P
Pierre Neidhardt wrote on 14 Nov 2019 19:07
[PATCH 9/9] gnu: jami: Fix wrapper.
(address . 38211@debbugs.gnu.org)
20191114180708.6942-7-mail@ambrevar.xyz
* gnu/packages/telephony.scm (jami)[arguments]: Wrap around jami-gnome instead
of gnome-ring.
[synopsis]: Make it more sensible.
---
gnu/packages/telephony.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index a3bc18f6f7..5b6c578fce 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -897,7 +897,7 @@ This package provides a library common to all Jami clients.")
("glib:bin" ,glib "bin")
("doxygen" ,doxygen)))
(propagated-inputs
- `(("libring" ,libring) ; Contains `dring', the daemon, which is automatically by d-bus.
+ `(("libring" ,libring) ; Contains `dring', the daemon, which is automatically by d-bus.
("adwaita-icon-theme" ,adwaita-icon-theme)
("evolution-data-server" ,evolution-data-server)))
(arguments
@@ -912,10 +912,10 @@ This package provides a library common to all Jami clients.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(path (string-append (assoc-ref inputs "sqlite") "/lib")))
- (wrap-program (string-append out "/bin/gnome-ring")
+ (wrap-program (string-append out "/bin/jami-gnome")
`("LD_LIBRARY_PATH" ":" prefix (,path))))
#t)))))
- (synopsis "Distributed multimedia communications platform")
+ (synopsis "Distributed, privacy-respecting communication program")
(description "Jami (formerly GNU Ring) is a secure and distributed voice,
video and chat communication platform that requires no centralized server and
leaves the power of privacy in the hands of the user. It supports the SIP and
--
2.23.0
P
P
Pierre Neidhardt wrote on 14 Nov 2019 19:07
[PATCH 7/9] gnu: pjproject-jami: Update to 2.9
(address . 38211@debbugs.gnu.org)
20191114180708.6942-5-mail@ambrevar.xyz
* gnu/packages/telephony.scm (pjproject-jami)[arguments]: Fix flags, make
files writable, update patch set.
---
gnu/packages/telephony.scm | 36 ++++++++++++++++++++++++++----------
1 file changed, 26 insertions(+), 10 deletions(-)

Toggle diff (74 lines)
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index e6d52bc832..2d6e5b2154 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2018 Jovany Leandro G.C <bit4bit@riseup.net>
;;; Copyright © 2018 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2019 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -685,14 +686,20 @@ Initiation Protocol (SIP) and a multimedia framework.")
"--disable-openh264"
"--disable-resample"
"--disable-libwebrtc"
- ;; "-fPIC" is required for libring. Bug?
- "CFLAGS=-fPIC -DPJ_ENABLE_EXTRA_CHECK=1 -DPJ_ICE_MAX_CAND=256 -DPJ_ICE_MAX_CHECKS=1024 -DPJ_ICE_COMP_BITS=2 -DPJ_ICE_MAX_STUN=3 -DPJSIP_MAX_PKT_LEN=8000 -DPJ_ICE_ST_MAX_CAND=32"
- "CXXFLAGS=-fPIC -DPJ_ENABLE_EXTRA_CHECK=1 -DPJ_ICE_MAX_CAND=256 -DPJ_ICE_MAX_CHECKS=1024 -DPJ_ICE_COMP_BITS=2 -DPJ_ICE_MAX_STUN=3 -DPJSIP_MAX_PKT_LEN=8000 -DPJ_ICE_ST_MAX_CAND=32"
- ;; Now deviating from the rules.mak file.
- "--enable-ssl=gnutls"
- "--with-external-srtp")
+ "--with-gnutls"
+ "--with-external-srtp"
+ ;; We need -fPIC or else we get the following error when linking
+ ;; against pjproject-jami:
+ ;; relocation R_X86_64_32S against `.rodata' can not be used when
+ ;; making a shared object;
+ "CFLAGS=-fPIC"
+ "CXXFLAGS=-fPIC")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'make-git-checkout-writable
+ (lambda _
+ (for-each make-file-writable (find-files "."))
+ #t))
(add-after 'unpack 'apply-patches
(lambda* (#:key inputs #:allow-other-keys)
(let ((savoir-faire-linux-patches-directory "Savoir-faire Linux patches")
@@ -700,19 +707,28 @@ Initiation Protocol (SIP) and a multimedia framework.")
;; "ring-project/daemon/contrib/src/pjproject/rules.mak".
;; WARNING: These amount for huge changes in pjproject.
(savoir-faire-linux-patches
- '("gnutls"
+ '("fix_turn_alloc_failure"
"rfc2466"
"ipv6"
- "ice_config"
"multiple_listeners"
"pj_ice_sess"
"fix_turn_fallback"
"fix_ioqueue_ipv6_sendto"
"add_dtls_transport"
- "rfc6062")))
+ "rfc6544"
+ "ice_config"
+ "sip_config"
+ "fix_first_packet_turn_tcp"
+ "fix_ebusy_turn"
+ "ignore_ipv6_on_transport_check"
+ "fix_turn_connection_failure"
+ ;; "uwp_vs" ; for windows
+ "disable_local_resolution")))
(mkdir-p savoir-faire-linux-patches-directory)
(invoke "tar" "-xvf" (assoc-ref inputs "savoir-faire-linux-patches")
- "-C" savoir-faire-linux-patches-directory "--strip-components=5" "ring-project/daemon/contrib/src/pjproject")
+ "-C" savoir-faire-linux-patches-directory
+ "--strip-components=5"
+ "ring-project/daemon/contrib/src/pjproject")
(for-each
(lambda (file)
(invoke "patch" "--force" "-p1" "-i"
--
2.23.0
J
[PATCH 0/9] Update Jami to 20111101
(address . 38211@debbugs.gnu.org)
20191116140804.1e615e05@kompiuter
Toggle quote (4 lines)
>When I start Jami however, I get the tray icon but I cannot bring up
>the main interface, it does not show anything
> Maybe because I'm on EXWM? It used to work a couple months ago
> though.
Works on my machine with XFCE, guix pulled, upgraded and reconfigured
yesterday.


Jan Wielkiewicz
A
A
Arun Isaac wrote on 27 Nov 2019 12:24
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)(address . 38211@debbugs.gnu.org)
cu7pnhdtve2.fsf@systemreboot.net
Hi,

Patches 5 and 6 are missing in this patchset. I even checked the debbugs
web page for this bug at
there. Did you forget to send them?

Thanks,
Arun.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAl3eXNUACgkQLiXui2GA
K7NTwgf8CnE3SN22iIrPWdLjKoEMvGY61F9qBoZEd4fWO/bWixvTZ2C9BaS2fcR8
OXiYs8iA25sNTZ0Mb4pTgAuG15ATIYLlidS+atQJ015euQTgcGAqvj1V21xprU+q
3x3kTl6CvX+ASJgsZx+vrBo3OvQxF+lno/vb2ztIxnQfGgVhGuXqrGhsfIhkeWRs
KPrl49ijn7SoAz7x3bJzxEpBreGAqAqIJp/xhV9e/uIweBCrPGjh3Zf5pXRN86vj
y2A9dTKqAYqnj41YA3VZYNvHdXCEGOalUXAb4LEEcQSwAld7AXEuI1Km1COcnL6d
3v30Ji7xXrk9vrEThGPzFpxPJvAfXA==
=j3Xh
-----END PGP SIGNATURE-----

P
P
Pierre Neidhardt wrote on 27 Nov 2019 13:05
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 38211@debbugs.gnu.org)
87imn5a5iw.fsf@ambrevar.xyz
This is very strange. In my Eshell history, patch 5 and 6 are part of
the command I've used to send patches from 3 to 9. No clue why 2
patches would be missing in the middle.

Anyways, sending again.

Thanks for noticing!

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl3eZocACgkQm9z0l6S7
zH/biQf/QzBpmT8Z5/wujROgCrNaBnc8UOu9dgJEKLUWL2UAKwNVZaw9E18iMseL
v0HOYYCGJ8hgdbPBMTUxcaLho25UJm9QWzcmLdUTR1hhXzqNUy7E0FXOW3+lI57z
MV7t2IBaQIRI/VCFAHKLqqiUTVHTN7VXDApybk7rdewCKq0yoSGox47tGPB7/Wl2
FS9w78Ts1fCihLNN1H1C9vMa3hVfHbSjX30BrywdM85T90s0uYkyLl3HeGnmHEsx
C637bSLyBgqRY149qyT10eu/DTj9sa/S98OBcn+DdtDm//0/iimJAIwsVl+yDVyA
62YWaVqbF6YnHFZxE/BSkadOPDW2tA==
=80Pp
-----END PGP SIGNATURE-----

A
A
Arun Isaac wrote on 28 Nov 2019 10:47
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)(address . 38211@debbugs.gnu.org)
cu78so0z60z.fsf@systemreboot.net
Toggle quote (2 lines)
> Anyways, sending again.

I still don't see the missing patches on the debbugs page for this
bug. Did you resend them?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAl3fl7wACgkQLiXui2GA
K7MPzwf6AvtuWasHkpfjvlgptvI9wRS1ZWpH6NxwkXTaAftsBhR39Ac30vSTJqjk
N8/ExKj5mYahD/9C4CXlczj9+gJskvIVAUHEU24w80tO0/ROkqBSmolH24ZCAhMS
7HwzevK49jcouSppdggMuYbpWkDShNg/vWuPRYJgdTHd0ieXaFC/BZSjveGW65Y7
WhA1L3L3Gl1oh/Eli8gy3PcRL+mLLErrUhLIP5zJGCAoQGuf7ZaLFLFmZAa5Ad76
pQm4ud17w6yIxIcsokQpH2NNsFaT+2qBE9vJyTJ7MbZlgcrFeTypRsl49WapD/1n
34c92Z46fxtMtQ0+y0IWc27dkp0W8g==
=aLCN
-----END PGP SIGNATURE-----

P
P
Pierre Neidhardt wrote on 28 Nov 2019 11:10
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 38211@debbugs.gnu.org)
87wobk8g65.fsf@ambrevar.xyz
What the hell?!?
Yes I did. I don't get this.

I'm attaching them here, seems like git send-email fails to send those 2
patches for some reason.

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl3fnSIACgkQm9z0l6S7
zH9rhgf+MRPkvD2UOwl7NURUnGMVpNZY5ZmS8xWdSKr8Z+Ha+G4TrfclArn1wmLw
i6Nmmge865lqIYh3geI5w81qXlINp7GoRpWUQKen27cLGVfLFTCi2St1FyU3RqXS
1LV6eYfI+xP1qaQ35+sTlWz+Huo6/kDWzEpM1FyoKS/fR/6zbrgMnqXaOPIo8A/H
y4KeM/CCnDtpVY0ZGFHLGs8jCTxKLnkFucPd0FU7Fj7qHvyu1RZnv/GQ4JE3ovNl
y4ELHueg0jxXnfIfV90vdVBtk2AlUxgSvDXJFfXZmQ1aQFrwwGXhMiVeUt6gn/jN
1K4foEAzlI7RpxYRtnzTOit3y5TuRQ==
=D1Rv
-----END PGP SIGNATURE-----

From 0b9e60dbd4c3cd9a20d1273517c8a501fa252449 Mon Sep 17 00:00:00 2001
From: Pierre Neidhardt <mail@ambrevar.xyz>
Date: Thu, 14 Nov 2019 18:03:12 +0100
Subject: [PATCH 5/9] gnu: pjproject: Update to 2.9.

* gnu/packages/telephony.scm (pjproject): Update to 2.9.
---
gnu/packages/telephony.scm | 35 ++++++++++++++++++++---------------
1 file changed, 20 insertions(+), 15 deletions(-)

Toggle diff (81 lines)
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index abb68f62b2..ce65648e76 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -553,29 +553,32 @@ calls and messages")
(define-public pjproject
(package
(name "pjproject")
- (version "2.7.2")
+ (version "2.9")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "http://www.pjsip.org/release/" ;
- version "/" name "-" version ".tar.bz2"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pjsip/pjproject.git")
+ (commit "5dfa75be7d69047387f9b0436dd9492bbbf03fe4")))
(modules '((guix build utils)))
(snippet
'(begin
(let ((third-party-directories
- (list "BaseClasses" "bdsound" "bin" "g7221" "gsm"
- "ilbc" "lib" "milenage" "mp3" "speex" "srtp"
- "resample"
+ ;; Things we don't need:
+ ;; BaseClasses - contains libraries from Windows SDK
+ ;; we don't need it, at least not now.
+ (list "BaseClasses" "g7221" "ilbc" "milenage"
+ "speex" "threademulation" "yuv" "bdsound"
+ "gsm" "mp3" "resample" "srtp" "webrtc"
;; Keep only resample, build and README.txt.
"build/baseclasses" "build/g7221" "build/gsm"
- "build/ilbc" "build/milenage" "build/samplerate"
- "build/speex" "build/srtp"
- "build/resample" "build/yuv")))
+ "build/ilbc" "build/milenage" "build/resample"
+ "build/samplerate" "build/speex" "build/srtp"
+ "build/webrtc" "build/yuv")))
;; Keep only Makefiles related to resample.
- (for-each (lambda (file)
+ (for-each (lambda (directory)
(delete-file-recursively
- (string-append "third_party/" file)))
+ (string-append "third_party/" directory)))
third-party-directories)
#t)
(let ((third-party-dirs
@@ -586,9 +589,10 @@ calls and messages")
(substitute* "third_party/build/os-linux.mak"
(((string-append "DIRS += " dirs)) "")))
third-party-dirs))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0wiph6g51wanzwjjrpwsz63amgvly8g08jz033gnwqmppa584b4w"))))
+ "1ayj6n7zd5wvd1nzj2k9s57fb4ckc2fv92k5sjvhd87yg69k3393"))))
(build-system gnu-build-system)
(inputs
`(("portaudio" ,portaudio)))
@@ -598,6 +602,7 @@ calls and messages")
`(("speex" ,speex)
("libsrtp" ,libsrtp)
("gnutls" ,gnutls)
+ ("resample", resample)
("util-linux" ,util-linux)))
(native-inputs
`(("autoconf" ,autoconf)
@@ -615,7 +620,7 @@ calls and messages")
(lambda _ (invoke "make" "dep")))
(add-before 'patch-source-shebangs 'autoconf
(lambda _
- (invoke "autoconf" "-vfi" "-o"
+ (invoke "autoconf" "-v" "-f" "-i" "-o"
"aconfigure" "aconfigure.ac")))
(add-before 'autoconf 'disable-some-tests
;; Three of the six test programs fail due to missing network
--
2.23.0
From 298c0fb463306846f3e97f6a89b9a78bef036599 Mon Sep 17 00:00:00 2001
From: Pierre Neidhardt <mail@ambrevar.xyz>
Date: Thu, 14 Nov 2019 18:03:44 +0100
Subject: [PATCH 6/9] gnu: jami: Update to 20191101.3.67671e7.

* gnu/packages/telephony.scm (jami): Update to 20191101.3.67671e7.
---
gnu/packages/telephony.scm | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index ce65648e76..e6d52bc832 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -636,12 +636,12 @@ calls and messages")
Initiation Protocol (SIP) and a multimedia framework.")
(license license:gpl2+)))
-(define %jami-version "20190319.4.a16a99f")
+(define %jami-version "20191101.3.67671e7")
(define* (jami-source #:key without-daemon)
(origin
(method url-fetch)
- (uri (string-append "http://dl.jami.net/ring-release/tarballs/ring_"
+ (uri (string-append "https://dl.jami.net/ring-release/tarballs/ring_"
%jami-version
".tar.gz"))
(modules '((guix build utils)))
@@ -652,7 +652,7 @@ Initiation Protocol (SIP) and a multimedia framework.")
#f))
(sha256
(base32
- "1c6n6sm7skw83v25g33g4jzbragz9j4przbzaz7asxw54jy33dwl"))))
+ "0kw172w2ccyz438kf5xqw14nhfm4xk6a2libnzib9j2wvhlpf4q0"))))
(define-public pjproject-jami
(package
@@ -699,7 +699,6 @@ Initiation Protocol (SIP) and a multimedia framework.")
;; Comes from
;; "ring-project/daemon/contrib/src/pjproject/rules.mak".
;; WARNING: These amount for huge changes in pjproject.
- ;; Particularly, they add support for GnuTLS.
(savoir-faire-linux-patches
'("gnutls"
"rfc2466"
--
2.23.0
A
A
Arun Isaac wrote on 30 Nov 2019 20:04
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)(address . 38211@debbugs.gnu.org)
cu7a78dmbhq.fsf@systemreboot.net
Toggle quote (2 lines)
> I believe this patchset to be mostly finished.

This patchset builds successfully. I am able to bring up the main jami
GUI. But, it tries to connect to the Jami daemon, fails and quits
immediately. I get a message box which says "Could not re-connect to the
Jami daemon (dring). Jami will now quit."

Am I missing something? Do I need to start dring somehow?

Toggle quote (2 lines)
> Maybe because I'm on EXWM? It used to work a couple months ago though.

I'm also on EXWM. I don't see any dconf errors in my console
output. Instead, I see the following.

** (jami-gnome:21234): WARNING **: 00:13:08.460: dring has possibly crashed, or has been killed... will wait 2.5 seconds and try to r
econnect

** (jami-gnome:21234): WARNING **: 00:13:10.977: Error : dring is not available, make sure it is running

** (jami-gnome:21234): WARNING **: 00:13:10.977: Error : dring is not available, make sure it is running

** (jami-gnome:21234): WARNING **: 00:13:10.977: could not reconnect to the daemon
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAl3ivVEACgkQLiXui2GA
K7MUVgf/abpAsZMF4FBqdcSXAnrZyPIJytayzR+NhGmsBNOuJn+LlZ4eWCdttNjD
Qvr1zmXfpHXIj4s3RLqyXMyRE3W8CSWYGFQ1eWlhCgxTA6tRKd3H25VHyudjvZXs
JGpQDGArmE9lFnPFkdVRv6cHa3wD8Jj7hiiLxBF5uRqb1ASwqOSzrsd9OwTmf+N+
8UG5ZrumrYUkjDkpiI8VEIlmt/94RJ0NF0jm/ymIHR6r0RirG1XZLxVDxDST+Jz7
n+4AMVa/4qJvCYHl8gdjicP3VkqKCzWFdvAcFfc46KYFJP1dDRtt1VVrKPL1KEpk
AHbV3DJ0XZW5mI06g2PyTxnDUhStSA==
=IPZ1
-----END PGP SIGNATURE-----

P
P
Pierre Neidhardt wrote on 30 Nov 2019 21:02
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 38211@debbugs.gnu.org)
87y2vxnnep.fsf@ambrevar.xyz
This is great news!

You should start ring with ring.cx, _not_ gnome-ring.

If it still does not work, try launching dring:

/gnu/store/v9scpdy0zip94gsfl75zlw1alvgi6xkq-libring-20190319.4.a16a99f/lib/ring/dring -dcp

Now if it works for you I really wonder what's wrong with the GUI on my end...

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl3iyr4ACgkQm9z0l6S7
zH+yaAf/aod+DWuPqUJFtrkI1ZA3dBx4u9rFFDTm2Nn6rBc0QwOZhEtrzj6VWV6m
ta1ekO3oQz0SDcoivuULnOWJ5hSTc5ZBBGtTZhelZYv0I1oI3QSMP8mi7r8Pw5s8
G7kEjXSufC5v/JvldH8W55fbDt7k23uHr7WFKe3yqCkwvuMQ8OSYsi/kkQLzxasJ
cDkwevZPKewDbDSuGdB9OZpnz5tvrYoDumwjaoFkvdS4DVjf45zBucaOEvJ/iKra
Sk5cKDqRoS+n49Vpx3D1ZqnJleV3XKwjcCnc9Gz6WGDaEMZxdwXJH3bSNOW9VE3+
Ku4KBmI3vyqKytiV+WbOdiL+38VJ5A==
=K+yg
-----END PGP SIGNATURE-----

A
A
Arun Isaac wrote on 1 Dec 2019 12:16
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)(address . 38211@debbugs.gnu.org)
cu7zhgcl2id.fsf@systemreboot.net
Toggle quote (6 lines)
> You should start ring with ring.cx, _not_ gnome-ring.
>
> If it still does not work, try launching dring:
>
> /gnu/store/v9scpdy0zip94gsfl75zlw1alvgi6xkq-libring-20190319.4.a16a99f/lib/ring/dring -dcp

It works for me now, but only after launching dring manually like you
said. Running ring.cx without starting dring failed.

Thank you very much for your work on jami! :-) Jami is of great
importance to the decentralized internet, and it's nice to have it in
Guix.

Toggle quote (3 lines)
> Now if it works for you I really wonder what's wrong with the GUI on
> my end...

This is strange, but I think someone who actually understands dconf and
dbus should comment on this. I'm sorry, I don't know enough.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAl3joQsACgkQLiXui2GA
K7OgFwf/RS62oOxXE44EKuzrYx2kU1hCCgxvsPoApBrUQcXQRHOpibML2otWj+lf
sr1GJHf0OG+RhQZOxzWrpJNq9pINMS2GZtjuNQHoUy/oK+4sDK4jTMMQAKZdkJ07
ig2aMi7h2WdR4xn9xDtvf8J2N1GsGMLdGBfV/Oa1hX6INVGj9oJcate6s4GjFUwQ
oF8sy6ptjVA70Wof/wVW2SsQmHuSmtWmiJerWO5HDamT76GgBdFbpsz8s9NUlaQe
kYsVMw2b7hrI3AwL3rdFcq0EVljca2SGn1sNYS7i248ozqFDEWM18tWxc/hCg65z
ddn3auNNIA3LupPgmMGxGa4as25OrA==
=Qlxu
-----END PGP SIGNATURE-----

P
P
Pierre Neidhardt wrote on 1 Dec 2019 13:24
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 38211@debbugs.gnu.org)
87pnh8nsi4.fsf@ambrevar.xyz
I'll merge the patch then, thanks for testing!

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl3jsPMACgkQm9z0l6S7
zH+c+Af7BPmUU/I2n6rbRgSXguEQtJFr/iVE353vopOqORDpJe2X87dscqu01wPO
viJ1tzuMh94tK8bt60/QyP47DupR9/XQB9A5YuLS/MgYz5dF2tvgmkDzKHPoYmSz
asD+BjCTBpjvIHzFzxJEZvtoQ9Nj7rQc0jnWp+JXuqIhUzvBnDG/Np3zWFqPwX0i
uCKPinPwXeSoYhIKiK7K4a8Sob6CHnlorbCPKbwNpLwmUoFJsw9qofqSJheWXCZd
RZjxSL3Bko3XvxWMBqGvrtuBQuVfvHriIogDbpg4wufTYFbr00SORIJQJ8fyiJoQ
2C7SOcXdugiYOdXv25n8985XZyv17g==
=DMDm
-----END PGP SIGNATURE-----

P
P
Pierre Neidhardt wrote on 1 Dec 2019 13:46
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 38211@debbugs.gnu.org)
87d0d82oya.fsf@ambrevar.xyz
Merged.

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl3jti0ACgkQm9z0l6S7
zH/40AgAg5roogz8pS3DpAjq0trvo9LF38xu+Xm9BL9v+67AyiEy7ZO4+FO6f4pv
QaUIVqvZ3pD01CC0ILTemXD3jcQLKeFgxxTdYzjhRoVs+/PdVBvcuMZtx7xBopNc
fRtA9BAVkXXekbdAuTXwM+mjAW+H/r0bi5uvaIlBuHbqIzN3NAP+/hPGBcjZCnQy
qGgkoygoATQXbjFH1tE8M5kngH8FV+XUQBUb3HjyNFiTrEP2K2059xmrBbU2GI0j
/XDCqWt/T6XrbEXIP9DqJo/l4fQPZPQJEFqS0uQdlZ6MDE7vb6A4a1120hnvck/Q
jWn9vvHZhjki/ou+HRrEo0MZ+zsITA==
=e5ey
-----END PGP SIGNATURE-----

P
P
Pierre Neidhardt wrote on 1 Dec 2019 13:47
control message for bug #38211
(address . control@debbugs.gnu.org)
87blss2oxf.fsf@ambrevar.xyz
close 38211
quit
?