patchelf: Assertion failed when setting interpreter

  • Done
  • quality assurance status badge
Details
3 participants
  • Efraim Flashner
  • Ivan Vilata i Balaguer
  • Ludovic Courtès
Owner
unassigned
Submitted by
Ivan Vilata i Balaguer
Severity
normal
I
I
Ivan Vilata i Balaguer wrote on 4 Nov 2019 05:56
(address . bug-guix@gnu.org)
20191104045614.GI17621@sax.terramar.selidor.net
Hi, I'm using patchelf 0.8 from Guix commit 7f81cce3 on Debian Sid. When
trying to patch the `go` binary from
error:

ivan@sax /tmp/tmps2Cv6w [env]$ patchelf --print-interpreter $SHELL
/gnu/store/ahqgl4h89xqj695lgqvsaf6zh2nhy4pj-glibc-2.29/lib/ld-linux-x86-64.so.2
ivan@sax /tmp/tmps2Cv6w [env]$ patchelf --set-interpreter $(patchelf --print-interpreter $SHELL) /tmp/tmps2Cv6w/golang/bin/go
patchelf: patchelf.cc:701: void ElfFile<Elf_Ehdr, Elf_Phdr, Elf_Shdr, Elf_Addr, Elf_Off, Elf_Dyn, Elf_Sym>::rewriteSectionsExecutable() \
[with Elf_Ehdr = Elf64_Ehdr; Elf_Phdr = Elf64_Phdr; Elf_Shdr = Elf64_Shdr; Elf_Addr = long unsigned int; Elf_Off = long unsigned int; \
Elf_Dyn = Elf64_Dyn; Elf_Sym = Elf64_Sym]: Assertion `(off_t) rdi(hdr->e_shoff) >= startOffset' failed.
Aborted

(I know Go is packed for Guix, my need arises from trying to build an
unrelated project which relies on binary Go for its build process.)

It may be the problem described here regarding Go-produced binaries:
patchelf 0.10, and indeed trying the same operation with patchelf 0.10 from
Debian does succeed to patch the binary.

As an aside, I tried to build `--with-source` for 0.10 and it succeeds to
compile, but tests fail to pass.

Thank you very much!

--
Ivan Vilata i Balaguer -- https://elvil.net/
L
L
Ludovic Courtès wrote on 5 Nov 2019 15:12
(name . Ivan Vilata i Balaguer)(address . ivan@selidor.net)(address . 38055@debbugs.gnu.org)
87muda1kfs.fsf@gnu.org
Hi Ivan,

Ivan Vilata i Balaguer <ivan@selidor.net> skribis:

Toggle quote (13 lines)
> Hi, I'm using patchelf 0.8 from Guix commit 7f81cce3 on Debian Sid. When
> trying to patch the `go` binary from
> <https://dl.google.com/go/go1.12.3.linux-amd64.tar.gz>, I get the following
> error:
>
> ivan@sax /tmp/tmps2Cv6w [env]$ patchelf --print-interpreter $SHELL
> /gnu/store/ahqgl4h89xqj695lgqvsaf6zh2nhy4pj-glibc-2.29/lib/ld-linux-x86-64.so.2
> ivan@sax /tmp/tmps2Cv6w [env]$ patchelf --set-interpreter $(patchelf --print-interpreter $SHELL) /tmp/tmps2Cv6w/golang/bin/go
> patchelf: patchelf.cc:701: void ElfFile<Elf_Ehdr, Elf_Phdr, Elf_Shdr, Elf_Addr, Elf_Off, Elf_Dyn, Elf_Sym>::rewriteSectionsExecutable() \
> [with Elf_Ehdr = Elf64_Ehdr; Elf_Phdr = Elf64_Phdr; Elf_Shdr = Elf64_Shdr; Elf_Addr = long unsigned int; Elf_Off = long unsigned int; \
> Elf_Dyn = Elf64_Dyn; Elf_Sym = Elf64_Sym]: Assertion `(off_t) rdi(hdr->e_shoff) >= startOffset' failed.
> Aborted

I think it’s a bug you should report upstream to the PatchELF
maintainers; it’s probably not Guix-specific.

Thanks,
Ludo’.
E
E
Efraim Flashner wrote on 5 Nov 2019 17:18
(name . Ludovic Courtès)(address . ludo@gnu.org)
20191105161822.GG14453@E5400
On Tue, Nov 05, 2019 at 03:12:23PM +0100, Ludovic Courtès wrote:
Toggle quote (21 lines)
> Hi Ivan,
>
> Ivan Vilata i Balaguer <ivan@selidor.net> skribis:
>
> > Hi, I'm using patchelf 0.8 from Guix commit 7f81cce3 on Debian Sid. When
> > trying to patch the `go` binary from
> > <https://dl.google.com/go/go1.12.3.linux-amd64.tar.gz>, I get the following
> > error:
> >
> > ivan@sax /tmp/tmps2Cv6w [env]$ patchelf --print-interpreter $SHELL
> > /gnu/store/ahqgl4h89xqj695lgqvsaf6zh2nhy4pj-glibc-2.29/lib/ld-linux-x86-64.so.2
> > ivan@sax /tmp/tmps2Cv6w [env]$ patchelf --set-interpreter $(patchelf --print-interpreter $SHELL) /tmp/tmps2Cv6w/golang/bin/go
> > patchelf: patchelf.cc:701: void ElfFile<Elf_Ehdr, Elf_Phdr, Elf_Shdr, Elf_Addr, Elf_Off, Elf_Dyn, Elf_Sym>::rewriteSectionsExecutable() \
> > [with Elf_Ehdr = Elf64_Ehdr; Elf_Phdr = Elf64_Phdr; Elf_Shdr = Elf64_Shdr; Elf_Addr = long unsigned int; Elf_Off = long unsigned int; \
> > Elf_Dyn = Elf64_Dyn; Elf_Sym = Elf64_Sym]: Assertion `(off_t) rdi(hdr->e_shoff) >= startOffset' failed.
> > Aborted
>
> I think it’s a bug you should report upstream to the PatchELF
> maintainers; it’s probably not Guix-specific.
>

On the other hand, if I were the patchelf maintainers, I'd suggest
upgrading our package from 0.8 to a newer version.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl3BoMsACgkQQarn3Mo9
g1HZ6A/+NFxHrliqlxDzdAAOwYDGYRiOIgP0B7RyQSo0RC84f49Hb/hpGBIcwoJb
DjJh+/KI28fsVSo2KppcSOhsB+x9uVxOTYUZnRmWNDQtN8njTEm7bkuy1QXY5h3e
P7VgcdecTAjpmOJp1OLsPxigdIFK8wYkIga+FnUCM2C53Dl9aOBVI+XGH/4V4Klr
vZ7GvJNaGhbot5WBAWca7LMXryz8LmWdhgs2yZJOpbnYmSmKapXxyl/TH7Tsq/xI
+7HjXqYxiGgjNbu7z2FYzvS3+8b0nXX1c+yJ98C+mCG/WvFdr/bl35Fd0hKqRsK7
ms6IedVtuwUXy52XTMFCy09xciHVc5avzk9OIUBeOsJ/dHb7CveSRC7wReUjXr4c
35OEljICl3/915tHs5oyjg31gu/fD3AvP0Y64WMifwFNsJtEIGs2etcSrFY1yJ5H
c7qbpqC294L3upywzZHpxjgaXA93HgTONmeTxqG0FE4C+8HU3tCgUKSQ/p3k90la
LeYXKj3RjBBfmW9Dx52+FWUWOFcoLjx/wA1I37tVA/2mnqPophXks7eTyy5xN+B0
q1DXHTe5mgyem9anV2m5hzT9SPhkl8JJWZ8pVMwNNZXf8oWOaVD6Jah14GmqIT2z
gDWaNDFX1EV+DwjO8fzmMkgpV/P5/ANahcVtZs7w47+S8Hfr+7w=
=vqlY
-----END PGP SIGNATURE-----


I
I
Ivan Vilata i Balaguer wrote on 6 Nov 2019 22:42
(name . Efraim Flashner)(address . efraim@flashner.co.il)
20191106214221.GL17621@sax.terramar.selidor.net
Efraim Flashner (2019-11-05 18:18:22 +0200) wrote:

Toggle quote (23 lines)
> On Tue, Nov 05, 2019 at 03:12:23PM +0100, Ludovic Courtès wrote:
> >
> > Ivan Vilata i Balaguer <ivan@selidor.net> skribis:
> >
> > > Hi, I'm using patchelf 0.8 from Guix commit 7f81cce3 on Debian Sid.
> > > When trying to patch the `go` binary from
> > > <https://dl.google.com/go/go1.12.3.linux-amd64.tar.gz>, I get the
> > > following error:
> > >
> > > ivan@sax /tmp/tmps2Cv6w [env]$ patchelf --print-interpreter $SHELL
> > > /gnu/store/ahqgl4h89xqj695lgqvsaf6zh2nhy4pj-glibc-2.29/lib/ld-linux-x86-64.so.2
> > > ivan@sax /tmp/tmps2Cv6w [env]$ patchelf --set-interpreter $(patchelf --print-interpreter $SHELL) /tmp/tmps2Cv6w/golang/bin/go
> > > patchelf: patchelf.cc:701: void ElfFile<Elf_Ehdr, Elf_Phdr, Elf_Shdr, Elf_Addr, Elf_Off, Elf_Dyn, Elf_Sym>::rewriteSectionsExecutable() \
> > > [with Elf_Ehdr = Elf64_Ehdr; Elf_Phdr = Elf64_Phdr; Elf_Shdr = Elf64_Shdr; Elf_Addr = long unsigned int; Elf_Off = long unsigned int; \
> > > Elf_Dyn = Elf64_Dyn; Elf_Sym = Elf64_Sym]: Assertion `(off_t) rdi(hdr->e_shoff) >= startOffset' failed.
> > > Aborted
> >
> > I think it’s a bug you should report upstream to the PatchELF
> > maintainers; it’s probably not Guix-specific.
>
> On the other hand, if I were the patchelf maintainers, I'd suggest
> upgrading our package from 0.8 to a newer version.

Yeah, as I mentioned in the original mail that particular problem does indeed
seem to be fixed in 0.10. However when I try to build that source with `guix
build patchelf --with-source=…`, tests fail.

If I run `guix environment -C --pure patchelf` then unpack and build the
source, the only test that actually fails is `no-rpath.sh`. If I run `sh -x
no-rpath.sh` I get this:

```
++ basename no-rpath.sh .sh
+ SCRATCH=scratch/no-rpath
+ rm -rf scratch/no-rpath
+ mkdir -p scratch/no-rpath
+ cp no-rpath scratch/no-rpath/
++ ../src/patchelf --print-rpath scratch/no-rpath/no-rpath
+ oldRPath=/gnu/store/ahqgl4h89xqj695lgqvsaf6zh2nhy4pj-glibc-2.29/lib:/gnu/store/2plcy91lypnbbysb18ymnhaw3zwk8pg1-gcc-7.4.0-lib/lib:/gnu/store/2plcy91lypnbbysb18ymnhaw3zwk8pg1-gcc-7.4.0-lib/lib/gcc/x86_64-unknown-linux-gnu/7.4.0/../../..:/gnu/store/dcrwf5irwh39knld1wim1qkny659af9g-profile/lib
+ test -n /gnu/store/ahqgl4h89xqj695lgqvsaf6zh2nhy4pj-glibc-2.29/lib:/gnu/store/2plcy91lypnbbysb18ymnhaw3zwk8pg1-gcc-7.4.0-lib/lib:/gnu/store/2plcy91lypnbbysb18ymnhaw3zwk8pg1-gcc-7.4.0-lib/lib/gcc/x86_64-unknown-linux-gnu/7.4.0/../../..:/gnu/store/dcrwf5irwh39knld1wim1qkny659af9g-profile/lib
+ exit 1
```

To succeed, the output of `…/patchelf --print-rpath …/no-rpath`
(i.e. `oldRPath`) should be empty. I'm not that familiar with Guix's GNU
build system, but is that at all possible under Guix? I mean, maybe the test
is pointless or must be altered in some Guix-specific way for the `no-rpath`
binary not to have an rpath.

Cheers,

--
Ivan Vilata i Balaguer -- https://elvil.net/
L
L
Ludovic Courtès wrote on 7 Nov 2019 21:55
(name . Ivan Vilata i Balaguer)(address . ivan@selidor.net)
87zhh7mmoo.fsf@gnu.org
Bona nit!

Ivan Vilata i Balaguer <ivan@selidor.net> skribis:

Toggle quote (26 lines)
> Yeah, as I mentioned in the original mail that particular problem does indeed
> seem to be fixed in 0.10. However when I try to build that source with `guix
> build patchelf --with-source=…`, tests fail.
>
> If I run `guix environment -C --pure patchelf` then unpack and build the
> source, the only test that actually fails is `no-rpath.sh`. If I run `sh -x
> no-rpath.sh` I get this:
>
> ```
> ++ basename no-rpath.sh .sh
> + SCRATCH=scratch/no-rpath
> + rm -rf scratch/no-rpath
> + mkdir -p scratch/no-rpath
> + cp no-rpath scratch/no-rpath/
> ++ ../src/patchelf --print-rpath scratch/no-rpath/no-rpath
> + oldRPath=/gnu/store/ahqgl4h89xqj695lgqvsaf6zh2nhy4pj-glibc-2.29/lib:/gnu/store/2plcy91lypnbbysb18ymnhaw3zwk8pg1-gcc-7.4.0-lib/lib:/gnu/store/2plcy91lypnbbysb18ymnhaw3zwk8pg1-gcc-7.4.0-lib/lib/gcc/x86_64-unknown-linux-gnu/7.4.0/../../..:/gnu/store/dcrwf5irwh39knld1wim1qkny659af9g-profile/lib
> + test -n /gnu/store/ahqgl4h89xqj695lgqvsaf6zh2nhy4pj-glibc-2.29/lib:/gnu/store/2plcy91lypnbbysb18ymnhaw3zwk8pg1-gcc-7.4.0-lib/lib:/gnu/store/2plcy91lypnbbysb18ymnhaw3zwk8pg1-gcc-7.4.0-lib/lib/gcc/x86_64-unknown-linux-gnu/7.4.0/../../..:/gnu/store/dcrwf5irwh39knld1wim1qkny659af9g-profile/lib
> + exit 1
> ```
>
> To succeed, the output of `…/patchelf --print-rpath …/no-rpath`
> (i.e. `oldRPath`) should be empty. I'm not that familiar with Guix's GNU
> build system, but is that at all possible under Guix? I mean, maybe the test
> is pointless or must be altered in some Guix-specific way for the `no-rpath`
> binary not to have an rpath.

Guix’ ‘gcc’ automatically adds RUNPATH entries to glibc/lib and
gcc:lib/lib:

Toggle snippet (4 lines)
$ gcc -dumpspecs |grep -e -rpath
%{!mandroid|tno-android-ld:-L/gnu/store/ahqgl4h89xqj695lgqvsaf6zh2nhy4pj-glibc-2.29/lib %{!static:-rpath=/gnu/store/ahqgl4h89xqj695lgqvsaf6zh2nhy4pj-glibc-2.29/lib %{!static-libgcc:-rpath=/gnu/store/347y0zr1a9s2f5pkcncgi3gd0r33qq81-gcc-9.2.0-lib/lib -lgcc_s}} %{pthread:-lpthread} %{shared:-lc} %{!shared:%{profile:-lc_p}%{!profile:-lc}};:%{shared:-lc} %{!shared:%{profile:-lc_p}%{!profile:-lc}} %{!static: -ldl}}

The code that modifies GCC to do that is in (gnu packages gcc).

Thus, RUNPATH is never empty, and the test above is bound to fail.

Two possibilities: change the test to ensure that ‘--print-rpath’
returns precisely libc/lib:gcc/lib, or, if that turns out to be tricky,
skip the test (in both cases, add a comment linking to this discussion
for future reference.)

How does that sound?

Thank you!

Ludo’.
E
E
Efraim Flashner wrote on 9 Nov 2019 19:25
(no subject)
(name . Ludovic Courtès)(address . ludo@gnu.org)
20191109182510.GA3954@E5400
guix-patches@gnu.org
Bcc:
Subject: Re: bug#38055: patchelf: Assertion failed when setting interpreter
Reply-To:
In-Reply-To: <87zhh7mmoo.fsf@gnu.org>
X-PGP-Key-ID: 0x41AAE7DCCA3D8351
X-PGP-Fingerprint: A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
I put together a patch to bump patchelf to 0.10. 'guix refresh -l
patchelf' says there's 614 dependent packages, but 'git grep ,patchelf'
and 'git grep guix\ build\ rpath' it looks like there's julia and 613
haskell packages.


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl3HBIYACgkQQarn3Mo9
g1FAdQ/9FfEXXZeUzthfZinUEVdX77z+XUPlcWXkwnmdfJZO0tJVdUqfS58edp3r
7Ttxh/ApYJ2sQX30BZINvD6kIvrLVFEqfVjUHjhk23QoNJo9qO6FPXJ2yaP+Ama0
lefX52cw1x6ibJFDiZQvRgsQakJz0JTu96777HZvIG50ZsJ8E7hvirIGl2ut881L
BYN2Q1JBARttfRzxkSm9ZBMOvQOjqPgmSTGHnrRB7Jh5x5nHMXQrcVOcysKKctDy
9VhLWzQhR6Rbnv347aB9d+Q2xyZeVJDH/CE2fv9JRsW3M43IqhPipxCIy+dxa/yJ
AOBGDWubP7GqREPo/VwjEzzutW1bRqwuyaequX/T5rcnYM1rUoA5/YPc4iL09XPf
T8iWKX8OAqM9Ypr0XmmLwZudzc6aAGtvPA5g8i2/nHUxszkig/Cz4jjVsTHlQZKC
JAKAvRqpmd84xht450HCmA+FmSyiDeENqTforiSOJW9eQRdTcoE0RiNL7VJNTI2m
1fAb8m3MEdGdSHte0L999TT5EG3ITebQsM/AjpJGb95kfWXT0iTWx0Y9EazKKfuk
t7SVpxZ2v+hvgjeBtQ40qhvqpi4kzInUVIPtKgOS1h194M2AQpsqx5UpOP99beg8
jOqar6t78dP9/URIoVs3jf9WWbA/QgTZCZ2jLMVjUGkml+pVglk=
=GFta
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 10 Nov 2019 15:14
Re: none
(name . Efraim Flashner)(address . efraim@flashner.co.il)
87k1873jjh.fsf@gnu.org
Hi,

Efraim Flashner <efraim@flashner.co.il> skribis:

Toggle quote (14 lines)
> From 2db156170a24fea36aced781faf96c839a3b7d15 Mon Sep 17 00:00:00 2001
> From: Efraim Flashner <efraim@flashner.co.il>
> Date: Sat, 9 Nov 2019 20:19:11 +0200
> Subject: [PATCH] gnu: patchelf: Update to 0.10.
>
> * gnu/packages/elf.scm (patchelf): Update to 0.10.
> [source]: Remove patches.
> [arguments]: Remove patch/rework-for-arm phase. Add phase to modify
> tests for our modified GCC package.
> [native-inputs]: Add gcc:lib.
> * gnu/packages/patches/patchelf-page-size.patch,
> * gnu/packages/patches/patchelf-rework-for-arm.patch: Remove files.
> * gnu/local.mk (dist_patch_DATA): Remove them.

[...]

Toggle quote (10 lines)
> + (modify-phases %standard-phases
> + (add-after 'unpack 'fix-tests
> + ;; Our GCC code ensures that RUNPATH is never empty, it includes
> + ;; at least glibc/lib and gcc:lib/lib.
> + (lambda* (#:key inputs #:allow-other-keys)
> + (substitute* "tests/no-rpath.sh"
> + (("^if test.*") "")
> + (("/xxxxxxxxxxxxxxx") (string-append (assoc-ref inputs "gcc:lib")
> + "/lib")))

Could you complement the above comment with something like: “Thus,
disable the test that checks for an empty RUNPATH.”, or whatever is
appropriate? That will clarify the intent because it’s not obvious what
the substitution is doing if you don’t have the file at hand. :-)

Otherwise LGTM, thanks for addressing this issue!

Ludo’.
E
E
Efraim Flashner wrote on 11 Nov 2019 10:27
(name . Ludovic Courtès)(address . ludo@gnu.org)
20191111092730.GF3954@E5400
Some inline comments added. Patch pushed.

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl3JKXUACgkQQarn3Mo9
g1G7sg/+KBFQJQYpGkmtmMhCWTUMKqRkERNgQgmwRJzn+yie1tXuc89cFMLwp9Mg
yjQT04EOMPCre+SvdczMGJeDav2ulqvNrLSLZN+SWDKxP6vx5F7iNK7JNmxGGj6J
KAe8cdivDzBxkL+wnqe+sSYtbV56EReHCAwnGsLXIe9/fJGBBUtA2PI1fbDQyxNB
UdxcMRePR195yr3H9+Vn16WqHeOqnRx1ifFlkLaolh6bsjtQEZQ4hfmaZgEaX9e3
Fvlto59vo3zakhU+IWvgbKxMqzLC3uWDW3qviU3uJhg6MhR7KZ7MPwmrcOQejKX0
OKa1mfKJc2oCHUBFHpz/pDMunXFkFZg2dXSUTr20YqiJLLf73l03s7UH4/Vr2ehH
zeIHjMQWVmEdl3iKA9+So6dtgwySuWuyzq2+/ezR9Y/wcH5+SfZnIycuADuwNrka
OdTYxdYAv207YAel/czmRojzi2mCKOCOssZTk0RNNt5N5IZnzfLTMVhuPRM0/Cxn
Xxhgc6Ikx0PXsD7Ql6WF0PPVGiAvcBJ+yZMKI6TlogqSXQiQvhsmKjpLDWZmrull
ayn6qPCj90wjuyDxE71agsOVfX9ZSZgSNVq1Sh7UUiAhLiEBVLax8vy5ul3k56yK
h7jM2kp0KMnFvC7Wh3r3dthITNJktfZ2OXb0otz/cv5RaJ57hYk=
=Zsjf
-----END PGP SIGNATURE-----


Closed
I
I
Ivan Vilata i Balaguer wrote on 11 Nov 2019 16:10
(name . Efraim Flashner)(address . efraim@flashner.co.il)
20191111151010.GO17621@sax.terramar.selidor.net
Efraim Flashner (2019-11-11 11:27:30 +0200) wrote:

Toggle quote (2 lines)
> Some inline comments added. Patch pushed.

Wow, thank you so much for taking care of this! I did prepare a patch on
Friday but I didn't have the time to send it, plus it pales in comparison to
Efraim's and it also had the `ipfs` binary segfault after patching. I'm still
attaching it in case you're curious (of course I don't expect any of it to get
merged�`;)`).

I'll try to find a moment to test your patch and see if the `ipfs` binary
doesn't segfault, then report back.

Thanks again!

--
Ivan Vilata i Balaguer -- https://elvil.net/
Closed
I
I
Ivan Vilata i Balaguer wrote on 11 Nov 2019 16:30
(name . Ivan Vilata i Balaguer)(address . ivan@selidor.net)
20191111153030.GP17621@sax.terramar.selidor.net
Ivan Vilata i Balaguer (2019-11-11 10:10:10 -0500) wrote:

Toggle quote (3 lines)
> […] I'm still attaching it in case you're curious (of course I don't expect
> any of it to get merged `;)`). […]

Forgot the attachment… `:P`

--
Ivan Vilata i Balaguer -- https://elvil.net/
Closed
I
I
Ivan Vilata i Balaguer wrote on 12 Nov 2019 06:19
(name . Ivan Vilata i Balaguer)(address . ivan@selidor.net)
20191112051931.GQ17621@sax.terramar.selidor.net
Ivan Vilata i Balaguer (2019-11-11 10:10:10 -0500) wrote:

Toggle quote (7 lines)
> Efraim Flashner (2019-11-11 11:27:30 +0200) wrote:
>
> > Some inline comments added. Patch pushed.
>
> […] I'll try to find a moment to test your patch and see if the `ipfs`
> binary doesn't segfault, then report back. […]

I tried your patch, the following command in a pure container environment:

$ patchelf --set-interpreter "$(patchelf --print-interpreter /bin/sh)" /path/to/bin/go

does not trigger the assertion error (both `--set-interpreter` and
`--set-rpath` suffered from the same failure), and the resulting `go` binary
can be executed without issues.

Thank you very much for fixing this! `:)`

--
Ivan Vilata i Balaguer -- https://elvil.net/
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38055@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38055
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch