GNOME night light doesn't change colors with GNOME 3.30
(address . bug-guix@gnu.org)
Hi Guix,
After the recent core-updates merge which included GNOME 3.30, it appears
the the night light feature, which makes the screen colors warmer, doesn't
seem to work. It appears to activate fine via the setting and via the
timer, but the screen colors don't change. It also appears that colord
isn't running, which I suspect is related.
$ guix describe
Generation 74 Oct 18 2019 21:59:02 (current)
guix 545ff7b
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: 545ff7b7841ddae9c73345ab5c6af42aadbda6e3
;; config.scm
;; This is an operating system configuration template
;; for a "desktop" setup with GNOME and Xfce where the
;; root partition is encrypted with LUKS.
(use-modules (gnu) (gnu system nss) (gnu services xorg)
(gnu packages linux))
(use-service-modules desktop)
(use-package-modules certs gnome scanner security-token)
(operating-system
(host-name "alperton")
(timezone "America/New_York")
(locale "en_US.utf8")
(bootloader (bootloader-configuration
(bootloader grub-bootloader)
(target "/dev/sda")))
;; Specify a mapped device for the encrypted root partition.
;; The UUID is that returned by 'cryptsetup luksUUID'.
(mapped-devices
(list (mapped-device
(source (uuid "f7776767-70c9-44e3-9973-c1334d301348"))
(target "alperton_root")
(type luks-device-mapping))))
(file-systems (cons
(file-system
(device (file-system-label "alperton_root"))
(mount-point "/")
(type "ext4")
(dependencies mapped-devices))
%base-file-systems))
(swap-devices (list "/root/swap"))
(users (cons (user-account
(name "jackhill")
(comment "Jack Hill")
(group "users")
(supplementary-groups '("wheel" "netdev"
"audio" "lp" "video"))
(home-directory "/home/jackhill"))
%base-user-accounts))
;; This is where we specify system-wide packages.
(packages (cons* nss-certs ;for HTTPS access
fuse-exfat
gvfs ;for user mounts
%base-packages))
;; Add GNOME and/or Xfce---we can choose at the log-in
;; screen with F1. Use the "desktop" services, which
;; include the X11 log-in service, networking with
;; NetworkManager, and more.
(services (cons* (service gnome-desktop-service-type)
(bluetooth-service)
(simple-service 'custom-udev-rules udev-service-type (list sane-backends libu2f-host))
%desktop-services))
Best,
Jack