(address . bug-Guix@gnu.org)
Hello,
On ‘core-updates’ (commit fb1d8d2baab907493367930e8069f937a5187b61),
Gnumeric fails to build due to a segfault of ‘itstool’ (that’s on
x86_64-linux):
Toggle snippet (26 lines)
make[2]: Leaving directory '/tmp/guix-build-gnumeric-1.12.45.drv-0/gnumeric-1.12.45/templates'
Making all in doc
make[2]: Entering directory '/tmp/guix-build-gnumeric-1.12.45.drv-0/gnumeric-1.12.45/doc'
GEN cs/cs.mo
GEN de/de.mo
GEN es/es.mo
GEN sv/sv.mo
make[3]: Entering directory '/tmp/guix-build-gnumeric-1.12.45.drv-0/gnumeric-1.12.45/doc'
make[3]: Nothing to be done for 'all-am'.
make[3]: Leaving directory '/tmp/guix-build-gnumeric-1.12.45.drv-0/gnumeric-1.12.45/doc'
GEN de/
GEN es/
GEN sv/
GEN cs/
/gnu/store/29jhbbg1hf557x8j53f9sxd9imlmf02a-bash-minimal-5.0.7/bin/bash: line 3: 23402 Segmentation fault itstool -m "${mo}" ${d}/C/gnumeric.xml
make[2]: *** [Makefile:1411: cs/cs.stamp] Error 139
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory '/tmp/guix-build-gnumeric-1.12.45.drv-0/gnumeric-1.12.45/doc'
make[1]: *** [Makefile:668: all-recursive] Error 1
make[1]: Leaving directory '/tmp/guix-build-gnumeric-1.12.45.drv-0/gnumeric-1.12.45'
make: *** [Makefile:525: all] Error 2
command "make" "-j" "8" "gtk_update_icon_cache=true" failed with status 2
builder for `/gnu/store/ycpc1zrlgmda7jq4rda6x3klsq8clqch-gnumeric-1.12.45.drv' failed with exit code 1
@ build-failed /gnu/store/ycpc1zrlgmda7jq4rda6x3klsq8clqch-gnumeric-1.12.45.drv - 1 builder for `/gnu/store/ycpc1zrlgmda7jq4rda6x3klsq8clqch-gnumeric-1.12.45.drv' failed with exit code 1
(From
Here’s an excerpt of the stack trace:
Toggle snippet (42 lines)
Core was generated by `/gnu/store/78w7y0lxar70j512iqw8x3nimzj10yga-python-3.7.4/bin/python3 -s /gnu/st'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0 0x00007fd83da82144 in function_code_fastcall ()
from /gnu/store/78w7y0lxar70j512iqw8x3nimzj10yga-python-3.7.4/lib/libpython3.7m.so.1.0
(gdb) bt
#0 0x00007fd83da82144 in function_code_fastcall ()
from /gnu/store/78w7y0lxar70j512iqw8x3nimzj10yga-python-3.7.4/lib/libpython3.7m.so.1.0
#1 0x00007fd83dab33ef in _PyFunction_FastCallDict ()
from /gnu/store/78w7y0lxar70j512iqw8x3nimzj10yga-python-3.7.4/lib/libpython3.7m.so.1.0
#2 0x00007fd83d03d891 in libxml_xmlErrorFuncHandler ()
from /gnu/store/08si9lismjkgzqylwsnik8qqjbprfr3f-python-libxml2-2.9.9/lib/python3.7/site-packages/libxml2mod.cpython-37m-x86_64-linux-gnu.so
#3 0x00007fd83c9c0faa in xmlParserPrintFileContextInternal ()
from /gnu/store/cpv88zzh37l7gnsinbwxiz6mnv63s07x-libxml2-2.9.9/lib/libxml2.so.2
#4 0x00007fd83c9c12cc in xmlReportError ()
from /gnu/store/cpv88zzh37l7gnsinbwxiz6mnv63s07x-libxml2-2.9.9/lib/libxml2.so.2
#5 0x00007fd83c9c2c8d in __xmlRaiseError ()
from /gnu/store/cpv88zzh37l7gnsinbwxiz6mnv63s07x-libxml2-2.9.9/lib/libxml2.so.2
#6 0x00007fd83c9c7235 in xmlFatalErrMsgStrIntStr ()
from /gnu/store/cpv88zzh37l7gnsinbwxiz6mnv63s07x-libxml2-2.9.9/lib/libxml2.so.2
#7 0x00007fd83c9d4b1c in xmlParseEndTag2 ()
from /gnu/store/cpv88zzh37l7gnsinbwxiz6mnv63s07x-libxml2-2.9.9/lib/libxml2.so.2
#8 0x00007fd83c9d9526 in xmlParseElement ()
from /gnu/store/cpv88zzh37l7gnsinbwxiz6mnv63s07x-libxml2-2.9.9/lib/libxml2.so.2
#9 0x00007fd83c9d8c26 in xmlParseContent ()
from /gnu/store/cpv88zzh37l7gnsinbwxiz6mnv63s07x-libxml2-2.9.9/lib/libxml2.so.2
#10 0x00007fd83c9d94c3 in xmlParseElement ()
from /gnu/store/cpv88zzh37l7gnsinbwxiz6mnv63s07x-libxml2-2.9.9/lib/libxml2.so.2
#11 0x00007fd83c9d8c26 in xmlParseContent ()
from /gnu/store/cpv88zzh37l7gnsinbwxiz6mnv63s07x-libxml2-2.9.9/lib/libxml2.so.2
#12 0x00007fd83c9d94c3 in xmlParseElement ()
from /gnu/store/cpv88zzh37l7gnsinbwxiz6mnv63s07x-libxml2-2.9.9/lib/libxml2.so.2
#13 0x00007fd83c9d9b2b in xmlParseDocument ()
from /gnu/store/cpv88zzh37l7gnsinbwxiz6mnv63s07x-libxml2-2.9.9/lib/libxml2.so.2
#14 0x00007fd83d031587 in libxml_xmlParseDocument ()
from /gnu/store/08si9lismjkgzqylwsnik8qqjbprfr3f-python-libxml2-2.9.9/lib/python3.7/site-packages/libxml2mod.cpython-37m-x86_64-linux-gnu.so
#15 0x00007fd83dab379b in _PyMethodDef_RawFastCallKeywords ()
from /gnu/store/78w7y0lxar70j512iqw8x3nimzj10yga-python-3.7.4/lib/libpython3.7m.so.1.0
#16 0x00007fd83dab39c5 in _PyCFunction_FastCallKeywords ()
from /gnu/store/78w7y0lxar70j512iqw8x3nimzj10yga-python-3.7.4/lib/libpython3.7m.so.1.0
[…]