Hi Ludovic,
Ludovic Courtès <ludo@gnu.org> writes:
Toggle quote (49 lines)
> Hi Maxim,
>
> Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:
>
>> Ludovic Courtès <ludo@gnu.org> writes:
>>
>>> Hi Maxim!
>>>
>>> Great to see Btrfs support improving; many people will love that!
>>>
>>> Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:
>>>
>>>> From 3640bea548826e1c1ec9b766da1fdfe4791d7452 Mon Sep 17 00:00:00 2001
>>>> From: Maxim Cournoyer <maxim.cournoyer@gmail.com>
>>>> Date: Sun, 17 Nov 2019 06:01:00 +0900
>>>> Subject: [PATCH 1/9] gnu: tests: Reduce the time required to run the system
>>>> tests.
>>>>
>>>> When setting the GUIX_DEV_HACKS environment variable, the Guix package used
>>>> inside the instrumented VMs recycles the binaries already found in the Guix
>>>> checkout of the developer instead of rebuilding Guix from scratch. This
>>>> brings the time required for this component from 20+ minutes down to 2-3
>>>> minutes on an X200 machine.
>>>>
>>>> * gnu/packages/package-management.scm (current-guix/pre-built): New procedure.
>>>> * build-aux/run-system-tests.scm (tests-for-channel-instance): Use it, when
>>>> GUIX_DEV_HACKS is defined.
>>>
>>> I understand the need, but I’d really like to avoid that; it’s too
>>> fragile IMO.
>>>
>>> But I have good news! First, commit
>>> 887fd835a7c90f720d36a211478012547feaead0 really improved things by
>>> avoiding the full ‘guix’ package rebuild (and we’re only talking about
>>> the installation tests; other tests are just fine.) Second, there are
>>> improvements to Guile that will appear in 3.0.1/2.2.7 that make
>>> compilation of big files roughly twice as fast.
>>>
>>> There’s still room for improvement, but I’d rather work in those
>>> directions. WDYT?
>>
>> With a little bit more love (inheriting from the Guix package from the
>> inferior captured at build time), I don't see the hack being any less
>> fragile than the Guix checkout compiled and ran with ./pre-inst-env.
>
> It’s grabbing files from the working tree, with heuristics to minimize
> the changes in incorporating files that shouldn’t be there; I think it’s
> fragile. :-)
Fragile or not, it's helped me getting this change tested much faster
than I could have had otherwise, which is the point of that hack :-).
Benchmarks below.
Toggle quote (22 lines)
> It also breaks that idea that things compiled by Guix are well under
> control.
>
>> There's no arguing that it *is* a hack, but:
>>
>> 1) Being labeled as such (GUIX_DEV_HACKS)
>> 2) Being undocumented
>> 3) Only being enabled explicitly (through that GUIX_DEV_HACKS
>> environment variable)
>> 4) Can be reverted easily in the future when the default, clean implementation is
>> fast enough to obsolete it.
>>
>> To me means its targeted to developers who understand the nature of the
>> hack and is provided without any warranty.
>>
>> And while it's exciting that Guile's compilation time is going to be
>> improved, no compiler's going to be as efficient as "no compilation"
>> ;-).
>
> True! But still, we’d have to maintain that in the meantime and deal
> with any “surprising” effects it has for those using it.
Toggle quote (12 lines)
> FWIW, when testing (gnu installer tests), I only have to rebuild
> “guix-system-tests.drv”, which is fast. And in fact, I can also not
> rebuild anything by doing:
>
> (define operating-system-with-current-guix identity)
>
> because in this particular case, I know it’s not necessary to have the
> current ‘guix’ package.
>
> I suppose this would also be an option in your case, when testing the
> Btrfs changes, no?
I think it is important that the 'installer' image corresponds to the
'current-guix' in my case, because it has to generate the correct GRUB
configuration file at 'guix system init' time.
Below are some analysis of the derivations triggered in different scenarios.
Without the hack:
Toggle snippet (112 lines)
./pre-inst-env make check-system TESTS=btrfs-root-on-subvolume-os
Compiling Scheme modules...
random seed for tests: 1581852580
Computing Guix derivation for 'x86_64-linux'... \
Running 1 system tests...
substitute: updating substitutes from 'http://10.42.0.199:80'... 100.0%
substitute: updating substitutes from 'https://ci.guix.gnu.org'... 100.0%
The following derivations will be built:
/gnu/store/3g9bawa6c876lml0318g2knqdcv2ahv9-btrfs-root-on-subvolume-os.drv
/gnu/store/vswbrzp8ab5wz0fyzrj9j72mqcbd6c4a-installation.drv
/gnu/store/nf1wd5bgminylzvwq4mjs5293hpr1mmi-disk-image.drv
/gnu/store/45334hsl3hs5yx13x7qz1b1sc83vkbzj-module-import-compiled.drv
/gnu/store/dmi03i3jv9wwkw10fm57g7fq97kwlscf-module-import.drv
/gnu/store/4cp5pqyn554rdmv9l4vfhnw7lgasv18q-raw-initrd.drv
/gnu/store/vx147spsmrxkiy0qcmvxn341fpz4fmrv-init.drv
/gnu/store/d6ri0lh953vaksiz5h8jx681h3i35vvm-module-import-compiled.drv
/gnu/store/b0gv94llsbvrlzkxs3naz7crcv1glxy1-grub.cfg.drv
/gnu/store/gcslrfymsqsp6kqckla41zkyaa7fy9in-raw-initrd.drv
/gnu/store/m8bbfcdn1irn7a41syy9arl1yz34hbln-init.drv
/gnu/store/hbfgqnralir92slqr9hhfw8cxqrlgv06-system.drv
/gnu/store/0v4aq6yprk8az183rpdjx90jnxw3w838-parameters.drv
/gnu/store/8daaamb92bbkpdwz96a19r81f7vnk40k-gc-roots.drv
/gnu/store/f48dwgib52ciaq1nh06nhks6g7gvy7bx-system.drv
/gnu/store/4ll7vvq5wxq8c2xl8qw5dbim7nrz0yda-raw-initrd.drv
/gnu/store/mxdfkkfyy3ld6656a01z0lw7gxgjns25-init.drv
/gnu/store/72fjlv3kp75629as4bc49yp9hgf80pv7-boot.drv
/gnu/store/xra5iv1ayyiml1kvpcjg5rkrgjbzy6lb-activate.scm.drv
/gnu/store/xww4xc7rpc1bw1xk9sn6vy3hazjk1gcq-module-import-compiled.drv
/gnu/store/y8hd9wzr9ypn2pfcl5al0dckijzw36x6-shepherd.conf.drv
/gnu/store/14mdcbdyqrihnl7x8lqygncxdbsvmhv0-shepherd-file-system--home.go.drv
/gnu/store/clv6h5sxwgchw1kkf9cnafgvd5ms4p4r-shepherd-file-system--home.scm.drv
/gnu/store/zc84ngrjdvbc4kibdvzipf9sxjj50rgz-module-import-compiled.drv
/gnu/store/6cca3yng6k4zl812ysdgmj5lyw8lmwln-shepherd-file-system--gnu-store.go.drv
/gnu/store/rplp3l38j9jm0fism0ka1iqbfhx7h3ir-shepherd-file-system--gnu-store.scm.drv
/gnu/store/729f2ranwr6klr90rvrx5pfka30iwazr-shepherd-user-homes.go.drv
/gnu/store/2cadf4viazfvzlazj996vmbpq3cw1hbr-shepherd-user-homes.scm.drv
/gnu/store/7j784x4jpxqlcisikn8cin4s0n1vv7z7-shepherd-term-auto.go.drv
/gnu/store/zgz6p1mss3jwra7d4vzh1dxy9b4llnlg-shepherd-term-auto.scm.drv
/gnu/store/7n6y2ljl0gp4s568wqbj5iwdkw5hrhk6-shepherd-file-system--dev-shm.go.drv
/gnu/store/apsplfgbzzq38b5q7p06jxjn37kx74b2-shepherd-file-system--dev-shm.scm.drv
/gnu/store/qj459c7mlrls9imm1nw98lw9fgqh4yyy-shepherd-udev.go.drv
/gnu/store/78klph6xipr232a938qjhm8v4qviacvd-shepherd-udev.scm.drv
/gnu/store/z103dcbbvz3inx6ax7s966zxmy1s38hn-shepherd-file-system--dev-pts.go.drv
/gnu/store/5ss1d8nwn4dv9vb69h1iyw884b61y487-shepherd-file-system--dev-pts.scm.drv
/gnu/store/z1f6a7gfxxszaa0lm68xfl9hbglz48cw-parameters.drv
/gnu/store/vvg05l3pgkyz1rky6f2cn0d1r2i1b6yr-system.drv
/gnu/store/1k5k3kd11l3wabcc8sci8m04nvc6wllw-raw-initrd.drv
/gnu/store/51ay1gi0ajsbrgm7wy6j1njyy6pcjlzb-init.drv
/gnu/store/jjhnm39rqckl6r0jf7l43000nlydb2vj-parameters.drv
/gnu/store/wdm0acks0pzl3hiam7knffl7n6xmyvrm-boot.drv
/gnu/store/59mhndnjhsq6yspag4miv4b71rb8v683-activate.scm.drv
/gnu/store/z0ik75q9nshaik97jsigd69vriyjijgp-shepherd.conf.drv
/gnu/store/6pxsd37k5nl5viqadd57n0hah53nzcp7-shepherd-user-homes.go.drv
/gnu/store/y9rj23r1xmyb5b4fwrh75pb5yr61clvp-shepherd-user-homes.scm.drv
/gnu/store/h0xbdk4hw1i4byy8xnrnaqmlwnfgrswz-profile.drv
/gnu/store/sxdgmvfjakapmbyqmxjgvarsaaxc2mw7-profile.drv
/gnu/store/hxcadzr771dzl99kylz64d9qz2qai8wd-guix-000000000.drv
/gnu/store/95lcx1xx41p4vcwqlwli7phny6hpp8b0-guix-manual.drv
/gnu/store/9yz0spp1h158zdh8wmg2r7sspnkm0qfc-guix-translated-texinfo.drv
/gnu/store/g6ggidnpaahws37qgx15mvkhfll0ns06-guix-daemon.drv
/gnu/store/jpb2jfk00q5nh5fg3k3cf6hcyw49zz84-guix-command.drv
/gnu/store/14zcma6hkqszaab37hda736i24r41rv4-guix-module-union.drv
/gnu/store/sfzd86425cl744lr58yh877i7z5qbd68-guix-000000000-modules.drv
/gnu/store/71a40hzi2d2wdn1vjl5amfq00caqlh3m-guix-system-tests-modules.drv
/gnu/store/kc3zg69yabaglvllj4l7hzgs72v9mk26-guix-system-tests.drv
/gnu/store/5zhgzvnyswm8g50aha95rvdx6dpmw329-guix-packages-base.drv
/gnu/store/d7df7qw5allqcm2qn75dn60wz1dg50cq-guix-system.drv
/gnu/store/ily3pqqvfkjz5622fxz6mxg31jbiqb21-guix-packages.drv
/gnu/store/xgpy1v810xi76w8ivpfi7gg5h7vg0ska-guix-cli.drv
/gnu/store/7ih7cmbhz1p7a4m7yrgy0s2jawqc666n-guix-packages-base-modules.drv
/gnu/store/j15kzs5m07pq3nmgqr5rr47cryq8arfs-guix-system-modules.drv
/gnu/store/rhk9cknm5wbk30slzzrr52app8mfn4a2-guix-packages-modules.drv
/gnu/store/x05mz632h3ph0k9n3s5y14m51qy3k929-guix-cli-modules.drv
/gnu/store/fs2g9iin23iq4505jsxjnrjaxnxp1wzl-inferior-script.scm.drv
/gnu/store/y4hv2s267zjz2gzja3cj428a7z1dln98-profile.drv
/gnu/store/kx5h4kxkz28gahlgkxni02i0rf8558vd-boot.drv
/gnu/store/nhi2s5zcyd5frjqag4jnp7fvhzbx6kd6-activate.scm.drv
/gnu/store/qnchikcfqx8hn0a7cn45f0pnf664s0jk-shepherd.conf.drv
/gnu/store/7n4cqlsbn7hywlwssxvax6j6b57gm1q4-shepherd-user-homes.go.drv
/gnu/store/dl333r3dshzi5nb4qqrvcsp2hmk3hd9p-shepherd-user-homes.scm.drv
/gnu/store/i96lsb7shixcczc62bfadbg1g73qp38l-shepherd-udev.go.drv
/gnu/store/yv3maqmnqqpiqj2jk5ss574pzvgh9jin-shepherd-udev.scm.drv
/gnu/store/s5w901l6zl0ql800bc9cndnskqdhnsxm-shepherd-file-system--tmp.go.drv
/gnu/store/a5nb6vhs86g76ww5bmpphi398pggnga7-shepherd-file-system--tmp.scm.drv
/gnu/store/sjn7zb56x72lh6i7arkh6gpd639g7d17-shepherd-guix-daemon.go.drv
/gnu/store/rww6z6m3nz6s7h54xklwj3plylg1f0yc-shepherd-guix-daemon.scm.drv
/gnu/store/lmbja82mymwsn3kmxwfy8g7s46xac443-linux-vm-loader.drv
/gnu/store/z8y0v374himjlig4qwjisv1xa7rk7r0l-builder-in-linux-vm.drv
/gnu/store/14bw0x4dq0g262vk4pjh3dlha6x3gz0s-module-import-compiled.drv
/gnu/store/nbkfy5wjpia5y7hj1p9j5hmbv42j4zp5-module-import.drv
The following grafts will be made:
/gnu/store/qn8j1cqp2lfvghiv4sy5rps4kv2hz02y-guile3.0-git-0.3.0.drv
/gnu/store/dnl877iincgcw7lw493h5nd4llxqjw7a-libgit2-0.28.4.drv
The following profile hooks will be built:
/gnu/store/96274clz8449s7s18a91sa31d1ilmi0p-fonts-dir.drv
/gnu/store/30lvdbci7v9zqgn3nqjy1vgbpv5k4b98-ca-certificate-bundle.drv
/gnu/store/b5dspr8576n0j3vl2cjsr7zrfdp380cw-guix-package-cache.drv
/gnu/store/chjdvqjbrnb7cqla43n5rvqia5d4f4mg-fonts-dir.drv
/gnu/store/kh7wixk3i5db2ym48ddyrdbggw8ccxp8-info-dir.drv
/gnu/store/x3bp2acfy04w9r9l11w30l9z0hpsii5a-manual-database.drv
/gnu/store/bhla9fihy35pgc3bwszfxvsfjir71v88-glib-schemas.drv
/gnu/store/isb4444058amfr4sipqmffcrgisx75gs-ca-certificate-bundle.drv
/gnu/store/l8qgqaxq1xcb8jk3lqmzzrfiv8hzpna1-xdg-desktop-database.drv
/gnu/store/x0vhd98kg66pzfwffbi45f76126by816-xdg-mime-database.drv
/gnu/store/xs4k7nmrpbjsy0a5k6lsbdxc2n4i23g4-info-dir.drv
/gnu/store/zffqfc9w73sy815av7hwincbqpl7hbkr-manual-database.drv
building /gnu/store/dmi03i3jv9wwkw10fm57g7fq97kwlscf-module-import.drv...
successfully built /gnu/store/dmi03i3jv9wwkw10fm57g7fq97kwlscf-module-import.drv
building /gnu/store/9yz0spp1h158zdh8wmg2r7sspnkm0qfc-guix-translated-texinfo.drv...
^Cmake: *** [Makefile:5711: check-system] Interrupt
Toggle snippet (82 lines)
./pre-inst-env make check-system TESTS=btrfs-root-on-subvolume-os GUIX_DEV_HACKS=1
Compiling Scheme modules...
random seed for tests: 1581851372
Running 1 system tests...
The following derivations will be built:
/gnu/store/l4z1363klr8a58qmm3pjzy2y5bxsr6bd-btrfs-root-on-subvolume-os.drv
/gnu/store/zlg6gxml4awbkbs2s6n1b0z3ysrqvy0h-installation.drv
/gnu/store/89vdpn33f47y0510im604snwfmbpswmm-disk-image.drv
/gnu/store/45334hsl3hs5yx13x7qz1b1sc83vkbzj-module-import-compiled.drv
/gnu/store/4cp5pqyn554rdmv9l4vfhnw7lgasv18q-raw-initrd.drv
/gnu/store/vx147spsmrxkiy0qcmvxn341fpz4fmrv-init.drv
/gnu/store/d6ri0lh953vaksiz5h8jx681h3i35vvm-module-import-compiled.drv
/gnu/store/58912rdjjk4jdv767svb2axp0llmn8ch-linux-vm-loader.drv
/gnu/store/hvcm9abi0br38plwpngqlvw1l0060fni-builder-in-linux-vm.drv
/gnu/store/14bw0x4dq0g262vk4pjh3dlha6x3gz0s-module-import-compiled.drv
/gnu/store/nbkfy5wjpia5y7hj1p9j5hmbv42j4zp5-module-import.drv
/gnu/store/shc8hzzqi40pdpip0773i2g9x2apnn0h-grub.cfg.drv
/gnu/store/gcslrfymsqsp6kqckla41zkyaa7fy9in-raw-initrd.drv
/gnu/store/m8bbfcdn1irn7a41syy9arl1yz34hbln-init.drv
/gnu/store/zifmvsbiw6x4gs15k29l1nvyzxkszafw-system.drv
/gnu/store/0v4aq6yprk8az183rpdjx90jnxw3w838-parameters.drv
/gnu/store/8daaamb92bbkpdwz96a19r81f7vnk40k-gc-roots.drv
/gnu/store/f48dwgib52ciaq1nh06nhks6g7gvy7bx-system.drv
/gnu/store/4ll7vvq5wxq8c2xl8qw5dbim7nrz0yda-raw-initrd.drv
/gnu/store/mxdfkkfyy3ld6656a01z0lw7gxgjns25-init.drv
/gnu/store/72fjlv3kp75629as4bc49yp9hgf80pv7-boot.drv
/gnu/store/xra5iv1ayyiml1kvpcjg5rkrgjbzy6lb-activate.scm.drv
/gnu/store/xww4xc7rpc1bw1xk9sn6vy3hazjk1gcq-module-import-compiled.drv
/gnu/store/y8hd9wzr9ypn2pfcl5al0dckijzw36x6-shepherd.conf.drv
/gnu/store/14mdcbdyqrihnl7x8lqygncxdbsvmhv0-shepherd-file-system--home.go.drv
/gnu/store/clv6h5sxwgchw1kkf9cnafgvd5ms4p4r-shepherd-file-system--home.scm.drv
/gnu/store/zc84ngrjdvbc4kibdvzipf9sxjj50rgz-module-import-compiled.drv
/gnu/store/6cca3yng6k4zl812ysdgmj5lyw8lmwln-shepherd-file-system--gnu-store.go.drv
/gnu/store/rplp3l38j9jm0fism0ka1iqbfhx7h3ir-shepherd-file-system--gnu-store.scm.drv
/gnu/store/729f2ranwr6klr90rvrx5pfka30iwazr-shepherd-user-homes.go.drv
/gnu/store/2cadf4viazfvzlazj996vmbpq3cw1hbr-shepherd-user-homes.scm.drv
/gnu/store/7j784x4jpxqlcisikn8cin4s0n1vv7z7-shepherd-term-auto.go.drv
/gnu/store/zgz6p1mss3jwra7d4vzh1dxy9b4llnlg-shepherd-term-auto.scm.drv
/gnu/store/7n6y2ljl0gp4s568wqbj5iwdkw5hrhk6-shepherd-file-system--dev-shm.go.drv
/gnu/store/apsplfgbzzq38b5q7p06jxjn37kx74b2-shepherd-file-system--dev-shm.scm.drv
/gnu/store/qj459c7mlrls9imm1nw98lw9fgqh4yyy-shepherd-udev.go.drv
/gnu/store/78klph6xipr232a938qjhm8v4qviacvd-shepherd-udev.scm.drv
/gnu/store/z103dcbbvz3inx6ax7s966zxmy1s38hn-shepherd-file-system--dev-pts.go.drv
/gnu/store/5ss1d8nwn4dv9vb69h1iyw884b61y487-shepherd-file-system--dev-pts.scm.drv
/gnu/store/z1f6a7gfxxszaa0lm68xfl9hbglz48cw-parameters.drv
/gnu/store/vvg05l3pgkyz1rky6f2cn0d1r2i1b6yr-system.drv
/gnu/store/1k5k3kd11l3wabcc8sci8m04nvc6wllw-raw-initrd.drv
/gnu/store/51ay1gi0ajsbrgm7wy6j1njyy6pcjlzb-init.drv
/gnu/store/jjhnm39rqckl6r0jf7l43000nlydb2vj-parameters.drv
/gnu/store/wdm0acks0pzl3hiam7knffl7n6xmyvrm-boot.drv
/gnu/store/59mhndnjhsq6yspag4miv4b71rb8v683-activate.scm.drv
/gnu/store/z0ik75q9nshaik97jsigd69vriyjijgp-shepherd.conf.drv
/gnu/store/6pxsd37k5nl5viqadd57n0hah53nzcp7-shepherd-user-homes.go.drv
/gnu/store/y9rj23r1xmyb5b4fwrh75pb5yr61clvp-shepherd-user-homes.scm.drv
/gnu/store/kammkm5z0ihjqalg0ijn69ffhdyzki47-profile.drv
/gnu/store/07kxlp8a99mvx2zidnlz6rm4ak2az8d0-guix-1.0.1-13.50299ad+.drv
/gnu/store/m9783fc7m360dk582b3mv2wgrsdz6amk-boot.drv
/gnu/store/3v1whxi5qkp9cyfc3vjpvziwc9ms7y7k-shepherd.conf.drv
/gnu/store/50halfax0zbiwpy47z6374ybh1mq1d5r-shepherd-guix-daemon.go.drv
/gnu/store/g4m4mqiz9z4yd2iwzmb6f81vidw0k4bg-shepherd-guix-daemon.scm.drv
/gnu/store/7n4cqlsbn7hywlwssxvax6j6b57gm1q4-shepherd-user-homes.go.drv
/gnu/store/dl333r3dshzi5nb4qqrvcsp2hmk3hd9p-shepherd-user-homes.scm.drv
/gnu/store/i96lsb7shixcczc62bfadbg1g73qp38l-shepherd-udev.go.drv
/gnu/store/yv3maqmnqqpiqj2jk5ss574pzvgh9jin-shepherd-udev.scm.drv
/gnu/store/s5w901l6zl0ql800bc9cndnskqdhnsxm-shepherd-file-system--tmp.go.drv
/gnu/store/a5nb6vhs86g76ww5bmpphi398pggnga7-shepherd-file-system--tmp.scm.drv
/gnu/store/nhi2s5zcyd5frjqag4jnp7fvhzbx6kd6-activate.scm.drv
The following profile hooks will be built:
/gnu/store/4j2hrilvx5rfycqs1sccd39jy5yjhxy0-xdg-mime-database.drv
/gnu/store/4rdg1bi6xxn85zq5cjqc3bdfksx14913-info-dir.drv
/gnu/store/c59p1krnc51qlbr5vnxjx6bg3rrixca4-glib-schemas.drv
/gnu/store/drf1pi6m91b6qra3p6hrknfzh7gcd51z-fonts-dir.drv
/gnu/store/fwal8vsrjzpbwljnihvv66k9ikkfx2ma-xdg-desktop-database.drv
/gnu/store/jzp4ps09ipy0kcc6ybx5967vi3xlq7aa-manual-database.drv
/gnu/store/m7yl2xvk07l37l19wp2hfbvhzl3583ji-ca-certificate-bundle.drv
building /gnu/store/45334hsl3hs5yx13x7qz1b1sc83vkbzj-module-import-compiled.drv...
process 21756 acquired build slot '/var/guix/offload/10.42.0.199:22/0'
load on machine '10.42.0.199' is 0.0 (normalized: 0.0)
building /gnu/store/07kxlp8a99mvx2zidnlz6rm4ak2az8d0-guix-1.0.1-13.50299ad+.drv...
^Cmake: *** [Makefile:5711: check-system] Interrupt
The diff between those two looks like:
Toggle snippet (50 lines)
--- /tmp/ediffD0RQCf 2020-02-16 12:10:53.643411325 -0500
+++ /tmp/ediffKmWrdZ 2020-02-16 12:10:53.647411377 -0500
@@ -1,15 +1,18 @@
- /gnu/store/3g9bawa6c876lml0318g2knqdcv2ahv9-btrfs-root-on-subvolume-os.drv
- /gnu/store/vswbrzp8ab5wz0fyzrj9j72mqcbd6c4a-installation.drv
- /gnu/store/nf1wd5bgminylzvwq4mjs5293hpr1mmi-disk-image.drv
+ /gnu/store/l4z1363klr8a58qmm3pjzy2y5bxsr6bd-btrfs-root-on-subvolume-os.drv
+ /gnu/store/zlg6gxml4awbkbs2s6n1b0z3ysrqvy0h-installation.drv
+ /gnu/store/89vdpn33f47y0510im604snwfmbpswmm-disk-image.drv
/gnu/store/45334hsl3hs5yx13x7qz1b1sc83vkbzj-module-import-compiled.drv
- /gnu/store/dmi03i3jv9wwkw10fm57g7fq97kwlscf-module-import.drv
/gnu/store/4cp5pqyn554rdmv9l4vfhnw7lgasv18q-raw-initrd.drv
/gnu/store/vx147spsmrxkiy0qcmvxn341fpz4fmrv-init.drv
/gnu/store/d6ri0lh953vaksiz5h8jx681h3i35vvm-module-import-compiled.drv
- /gnu/store/b0gv94llsbvrlzkxs3naz7crcv1glxy1-grub.cfg.drv
+ /gnu/store/58912rdjjk4jdv767svb2axp0llmn8ch-linux-vm-loader.drv
+ /gnu/store/hvcm9abi0br38plwpngqlvw1l0060fni-builder-in-linux-vm.drv
+ /gnu/store/14bw0x4dq0g262vk4pjh3dlha6x3gz0s-module-import-compiled.drv
+ /gnu/store/nbkfy5wjpia5y7hj1p9j5hmbv42j4zp5-module-import.drv
+ /gnu/store/shc8hzzqi40pdpip0773i2g9x2apnn0h-grub.cfg.drv
/gnu/store/gcslrfymsqsp6kqckla41zkyaa7fy9in-raw-initrd.drv
/gnu/store/m8bbfcdn1irn7a41syy9arl1yz34hbln-init.drv
- /gnu/store/hbfgqnralir92slqr9hhfw8cxqrlgv06-system.drv
+ /gnu/store/zifmvsbiw6x4gs15k29l1nvyzxkszafw-system.drv
/gnu/store/0v4aq6yprk8az183rpdjx90jnxw3w838-parameters.drv
/gnu/store/8daaamb92bbkpdwz96a19r81f7vnk40k-gc-roots.drv
/gnu/store/f48dwgib52ciaq1nh06nhks6g7gvy7bx-system.drv
@@ -44,56 +47,24 @@
/gnu/store/z0ik75q9nshaik97jsigd69vriyjijgp-shepherd.conf.drv
/gnu/store/6pxsd37k5nl5viqadd57n0hah53nzcp7-shepherd-user-homes.go.drv
/gnu/store/y9rj23r1xmyb5b4fwrh75pb5yr61clvp-shepherd-user-homes.scm.drv
- /gnu/store/h0xbdk4hw1i4byy8xnrnaqmlwnfgrswz-profile.drv
- /gnu/store/sxdgmvfjakapmbyqmxjgvarsaaxc2mw7-profile.drv
- /gnu/store/hxcadzr771dzl99kylz64d9qz2qai8wd-guix-000000000.drv
- /gnu/store/95lcx1xx41p4vcwqlwli7phny6hpp8b0-guix-manual.drv
- /gnu/store/9yz0spp1h158zdh8wmg2r7sspnkm0qfc-guix-translated-texinfo.drv
- /gnu/store/g6ggidnpaahws37qgx15mvkhfll0ns06-guix-daemon.drv
- /gnu/store/jpb2jfk00q5nh5fg3k3cf6hcyw49zz84-guix-command.drv
- /gnu/store/14zcma6hkqszaab37hda736i24r41rv4-guix-module-union.drv
- /gnu/store/sfzd86425cl744lr58yh877i7z5qbd68-guix-000000000-modules.drv
- /gnu/store/71a40hzi2d2wdn1vjl5amfq00caqlh3m-guix-system-tests-modules.drv
- /gnu/store/kc3zg69yabaglvllj4l7hzgs72v9mk26-guix-system-tests.drv
- /gnu/store/5zhgzvnyswm8g50aha95rvdx6dpmw329-guix-packages-base.drv
- /gnu/store/d7df7qw5allqcm2qn75dn60wz1dg50cq-guix-system.drv
- /gnu/store/ily3pqqvfkjz5622fxz6mxg31jbiqb21-guix-packages.drv
- /gnu/store/xgpy1v810xi76w8ivpfi7gg5h7vg0ska-guix-cli.drv
- /gnu/store/7ih7cmbhz1p7a4m7yrgy0s2jawqc666n-guix-packages-base-modules.drv
- /gnu/store/j15kzs5m07pq3nmgqr5rr47cryq8arfs-guix-system-modules.drv
- /gnu/store/rhk9cknm5wbk30slzzrr52app8mfn4a2-gu