[PATCH] gnu: Add libhandy.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jonathan Frederickson
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Jonathan Frederickson
Severity
normal
J
J
Jonathan Frederickson wrote on 5 Aug 2019 02:13
(address . guix-patches@gnu.org)(name . Jonathan Frederickson)(address . jonathan@terracrypt.net)
20190805001300.24655-1-jonathan@terracrypt.net
gnu/packages/gnome.scm (libhandy): New variable.
---
gnu/packages/gnome.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3f7bbac214..6a3e69b5a8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8178,3 +8178,40 @@ advanced image management tool")
"Terminator allows you to run multiple GNOME terminals in a grid and
+tabs, and it supports drag and drop re-ordering of terminals.")
(license license:gpl2)))
+
+(define-public libhandy
+ (package
+ (name "libhandy")
+ (version "v0.0.10")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://source.puri.sm/Librem5/libhandy")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1702hbdqhfpgw0c4vj2ag08vgl83byiryrbngbq11b9azmj3jhzs"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:tests? #f
+ #:configure-flags '("-Dglade_catalog=disabled")))
+ (inputs
+ `(("gobject-introspection" ,gobject-introspection)
+ ("gtk-doc" ,gtk-doc)
+ ("glib" ,glib)
+ ("gladeui" ,libglade)
+ ("gnome-desktop" ,gnome-desktop)
+ ("gtk+" ,gtk+)
+ ("libxml2" ,libxml2)
+ ("vala" ,vala)
+ ("glade" ,glade3)))
+ (native-inputs
+ `(("glib:bin" ,glib "bin")
+ ("pkg-config" ,pkg-config)
+ ("gettext" ,gettext-minimal)))
+ (home-page "https://source.puri.sm/Librem5/libhandy")
+ (synopsis "Library full of GTK+ widgets for mobile phones")
+ (description "The aim of the handy library is to help with developing UI
+for mobile devices using GTK+/GNOME.")
+ (license license:lgpl2.1+)))
--
2.22.0
R
R
Ricardo Wurmus wrote on 5 Aug 2019 14:09
(name . Jonathan Frederickson)(address . jonathan@terracrypt.net)(address . 36926-done@debbugs.gnu.org)
87pnljzud8.fsf@elephly.net
Hi Jonathan,

thank you for this patch!

I applied a modified version of it with commit 213315d485 after these
changes:

* added a copyright line for you
* removed the “v” from the version field (and added it to the
git-reference instead)
* removed unneeded inputs
* moved some inputs to the native-inputs
* enabled tests (except for one)
* edited the description a little

Thanks again for your contribution!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 36926@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 36926
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch