ungoogled-chromium needs font-gnu-freefont-ttf

  • Open
  • quality assurance status badge
Details
2 participants
  • Martin Becze
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Martin Becze
Severity
normal

Debbugs page

Martin Becze wrote 6 years ago
(address . bug-guix@gnu.org)
d13ae854-70aa-5c44-654e-f148ba151b0e@riseup.net
ungoogled-chromium will crash until font-gnu-freefont-ttf is installed.
Attachment: signature.asc
mjbecze wrote 6 years ago
[Patch] add font-gnu-freefont-ttf propagated-inputs
(address . 36632@debbugs.gnu.org)
5ff60dda7f2e1a70c85832b51fa74dd3@riseup.net
hi this fixes bug 36632

---
gnu/packages/chromium.scm | 3 +++
1 file changed, 3 insertions(+)

Toggle diff (25 lines)
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index d072fc58ad..04ce780be0 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -35,6 +35,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages cups)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gcc)
@@ -763,6 +764,8 @@ from forcing GEXP-PROMISE."
("udev" ,eudev)
("valgrind" ,valgrind)
("vulkan-headers" ,vulkan-headers)))
+ (propagated-inputs
+ `(("font-gnu-freefont-ttf" ,font-gnu-freefont-ttf)))
;; Building Chromium takes ... a very long time. On a single core,
a busy
;; mid-end x86 system may need more than 24 hours to complete the
build.
--
2.22.0
Martin Becze wrote 6 years ago
(no subject)
(address . 36632@debbugs.gnu.org)
6b7a1de1-b693-157f-c687-7f141a13d3fc@riseup.net
bump :)
mjbecze wrote 6 years ago
Re: [Patch] add font-gnu-freefont-ttf propagated-inputs
(address . 36632@debbugs.gnu.org)
882789cfa85760cacd43617b3f5cea8a@riseup.net
On 2019-07-29 13:59, mjbecze@riseup.net wrote:
Toggle quote (31 lines)
> hi this fixes bug 36632
>
> ---
> gnu/packages/chromium.scm | 3 +++
> 1 file changed, 3 insertions(+)
>
> diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
> index d072fc58ad..04ce780be0 100644
> --- a/gnu/packages/chromium.scm
> +++ b/gnu/packages/chromium.scm
> @@ -35,6 +35,7 @@
> #:use-module (gnu packages compression)
> #:use-module (gnu packages cups)
> #:use-module (gnu packages curl)
> + #:use-module (gnu packages fonts)
> #:use-module (gnu packages fontutils)
> #:use-module (gnu packages freedesktop)
> #:use-module (gnu packages gcc)
> @@ -763,6 +764,8 @@ from forcing GEXP-PROMISE."
> ("udev" ,eudev)
> ("valgrind" ,valgrind)
> ("vulkan-headers" ,vulkan-headers)))
> + (propagated-inputs
> + `(("font-gnu-freefont-ttf" ,font-gnu-freefont-ttf)))
>
> ;; Building Chromium takes ... a very long time. On a single core,
> a busy
> ;; mid-end x86 system may need more than 24 hours to complete the
> build.


bump bump :)
Ricardo Wurmus wrote 6 years ago
Re: bug#36632: ungoogled-chromium needs font-gnu-freefont-ttf
(name . Martin Becze)(address . mjbecze@riseup.net)(address . 36632@debbugs.gnu.org)
87a7cnz9on.fsf@elephly.net
Hi Martin,

Toggle quote (2 lines)
> ungoogled-chromium will crash until font-gnu-freefont-ttf is installed.

Thank you for reporting this problem and proposing a patch.

I’d prefer not to propagate any fonts. Do you happen to know what the
mechanism underlying the fix is? Why does this fix the problem? Why
does it crash in the first place?

Is this at all related to a stale font cache, perhaps?

--
Ricardo
Martin Becze wrote 6 years ago
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 36632@debbugs.gnu.org)
3b327caa80991fcf6528f718bca8e718@riseup.net
On 2019-08-05 15:36, Ricardo Wurmus wrote:
Toggle quote (12 lines)
> Hi Martin,
>
>> ungoogled-chromium will crash until font-gnu-freefont-ttf is installed.
>
> Thank you for reporting this problem and proposing a patch.
>
> I’d prefer not to propagate any fonts. Do you happen to know what the
> mechanism underlying the fix is? Why does this fix the problem? Why
> does it crash in the first place?
>
> Is this at all related to a stale font cache, perhaps?

So i got a chance to dig into this a bit. chromium needs a ttf font and
there are no fonts installed yet, so defaintly not a stale cache issue.
Chrome is crashing here
Its using fontconfig i think. I have no idea how to get chromium to read
fonts from a custom path.
Ricardo Wurmus wrote 6 years ago
(name . Martin Becze)(address . mjbecze@riseup.net)(address . 36632@debbugs.gnu.org)
87h86al0dy.fsf@elephly.net
Hi Martin,

Toggle quote (7 lines)
> So i got a chance to dig into this a bit. chromium needs a ttf font and
> there are no fonts installed yet, so defaintly not a stale cache issue.
> Chrome is crashing here
> https://chromium.googlesource.com/chromium/src/+/master/ui/gfx/platform_font_skia.cc#97
> Its using fontconfig i think. I have no idea how to get chromium to read
> fonts from a custom path.

Can we arrange for a default font to be returned by fontconfig? Perhaps
the fix is not needed in Chromium but in fontconfig or our profile hooks?

--
Ricardo
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 36632@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 36632
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help