sway fails to launch after installing

DoneSubmitted by martin.
Details
3 participants
  • Efraim Flashner
  • Ludovic Courtès
  • martin
Owner
unassigned
Severity
normal
Merged with
M
M
martin wrote on 11 Jul 2019 01:38
(address . bug-guix@gnu.org)
4c7ae5e4-34f7-40f2-2620-6024e1dac9cc@riseup.net
After installing sway it fails to launch from the command line. The
resulting error is


"XDG_RUNTIME_DIR is not set in the environment. Aborting."
E
E
Efraim Flashner wrote on 11 Jul 2019 08:33
debbugs
(address . control@debbugs.gnu.org)
20190711063315.GA5936@macbook41
merge 36589 36590
thanks

--
Efraim Flashner <efraim@flashner.co.il> אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl0m2CsACgkQQarn3Mo9
g1Eo4A//aSEa9c4HIWoPif+1x3cBuoWowLmtuDrkf5a2HIDfog7+eBcmyh8UpsRF
eEaYwMU3EJJf2S6uoM73a+/oF7Nf8kUEZvaJtD9ZGzkE/+76rFRIbDo/X5AJDrtG
L9ujJ08sDq8HfxWX6LOoEqWRZesstZs4bG2dd1z5zOqg9oN09GuAn7vgnLkyVznq
PofIm9ayKqmwdEs1mwdyVTytrrdfhQvQO7d8E943nVTgDibYVLHaZwmyjh7NqUmE
Y6HIKxcb6Yypxw+8HRolyfQmzZohiGagHVIVW9lIUryFceJ+MEqS9jMUAMgx2b7l
zIYbxztTC66eB6m+tUZZh7e4ogZv7UjapzxO/rawQrPXtIeOK5yDyN1fLlFFfY+p
r0oviXbzGC3lRczTbnh/X3yt5DbrhUfEF08YHubrPr4BjP+dlscvhxEygDRmFPSt
2T9iGDUdmyYy/JwqgoLjhMpJI45ChOBHRzWD0v7N0r0jqEJVUMNloNQfrV6UxwLc
U3nZxEJMNEc/lWtGiXFUnlBDzo3EK7ssfbghm7mcjBAMorKyORhrQyNsyLKgUWfG
KypJwSZ50et4Hrbt+XQyAPsKrVDL3LYEZWVNoaZZylpKOMYucXAHigQqbIc2UHvO
JYeJSwPpohT1Ja1ZlmD8WHl9J+N7DJhHFqTquvWpqrzPIEHT2xo=
=tL8V
-----END PGP SIGNATURE-----


M
M
martin wrote on 11 Jul 2019 18:50
Re: bug#36590: sway fails to launch after installing
(address . 36590@debbugs.gnu.org)
a859abba-2491-a7e0-35c8-7abaa7f6e114@riseup.net
so after I set XDG_RUNTIME_DIR=/tmp

i get the following errors

[source/backend/session/logind.c:511] User has no session

[source/backend/session/logind.c:599] Couldn't find an active session or
a greeter session

[source/backend/session/direct-ipc.c:96] Failed to load session backend

[source/backend/backend.c:321] Failed to start a DRM session

[source/backend/sway/server.c:47] Unable to create backend


The first error looks like it start here

where `sd_uid_get_sessions
` returns 0. I'm not sure why it would return 0 though.

On 7/10/19 6:38 PM, martin wrote:
Toggle quote (9 lines)
> After installing sway it fails to launch from the command line. The
> resulting error is
>
>
> "XDG_RUNTIME_DIR is not set in the environment. Aborting."
>
>
>
>
Attachment: file
Attachment: signature.asc
M
M
martin wrote on 12 Jul 2019 04:57
(no subject)
(address . 36590@debbugs.gnu.org)
9d22b7f1-282e-ec97-39bc-940eb3f8aa7a@riseup.net
Yay! i figured it out, i just needed to add %desktop-services.

1) how do i document this

2) how can i close this issue?
Attachment: signature.asc
M
M
Martin Becze wrote on 12 Jul 2019 23:47
its done
(address . 36590-done@debbugs.gnu.org)
59f495b6-3c21-7030-3113-c82362594224@riseup.net
its done
Closed
L
L
Ludovic Courtès wrote on 14 Jul 2019 16:05
Re: bug#36590: (no subject)
(name . martin)(address . mjbecze@riseup.net)(address . 36590-done@debbugs.gnu.org)
87ims43e4x.fsf@gnu.org
Hello,

martin <mjbecze@riseup.net> skribis:

Toggle quote (4 lines)
> Yay! i figured it out, i just needed to add %desktop-services.
>
> 1) how do i document this

Consider sending us modifications to the ‘doc/guix.texi’ file, which is
the manual.

Toggle quote (2 lines)
> 2) how can i close this issue?

By emailing NNN-done@debbugs.gnu.org, where NNN is the bug number.

Done! :-)

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send email to 36590@debbugs.gnu.org