[PATCH 1/4] guix: Add helper for generating desktop entry files.

  • Done
  • quality assurance status badge
Details
4 participants
  • Efraim Flashner
  • Ludovic Courtès
  • Pierre Neidhardt
  • Marius Bakke
Owner
unassigned
Submitted by
Pierre Neidhardt
Severity
normal
P
P
Pierre Neidhardt wrote on 30 May 2019 09:11
(address . guix-patches@gnu.org)
20190530071138.31690-1-mail@ambrevar.xyz
* guix/build/utils.scm (make-desktop-entry-file): New procedure.
---
guix/build/utils.scm | 99 ++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 99 insertions(+)

Toggle diff (112 lines)
diff --git a/guix/build/utils.scm b/guix/build/utils.scm
index 5fe3286843..21bdc42719 100644
--- a/guix/build/utils.scm
+++ b/guix/build/utils.scm
@@ -1100,6 +1100,105 @@ with definitions for VARS."
(chmod prog-tmp #o755)
(rename-file prog-tmp prog))))
+(define* (make-desktop-entry-file destination #:key
+ (type "Application") ; One of "Application", "Link" or "Directory".
+ (version "1.1")
+ name
+ (generic-name name)
+ (no-display #f)
+ comment
+ icon
+ (hidden #f)
+ only-show-in
+ not-show-in
+ (d-bus-activatable #f)
+ try-exec
+ exec
+ path
+ (terminal #f)
+ actions
+ mime-type
+ (categories "Application")
+ implements
+ keywords
+ (startup-notify #t)
+ startup-w-m-class
+ #:rest all-args)
+ "Create a desktop entry file at DESTINATION.
+You must specify NAME.
+
+Values can be booleans, numbers, strings or list of strings.
+
+Additionally, locales can be specified with an alist where the key is the
+locale. The #f key specifies the default. Example:
+
+ #:name '((#f \"I love Guix\") (\"fr\" \"J'aime Guix\"))
+
+produces
+
+ Name=I love Guix
+ Name[fr]=J'aime Guix
+
+For a complete description of the format, see the specifications at
+https://specifications.freedesktop.org/desktop-entry-spec/desktop-entry-spec-latest.html."
+ (define (escape-semicolon s)
+ (string-join (string-split s #\;) "\\;"))
+ (define* (parse key value #:optional locale)
+ (set! value (match value
+ (#t "true")
+ (#f "false")
+ ((? number? n) n)
+ ((? string? s) (escape-semicolon s))
+ ((? list? value)
+ (catch 'wrong-type-arg
+ (lambda () (string-join (map escape-semicolon value) ";"))
+ (lambda args (error "List arguments can only contain strings: ~a" args))))
+ (_ (error "Value must be a boolean, number, string or list of strings"))))
+ (format #t "~a=~a~%"
+ (if locale
+ (format #f "~a[~a]" key locale)
+ key)
+ value))
+
+ (define key-error-message "This procedure only takes key arguments beside DESTINATION")
+
+ (unless name
+ (error "Missing NAME key argument"))
+ (unless (member #:type all-args)
+ (set! all-args (append (list #:type type) all-args)))
+ (mkdir-p (dirname destination))
+
+ (with-output-to-file destination
+ (lambda ()
+ (format #t "[Desktop Entry]~%")
+ (let loop ((args all-args))
+ (match args
+ (() #t)
+ ((_) (error key-error-message))
+ ((key value . ...)
+ (unless (keyword? key)
+ (error key-error-message))
+ (set! key
+ (string-join (map string-titlecase
+ (string-split (symbol->string
+ (keyword->symbol key))
+ #\-))
+ ""))
+ (match value
+ (((_ . _) . _)
+ (for-each (lambda (locale-subvalue)
+ (parse key
+ (if (and (list? (cdr locale-subvalue))
+ (= 1 (length (cdr locale-subvalue))))
+ ;; Support both proper and improper lists for convenience.
+ (cadr locale-subvalue)
+ (cdr locale-subvalue))
+ (car locale-subvalue)))
+ value))
+ (_
+ (parse key value)))
+ (loop (cddr args))))))))
+
;;;
;;; Locales.
--
2.21.0
P
P
Pierre Neidhardt wrote on 30 May 2019 10:17
[PATCH 4/4] gnu: drascula: Use make-desktop-entry-file.
(address . 36000@debbugs.gnu.org)
20190530081728.27140-3-mail@ambrevar.xyz
* gnu/packages/games.scm (drascula)[arguments]: Do it.
---
gnu/packages/games.scm | 28 ++++++++++++----------------
1 file changed, 12 insertions(+), 16 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index af875435d6..94a44f0fc1 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7276,22 +7276,18 @@ on items and player adaptability for character progression.")
;; game, so we borrow SCUMMVM's.
(let ((apps (string-append out "/share/applications")))
(mkdir-p apps)
- (with-output-to-file (string-append apps "/drascula.desktop")
- (lambda _
- (format #t
- "[Desktop Entry]~@
- Name=Drascula: The Vampire Strikes Back~@
- GenericName=Drascula~@
- Exec=~a/bin/drascula~@
- Icon=~a/share/icons/hicolor/scalable/apps/scummvm.svg~@
- Categories=AdventureGame;Game;RolePlaying;~@
- Keywords=game;adventure;roleplaying;2D,fantasy;~@
- Comment=Classic 2D point and click adventure game~@
- Comment[de]=klassisches 2D-Abenteuerspiel in Zeigen-und-Klicken-Manier~@
- Comment[fr]=Jeux classique d'aventure pointer-et-cliquer en 2D~@
- Comment[it]=Gioco classico di avventura punta e clicca 2D~@
- Type=Application~%"
- out scummvm))))
+ (make-desktop-entry-file
+ (string-append apps "/drascula.desktop")
+ #:name "Drascula: The Vampire Strikes Back"
+ #:generic-name "Drascula"
+ #:exec (string-append out "/bin/drascula")
+ #:icon (string-append scummvm "/share/icons/hicolor/scalable/apps/scummvm.svg")
+ #:categories '("AdventureGame" "Game" "RolePlaying")
+ #:keywords '("game" "adventure" "roleplaying" "2D" "fantasy")
+ #:comment '((#f "Classic 2D point and click adventure game")
+ ("de" "Klassisches 2D-Abenteuerspiel in Zeigen-und-Klicken-Manier")
+ ("fr" "Jeu classique d'aventure pointer-et-cliquer en 2D")
+ ("it" "Gioco classico di avventura punta e clicca 2D"))))
#t))))
(native-inputs
`(("bash" ,bash)
--
2.21.0
P
P
Pierre Neidhardt wrote on 30 May 2019 10:17
[PATCH 3/4] gnu: tome4: Use make-desktop-entry-file.
(address . 36000@debbugs.gnu.org)
20190530081728.27140-2-mail@ambrevar.xyz
* gnu/packages/games.scm (tome4)[arguments]: Do it.
---
gnu/packages/games.scm | 20 +++++++-------------
1 file changed, 7 insertions(+), 13 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4fdc9b01e6..af875435d6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5035,19 +5035,13 @@ Crowther & Woods, its original authors, in 1995. It has been known as
(copy-recursively "game" (string-append data "/game"))
;; launcher
(mkdir-p applications)
- (with-output-to-file (string-append applications "/"
- ,name ".desktop")
- (lambda ()
- (display
- (string-append
- "[Desktop Entry]
-Name=ToME4
-Comment=" ,synopsis "\n"
-"Exec=" ,name "\n"
-"Icon=" icon "\n"
-"Terminal=false
-Type=Application
-Categories=Game;RolePlaying;\n")))))
+ (make-desktop-entry-file
+ (string-append applications "/" ,name ".desktop")
+ #:name "ToME4"
+ #:comment ,synopsis
+ #:exec ,name
+ #:icon icon
+ #:categories '("Game" "RolePlaying")))
#t)))))
(home-page "https://te4.org")
(description "Tales of Maj’Eyal (ToME) RPG, featuring tactical turn-based
--
2.21.0
P
P
Pierre Neidhardt wrote on 30 May 2019 10:17
[PATCH 2/4] gnu: emacs-exwm: Use make-desktop-entry-file.
(address . 36000@debbugs.gnu.org)
20190530081728.27140-1-mail@ambrevar.xyz
* gnu/packages/emacs-xyz.scm (emacs-exwm)[arguments]: Do it.
---
gnu/packages/emacs-xyz.scm | 15 ++++++---------
1 file changed, 6 insertions(+), 9 deletions(-)

Toggle diff (28 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9199b45e40..fed92528c3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7498,15 +7498,12 @@ It should enable you to implement low-level X11 applications.")
;; Add a .desktop file to xsessions
(mkdir-p xsessions)
(mkdir-p bin)
- (with-output-to-file
- (string-append xsessions "/exwm.desktop")
- (lambda _
- (format #t "[Desktop Entry]~@
- Name=~a~@
- Comment=~a~@
- Exec=~a~@
- TryExec=~:*~a~@
- Type=Application~%" ,name ,synopsis exwm-executable)))
+ (make-desktop-entry-file
+ (string-append xsessions "/exwm.desktop")
+ #:name ,name
+ #:comment ,synopsis
+ #:exec exwm-executable
+ #:try-exec exwm-executable)
;; Add a shell wrapper to bin
(with-output-to-file exwm-executable
(lambda _
--
2.21.0
P
P
Pierre Neidhardt wrote on 12 Oct 2019 10:43
Re: bug#36000: Acknowledgement ([PATCH 1/4] guix: Add helper for generating desktop entry files.)
(address . 36000@debbugs.gnu.org)
87y2xquzeb.fsf@ambrevar.xyz
Can we merge this in core updates?
Any blocker?

Thanks!

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl2hkkwACgkQm9z0l6S7
zH8m0wgAsO2ZwpOK1DxhQ9Flj0FEh7KSKuEAnnRmvzxyooP45c1IBmctesdcmUrz
8HLRLCEy8b/GwVHdWFXHEP1D3E7jwoqs0uAqn7bNAjynHuadhQfrZL8BGOoCaGiW
YaEwNsb6VAylm6iH0TnzeYYXyUARUHc3aZQ6AdXHc2EFE3zWzYp4OwrJkYrCmTbl
AOZWPHTTfkc8Jn05LunDddd4Bu+SgdRIj3BLDJihH91YOGYyzIhy9cSbQPoN21Cd
y/gcX0NdL5FGYOei9y9PJ3/YjzAMXk06YYyb3Iwy5sEalr8MjEVrSn0iCmVaqwNF
E8ax6X0FvGD35MSrqvRxiKCmiRs7lw==
=HK3g
-----END PGP SIGNATURE-----

E
E
Efraim Flashner wrote on 12 Oct 2019 20:44
Re: [bug#36000] Acknowledgement ([PATCH 1/4] guix: Add helper for generating desktop entry files.)
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)
20191012184406.GD13364@E5400
On Sat, Oct 12, 2019 at 10:43:56AM +0200, Pierre Neidhardt wrote:
Toggle quote (4 lines)
> Can we merge this in core updates?
> Any blocker?
>

The wrapping is wrong at the very top, it should be under the 'e' in
define. It looks good. I didn't look too much at the logic (my weak
point) but this should be a very welcome addition.

Why core-updates specifically?


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl2iHvMACgkQQarn3Mo9
g1FZpQ//b5xA+39A7D2fRn4lftKrKxJLDhN40GIFTqLCNm8in1J7rRZWKKu72rnp
h+hV/w2B9ODv4CW/fFu9TQ8xzj5/nee2F0zgYS/1KbNsoW2inDGb9b/BRgJqSt2r
CAYnL57X2qSMV1gdCv7b/vVdVBedzL6K5hi6O+20nyZJSJUL5DOSCDVQ0ls4XXGV
/2B63z3dkNZpzB8620lSyja7ibu0QKsrm8PshO+VrwLyfy2pF4V81j2eZEVyNiY1
NuTmhrQPG7PcmFwV7M+xNuwkinRBOAizz4h76Kxa9X6yd9ud/SrFXyiMlVGLqou7
VGrcC1P2Rz1liziuMsBo7j5M6pnWnhXw/G6viWGYAU5q4UJr9z9p13wpUOCWmfX2
5BOXYl3syIVpNyGEzXGswladK6Z9r+33pTBBbQ9jaamP4qwEAqtEGoPC2hUrp2Xg
eKRKDWMdyymDHhx/WL3+7yhz/wtlja1skMhi4GUKzSw51WU6LpxqKQsWBkdbx9om
vaHrqNuSPLc9bBcFtRYNDjUaZS6L8AuOe0f1FEmfyAgVBYUDHzQqIjbb/sPuLkLV
26UVnk0bpjT/RyBwebhwJmN238OC6+kXNM9TBDSgNe4o0E+CJENf57NnZQB/7/Cb
SgMWfN/bvDdtfE7aXHc5LiX7gmMRxm4jP+KakSYYGlFUGm+NqFU=
=R9rW
-----END PGP SIGNATURE-----


P
P
Pierre Neidhardt wrote on 12 Oct 2019 21:05
(name . Efraim Flashner)(address . efraim@flashner.co.il)
87o8yl6ayl.fsf@ambrevar.xyz
Cc-ing Nicolas since he was part of the discussion:

Efraim Flashner <efraim@flashner.co.il> writes:

Toggle quote (3 lines)
> The wrapping is wrong at the very top, it should be under the 'e' in
> define.

You mean the indentation? I'm not sure what's wrong, could you write a snippet?

Toggle quote (2 lines)
> Why core-updates specifically?

Because this rebuilds the world :(

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl2iJAIACgkQm9z0l6S7
zH/UjQf7BR8zS9G1YkMfR2pkIh64GdWinQXTeTNjAIFcPnue9Q0GsOmBqALCJEW8
u0Dbx+OSRbTfxONn07QNMiD6IUdAomwkm3XZJf7G5YkPeh0lwUlra4gZ2xqKZhat
2eSm01n2b3s7a5ze4tHUaoFq6vrEqgvguRihBhma2vbM305MAV1PzfawLQvrjaga
BlUdqbn5qNjI3GQQIGgYHWpuFahtk9bUYYP2lWhk/P6O7IZ2GslK256krx8D7Xgb
zqmeFVsMnXVt8FbnS2rSbqwXhm72+J9NhtbDVleI5Hs73fSqJL381fVlIasI8HQJ
a/zhWPWyoN1s8OFyeGhOQ2h8Gum1dQ==
=w+8Q
-----END PGP SIGNATURE-----

E
E
Efraim Flashner wrote on 12 Oct 2019 21:12
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)
20191012191215.GE13364@E5400
On Sat, Oct 12, 2019 at 09:05:38PM +0200, Pierre Neidhardt wrote:
Toggle quote (11 lines)
> Cc-ing Nicolas since he was part of the discussion:
> https://lists.gnu.org/archive/html/guix-devel/2019-05/msg00404.html
>
> Efraim Flashner <efraim@flashner.co.il> writes:
>
> > The wrapping is wrong at the very top, it should be under the 'e' in
> > define.
>
> You mean the indentation? I'm not sure what's wrong, could you write a snippet?
>

Yeah, I did mean indentation. I meant that it should be

(define* (...
next-line-here

but then I checked guix/build/utils and saw that all the other ones are
indented the way you have it so keep it :).

Toggle quote (5 lines)
> > Why core-updates specifically?
>
> Because this rebuilds the world :(
>

Ah, that's unfortunate


--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAl2iJYsACgkQQarn3Mo9
g1H1ZQ//d9Y+o7mLUZW6yk/MFXA82N18uNElzOLUsDtLouQUeLXzKo1tWjdQstus
QRkk2PbN9CFKLh/FaSuhSCd8ILD9e5cyQl0q/R56YsPnfdlsTmgEUV1cylmAiqMb
ij/PU6YapHgF9Ijkt074l3nd3ZANnn6mumIFovVJpDSl+F7loipxLbnmWn28QNtm
PMMXGA63TnUJ1DzRQGH4iJ+wNzi5KUtvuHwQFDZ4Y+yfVsMs+fHeLK2XlGun9Fgp
zNt7B8qmHhvzbl+m9Tm/79DEiGewdcof8GJEwuuKmUjdRmCky4PT+CDS8sHXtPrH
A8EaT+4aKzm+VFouY26xOdm4h8MfnjpE4WMaBbGOFKD0TIepH1J9mV9b7wT4ysL7
DK20aoyd2iueTCXSGDai2ndeA8JiXxpapPbBbEn+y5OikkgqDINM1s6SqGtosqVm
omLbuSp4a3S0SiF9h0bTX0seXOvy5sHno5BFurwAS48kOQkC9Xht+wUQaduL4Rif
i8eQR+cs9KwZi5mkyzWoSJHhjnaEdXCX2EGXKBaXcF4uzWrVzimTd/n6ig4asAIG
Oc1Hqh6xFZgWKHoNZKR7GaJkxdIaqJWBGipZ1dp1RPMC1hO5RwbScC/MFiB4Ygpy
nxmI9vawkYPexbejwirZfIe5q9zaOqgoyvxfzexB1FZeuY8Be84=
=uMpG
-----END PGP SIGNATURE-----


P
P
Pierre Neidhardt wrote on 18 Oct 2019 10:43
(name . Efraim Flashner)(address . efraim@flashner.co.il)
87k192l9yp.fsf@ambrevar.xyz
So shall I merge it on staging then?

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl2pe04ACgkQm9z0l6S7
zH+s8wf/UwoqhodXVZvi7P0zU2MTgw1WWtdP8EZL9fHqEbEmullcVvf1Iea4/GGK
8WPteyls+f97oskfES9VGOz1wBhgQ7fRxltAW2YiN8RDHK1rW9CQqX76tnzuyUxn
D84hHu24aWAMz1E3sUCs95JJRN9dfxuHN8iS+M3zIhVRd10If7otfH9F3vdruRx8
NMVRf8fYk5I3r2flWqUTkJIMnNiy2wAM0YrrwxySEoK2GNNunnWODUcBXIoLUJk8
R9Ze7XFx+3WyPFbq5dp/ZnF7nfRn3BSSEY76zOY5JPYDk9A1x8BX+NEMZW7NlSpk
ez6g1ppshXsQURbSwgoHCZBRbKRWuQ==
=zibA
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 18 Oct 2019 16:40
(name . Pierre Neidhardt)(address . mail@ambrevar.xyz)
87v9smyv5e.fsf@gnu.org
Hi,

Pierre Neidhardt <mail@ambrevar.xyz> skribis:

Toggle quote (2 lines)
> So shall I merge it on staging then?

I think ‘staging’ is in fact pretty much ready, no? Marius?


Ludo’.
M
M
Marius Bakke wrote on 18 Oct 2019 17:10
87imomytrp.fsf@devup.no
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (10 lines)
> Hi,
>
> Pierre Neidhardt <mail@ambrevar.xyz> skribis:
>
>> So shall I merge it on staging then?
>
> I think ‘staging’ is in fact pretty much ready, no? Marius?
>
> https://ci.guix.gnu.org/jobset/staging-staging

Indeed, it will be merged within a day or two and is currently only
taking bugfixes.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl2p1csACgkQoqBt8qM6
VPpi7QgAj1PsruXh0azP0chky1X9oSVjKyveqF8G29Zt1SGGPAtin2V/PBaGEWEy
qvqlUXWWwIh5+vRQzCUQRuwtNAjhNzrtLuVZjTZVkne5P6rgXl8CEf6sMD0yxl81
hUl+O8m+WDmkoW7vrd5W54gNsDEtCgEebTOUCOBsY0jDUr2Bk51dsC3Zi7JaHPwm
KZ9wXG4wuvN5IT0dVw+4AsM58ojC2GhtCXz9BnNJY1+KNzYF3RbkgSrZkSo8SaT+
mRqk7OcaG+CNjKWzDQM4xPLkkEsLU98ALMWWuXK+AN6hQsHLOkgKThZShLUa5lvV
LOmgfas9bKvdkFXMXst9xCeWIkNiDQ==
=3srz
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 18 Oct 2019 17:13
87ftjqytm0.fsf@devup.no
Pierre Neidhardt <mail@ambrevar.xyz> writes:

Toggle quote (2 lines)
> So shall I merge it on staging then?

This is world-rebuilding change, no? In that case it has to go through
'core-updates' as per the branch rebuild policy:


(it would be good to shorten that section a bit...)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl2p1pcACgkQoqBt8qM6
VPoF3Af/cgToWx5QiSF25TbNT51glKj0roQc1yGjNOolVp7CYro2m1/lPbDNmLY3
7opxd4wY0sBwu7l/d6fUsu79ozeKuT7v0Ti/oepHQMeVXZgQ+xvLxAW2LCyz9nt6
goMtKDBieaSJ+Qv5moBvVVP0/KqoIJ/EN69fHrIw9GRswUtDYZmXBZYhGjWj/qVL
qJi33yuHFRUyOdSOcE8WrAKlnwzbxmZezUqfxxKYo++IcYgM6lqllPJHcBKhVA3a
iBrsK5QRkNBlxTOxL2fz2x9jK18ned5t+EEMg4MQN62GukpZGunprmyyx01gUe6n
jUrnhlBxnsXnYYyJCi/blWNdPxz9Tw==
=WZW6
-----END PGP SIGNATURE-----

P
P
Pierre Neidhardt wrote on 18 Oct 2019 17:22
87y2xihyea.fsf@ambrevar.xyz
Sorry, my email this morning meant "core-updates", as per the other
comments in this thread!

So should I merge on core-updates then?

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl2p2J0ACgkQm9z0l6S7
zH+VVQf/dV6a50Pf2kU3IvM+fnWHvFfulVkcqHG5IQIBnnEWxoTASCfLZwUCEj2M
6y3xiAEMRAey4TB3MdMVlUH8oSif2dXjqpLPt9dShdIZ42RQ6n4K1RbOB9Enu1mr
+pkUqGez95cwxgSxNgdxqP+yBQgcOrksSA/0KQ2KBLqFvkfk9HGikT81AY9zCOBD
pL9EhdeIZGYyO6kXABxHnGFKdsj4me5o1huflUwlKrGP42B5CITOLje8/WWTQuLD
a553dDPrX24soPy2KLtY9VbqXVKJd5lNIcgJBtIcyh6hKiMwnAV/R/QFpcs3hAI9
dr3CmtmFgwMDH3MYaxNnpsDONWLcVQ==
=3NS1
-----END PGP SIGNATURE-----

M
M
Marius Bakke wrote on 18 Oct 2019 17:24
87d0euyt35.fsf@devup.no
Pierre Neidhardt <mail@ambrevar.xyz> writes:

Toggle quote (5 lines)
> Sorry, my email this morning meant "core-updates", as per the other
> comments in this thread!
>
> So should I merge on core-updates then?

If you think it is ready, go for it! :-)
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl2p2T4ACgkQoqBt8qM6
VPq4ggf9HpJP4qg/tFJI+ZbGqiQ/UOaizkO8wuv4eZk9VgPdYMZqFsoh/+TUzVB7
mLruVdyHYcLIiN74w3ZfjmLy0QQM/2fYCOkyHKQVSAeZGD7e3jHqUT306tb2I3ro
9/OU65IDNdlnzLPcQQINhVIFpKGKDTC/X84R3qHZTjHnc4yCcpU4l/aQMbWQ7vKp
e6i3B/l9UGV4uWfXXhOyyz0YERn4njDWawUUJFGIYjQlbsmLRjfxVVtVHvDzuBRu
/Z61Ho+sjP+1IFRHEx44zB1+hcJXp1vE/LtdZMS9jm2ewk1B6IGKmmHPCK3t6sZ7
WCbh4NwmwepchA85YBvU6hxPteNLLA==
=LZTm
-----END PGP SIGNATURE-----

P
P
Pierre Neidhardt wrote on 19 Oct 2019 12:46
87bludhv1x.fsf@ambrevar.xyz
Done, thanks!

--
Pierre Neidhardt
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAl2q6YoACgkQm9z0l6S7
zH9nhAf9Eb1c6fTi2VbDbK+65/MC3iIBmTZqY04d5nDdfMaV+0yUUhvpYcJbBLVq
NICMq176FD3Hp2/0EsC8ztQ0T67YLzVoNX4FNQ09Q4zH8mqftkxRvRDm4rQ5PNxk
7XyA1wXjaJF+dlWYHPtgxYdwE5S/WhEzL7L3WKPIJVZHVZi+Z68Y7TIbNrUQ0esZ
RXTz6UNllZZqrutRFHvbeHNrk3a4uK2UeQaaxtbHapiDbm37Jo0jJKWjhbWMq9U8
sTiMaJA+sBm2I2JzP9KAHKrLQSskPNPv7y8+zkhpBENXUIlIpT/KziBG0TWc//e4
Z08+ODr9arZc7hEiHSPGJAYN91IvvQ==
=1h6P
-----END PGP SIGNATURE-----

P
P
Pierre Neidhardt wrote on 19 Oct 2019 12:47
control message for bug #36000
(address . control@debbugs.gnu.org)
87a79xhv0p.fsf@ambrevar.xyz
close 36000
quit
?