(address . bug-guix@gnu.org)(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)
I've tried the installer today and it failed at the wifi selection,
printing a stack trace which allowed me to investigate. Since I could
not save it (shouldn't we dump it to a file by the way?), I've noted
down the following, roughly:
Toggle snippet (8 lines)
In /gnu/installer/newt/wifi.scm:
204: (run-wifi-page)
(filter ...:145 (service)...
(#<<service> name: "foo" type: "wifi" path: "wifi_d..." ...)
147: (_ #<<service name: #f ...)
(string-null? #f)
Apparently it fails because a wifi service name is #f.
I can think of two fixes (untested). In wifi.scm:
Toggle snippet (8 lines)
@@ -144,6 +144,7 @@ of <service-item> records present in LISTBOX."
(let ((services (connman-services)))
(filter (lambda (service)
(and (string=? (service-type service) "wifi")
+ (service-name service)
(not (string-null? (service-name service)))))
services)))
Or, more directly in connman.scm:
Toggle snippet (12 lines)
@@ -108,7 +108,8 @@
(define-record-type* <service>
service make-service
service?
- (name service-name) ; string
+ (name service-name
+ (default ""))
(type service-type) ; string
(path service-path) ; string
(strength service-strength) ; integer
-----BEGIN PGP SIGNATURE-----
iQEzBAEBCAAdFiEEUPM+LlsMPZAEJKvom9z0l6S7zH8FAlzs+FgACgkQm9z0l6S7
zH8YZggAlngA++B+PkbVOB9aku9vJAQSdI3y5+Fclza5rn13FtbkGITzBKQD+mr0
MGkF6vgTib74Z3Q8Lfy2Aitsr3H+nm1VdlUvPMrNuC88JEmZsE3HPtlbK/uMYqBo
uTD94589+BGEPuGy/hV/AJKnam2+dYhCEcbrK4FVgmHoDyBVbIqVzb/Fd/AawcjW
V8pfYtplMKK5TUxE64jx5SBO5WiZZbl9s1L4Iv4JCnU+yW6u+2Abt2A682tXxKXU
0MclWGlc+UAkYSzVvHJ4WRZ414eMd6DxOohqeP5XeEYnOUmZeI+NiStXfVv60pqq
yBkf6rhspR2P6bFb3wJbhanvTwrNeg==
=02pu
-----END PGP SIGNATURE-----