[PATCH] services: Add ‘/usr/bin/env ’ special file.
(address . guix-patches@gnu.org)
* gnu/services/base.scm (%base-services): Add ‘/usr/bin/env‘ to
special-files-service-type.
---
Guix,
I didn't even realise this was ‘missing’. Is there any reason not to include it next to /bin/sh?
Sure, it's not pure, but then why provide /bin/sh when nowadays /usr/bin/env is both more common, more flexible,>
Feel free to gently enlighten me.
Kind regards,
T G-R
gnu/services/base.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
Toggle diff (24 lines)
diff --git a/gnu/services/base.scm b/gnu/services/base.scm
index f709ca5519..444e48f137 100644
--- a/gnu/services/base.scm
+++ b/gnu/services/base.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2382,6 +2383,8 @@ to handle."
(service special-files-service-type
`(("/bin/sh" ,(file-append (canonical-package bash)
- "/bin/sh"))))))
+ "/bin/sh"))
+ ("/usr/bin/env" ,(file-append (canonical-package coreutils)
+ "/usr/bin/env"))))))
;;; base.scm ends here
--
2.21.0