[PATCH] gnu: Add mallard-ducktype

  • Done
  • quality assurance status badge
Details
2 participants
  • Jack Hill
  • Ludovic Courtès
Owner
unassigned
Submitted by
Jack Hill
Severity
normal
J
J
Jack Hill wrote on 17 May 2019 19:42
(address . guix-patches@gnu.org)
alpine.DEB.2.20.1905171341010.5164@marsh.hcoop.net
* gnu/packages/python-xyz.scm: (mallard-ducktype) new variable.
---
gnu/packages/python-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5322b70759..1c337e0685 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -59,6 +59,7 @@
;;; Copyright ᅵ 2018 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright ᅵ 2019 Brett Gilio <brettg@posteo.net>
;;; Copyright ᅵ 2019 Sam <smbaines8@gmail.com>
+;;; Copyright ᅵ 2019 Jack Hill <jackhill@jackhill.us>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3224,6 +3225,32 @@ Markdown input files, and more. Pelican uses Jinja2 for templating
and is very extensible.")
(license license:agpl3+)))

+(define-public mallard-ducktype
+ (package
+ (name "mallard-ducktype")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ ;; git-reference because a proper source tarball is not available
+ ;; https://lists.gnu.org/archive/html/guix-devel/2019-05/msg00209.html
+ (uri (git-reference
+ (url "https://github.com/projectmallard/mallard-ducktype.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0crland0kmpsyjfmnflcw7gaqy5b87b6ah17cmr9d5z1kyazf54n"))))
+ (build-system python-build-system)
+ (home-page "http://projectmallard.org")
+ (synopsis "Convert Ducktype to Mallard documentation markup")
+ (description
+ "Ducktype is a lightweight syntax that can represent all the semantics
+of the Mallard XML documentation system. Ducktype files can be converted to
+Mallard using the @command{ducktype} tool. The yelp-tools package
+provides additional functionality on the produced Mallard documents.")
+ (license license:expat)))
+
(define-public python-scikit-image
(package
(name "python-scikit-image")
--
2.21.0
L
L
Ludovic Courtès wrote on 21 May 2019 16:24
(name . Jack Hill)(address . jackhill@jackhill.us)(address . 35782-done@debbugs.gnu.org)
87zhnf28do.fsf@gnu.org
Hi,

Jack Hill <jackhill@jackhill.us> skribis:

Toggle quote (2 lines)
> * gnu/packages/python-xyz.scm: (mallard-ducktype) new variable.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 35782@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 35782
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch