(address . bug-guix@gnu.org)
Hi, I am having an issue with the docker daemon as a service in guixsd.
It seems that dockerd will not start on boot, but it will successfully
start after running "guix system reconfigure".
Here is my config.scm:
(use-modules (gnu)
(gnu system nss)
(gnu services)
(gnu services docker))
(use-service-modules desktop)
(use-package-modules certs gnome)
(operating-system
(host-name "guixsd")
(timezone "Europe/Oslo")
(locale "en_US.utf8")
(bootloader (bootloader-configuration
(bootloader grub-bootloader)
(target "/dev/sda")))
(file-systems (cons (file-system
(device (file-system-label "my-root"))
(mount-point "/")
(type "ext4"))
%base-file-systems))
(users (cons (user-account
(name "allana")
(group "users")
(supplementary-groups '("wheel" "docker" "netdev"
"audio" "video"))
(home-directory "/home/allana"))
%base-user-accounts))
;; This is where we specify system-wide packages.
(packages (cons* nss-certs ;for HTTPS access
gvfs ;for user mounts
%base-packages))
(services (cons* (console-keymap-service "no-latin1")
(gnome-desktop-service)
(service docker-service-type)
%desktop-services))
;; Allow resolution of '.local' host names with mDNS.
(name-service-switch %mdns-host-lookup-nss))
After booting:
allana@guixsd ~$ docker ps
Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is
the docker daemon running?
allana@guixsd ~$ sudo herd status dockerd
Password:
Status of dockerd:
It is stopped.
It is enabled.
Provides (dockerd).
Requires (containerd file-system-/sys/fs/cgroup/blkio
file-system-/sys/fs/cgroup/cpu file-system-/sys/fs/cgroup/cpuset
file-system-/sys/fs/cgroup/devices file-system-/sys/fs/cgroup/memory).
Conflicts with ().
Will be respawned.
allana@guixsd ~$ sudo herd start dockerd
Service dockerd could not be started.
herd: failed to start service dockerd
But if I run:
allana@guixsd ~$ sudo guix reconfigure config.scm
...
allana@guixsd ~$ docker ps
CONTAINER ID IMAGE COMMAND CREATED
STATUS PORTS NAMES
allana@guixsd ~$ sudo herd status dockerd
Password:
Status of dockerd:
It is started.
Running value is 2123.
It is enabled.
Provides (dockerd).
Requires (containerd file-system-/sys/fs/cgroup/blkio
file-system-/sys/fs/cgroup/cpu file-system-/sys/fs/cgroup/cpuset
file-system-/sys/fs/cgroup/devices file-system-/sys/fs/cgroup/memory).
Conflicts with ().
Will be respawned.
Dump from /var/log/messages:
Feb 5 10:06:37 localhost -- MARK --
Feb 5 10:15:47 localhost nscd: 319 monitored file `/etc/hosts` was
deleted, removing watch
Feb 5 10:15:47 localhost nscd: 319 monitored file `/etc/hosts` was
created, adding watch
Feb 5 10:15:47 localhost nscd: 319 monitored file `/etc/hosts` was
written to
Feb 5 10:15:47 localhost nscd: 319 monitored file `/etc/services` was
deleted, removing watch
Feb 5 10:15:47 localhost nscd: 319 monitored file `/etc/services` was
created, adding watch
Feb 5 10:15:47 localhost nscd: 319 monitored file `/etc/services` was
written to
Feb 5 10:15:47 localhost NetworkManager[355]: <info> [1549358147.5315]
settings: hostname changed from (none) to "guixsd"
Feb 5 10:15:48 localhost shepherd[1]: Evaluating user expression (let*
((services (map primitive-load (?))) # ?) ?).
Feb 5 10:15:48 localhost shepherd[1]: Service user-homes could not be
started.
Feb 5 10:15:48 localhost shepherd[1]: Service term-auto could not be
started.
Feb 5 10:15:49 localhost vmunix: [ 2965.192083] bridge: filtering via
arp/ip/ip6tables is no longer available by default. Update your scripts
to load br_netfilter if you need this.
Feb 5 10:15:49 localhost vmunix: [ 2965.194289] Bridge firewalling
registered
Feb 5 10:15:49 localhost vmunix: [ 2965.405743] Initializing XFRM
netlink socket
Feb 5 10:15:49 localhost NetworkManager[355]: <info> [1549358149.2361]
manager: (docker0): new Bridge device
(/org/freedesktop/NetworkManager/Devices/3)
Feb 5 10:15:49 localhost avahi-daemon[361]: Joining mDNS multicast
group on interface docker0.IPv4 with address 172.17.0.1.
Feb 5 10:15:49 localhost NetworkManager[355]: <info> [1549358149.3174]
device (docker0): state change: unmanaged -> unavailable (reason
'connection-assumed', internal state 'external')
Feb 5 10:15:49 localhost vmunix: [ 2965.500493] IPv6:
ADDRCONF(NETDEV_UP): docker0: link is not ready
Feb 5 10:15:49 localhost avahi-daemon[361]: New relevant interface
docker0.IPv4 for mDNS.
Feb 5 10:15:49 localhost NetworkManager[355]: <info> [1549358149.3195]
keyfile: add connection in-memory
(33e2c9e2-62a1-4439-8fb5-be99034ffc7b,"docker0")
Feb 5 10:15:49 localhost avahi-daemon[361]: Registering new address
record for 172.17.0.1 on docker0.IPv4.
Feb 5 10:15:49 localhost NetworkManager[355]: <info> [1549358149.3203]
device (docker0): state change: unavailable -> disconnected (reason
'connection-assumed', internal state 'external')
Feb 5 10:15:49 localhost NetworkManager[355]: <info> [1549358149.3223]
device (docker0): Activation: starting connection 'docker0'
(33e2c9e2-62a1-4439-8fb5-be99034ffc7b)
Feb 5 10:15:49 localhost NetworkManager[355]: <info> [1549358149.3236]
device (docker0): state change: disconnected -> prepare (reason 'none',
internal state 'external')
Feb 5 10:15:49 localhost NetworkManager[355]: <info> [1549358149.3243]
device (docker0): state change: prepare -> config (reason 'none',
internal state 'external')
Feb 5 10:15:49 localhost NetworkManager[355]: <info> [1549358149.3247]
device (docker0): state change: config -> ip-config (reason 'none',
internal state 'external')
Feb 5 10:15:49 localhost NetworkManager[355]: <warn> [1549358149.3321]
arping[0x82cc80,3]: arping could not be found; no ARPs will be sent
Feb 5 10:15:49 localhost NetworkManager[355]: <info> [1549358149.3322]
device (docker0): state change: ip-config -> ip-check (reason 'none',
internal state 'external')
Feb 5 10:15:49 localhost NetworkManager[355]: <info> [1549358149.3462]
device (docker0): state change: ip-check -> secondaries (reason 'none',
internal state 'external')
Feb 5 10:15:49 localhost NetworkManager[355]: <info> [1549358149.3508]
device (docker0): state change: secondaries -> activated (reason 'none',
internal state 'external')
Feb 5 10:15:49 localhost NetworkManager[355]: <info> [1549358149.3528]
device (docker0): Activation: successful, device activated.
Feb 5 10:15:49 localhost shepherd[1]: Service dockerd has been started.
Feb 5 10:15:51 localhost NetworkManager[355]: <warn> [1549358151.9250]
arping[0x82cc80,3]: arping could not be found; no ARPs will be sent
Feb 5 10:16:10 localhost shepherd[1]: Exiting shepherd...
Feb 5 10:16:10 localhost ntpd[356]: ntpd exiting on signal 15
(Terminated)
Feb 5 10:16:10 localhost ntpd[356]: 80.89.32.122 local addr 10.0.2.15
-> <null>
Feb 5 10:16:10 localhost ntpd[356]: 31.185.27.200 local addr 10.0.2.15
-> <null>
Feb 5 10:16:10 localhost ntpd[356]: 92.62.34.78 local addr 10.0.2.15 ->
<null>
Feb 5 10:16:10 localhost syslogd: exiting on signal 15
Feb 5 10:16:49 localhost syslogd (GNU inetutils 1.9.4): restart
Feb 5 10:16:49 localhost vmunix: [ 0.000000] Linux version
4.20.6-gnu (nixbld@) (gcc version 7.4.0 (GCC)) #1 SMP 1
Feb 5 10:16:49 localhost vmunix: [ 0.000000] Command line:
BOOT_IMAGE=/gnu/store/fnpq4ndcjyai0rqlgj8x02qwlm88fc9d-linux-libre-4.20.6/bzImage
--root=my-root
--system=/gnu/store/b93pw0x9z120bilhiicics30f5y8fgj6-system
--load=/gnu/store/b93pw0x9z120bilhiicics30f5y8fgj6-system/boot
Feb 5 10:16:49 localhost vmunix: [ 0.000000] KERNEL supported cpus:
Feb 5 10:16:49 localhost vmunix: [ 0.000000] Intel GenuineIntel
Feb 5 10:16:49 localhost vmunix: [ 0.000000] AMD AuthenticAMD
Feb 5 10:16:49 localhost vmunix: [ 0.000000] Hygon HygonGenuine
Feb 5 10:16:49 localhost vmunix: [ 0.000000] Centaur CentaurHauls
Feb 5 10:16:49 localhost vmunix: [ 0.000000] x86/fpu: Supporting
XSAVE feature 0x001: 'x87 floating point registers'
Feb 5 10:16:49 localhost vmunix: [ 0.000000] x86/fpu: Supporting
XSAVE feature 0x002: 'SSE registers'
Feb 5 10:16:49 localhost vmunix: [ 0.000000] x86/fpu: Supporting
XSAVE feature 0x004: 'AVX registers'
Feb 5 10:16:49 localhost vmunix: [ 0.000000] x86/fpu:
xstate_offset[2]: 576, xstate_sizes[2]: 256
Feb 5 10:16:49 localhost vmunix: [ 0.000000] x86/fpu: Enabled xstate
features 0x7, context size is 832 bytes, using 'standard' format.
Feb 5 10:16:49 localhost vmunix: [ 0.000000] BIOS-provided physical
RAM map:
Feb 5 10:16:49 localhost vmunix: [ 0.000000] BIOS-e820: [mem
0x0000000000000000-0x000000000009fbff] usable
Feb 5 10:16:49 localhost vmunix: [ 0.000000] BIOS-e820: [mem
0x000000000009fc00-0x000000000009ffff] reserved
Feb 5 10:16:49 localhost vmunix: [ 0.000000] BIOS-e820: [mem
0x00000000000f0000-0x00000000000fffff] reserved
Feb 5 10:16:49 localhost vmunix: [ 0.000000] BIOS-e820: [mem
0x0000000000100000-0x00000000dffeffff] usable
Feb 5 10:16:49 localhost vmunix: [ 0.000000] BIOS-e820: [mem
0x00000000dfff0000-0x00000000dfffffff] ACPI data
Feb 5 10:16:49 localhost vmunix: [ 0.000000] BIOS-e820: [mem
0x00000000fec00000-0x00000000fec00fff] reserved
Feb 5 10:16:49 localhost vmunix: [ 0.000000] BIOS-e820: [mem
0x00000000fee00000-0x00000000fee00fff] reserved
Feb 5 10:16:49 localhost vmunix: [ 0.000000] BIOS-e820: [mem
0x00000000fffc0000-0x00000000ffffffff] reserved
Feb 5 10:16:49 localhost vmunix: [ 0.000000] BIOS-e820: [mem
0x0000000100000000-0x000000019fffffff] usable
Feb 5 10:16:49 localhost vmunix: [ 0.000000] NX (Execute Disable)
protection: active
Feb 5 10:16:49 localhost vmunix: [ 0.000000] SMBIOS 2.5 present.
Feb 5 10:16:49 localhost vmunix: [ 0.000000] DMI: innotek GmbH
VirtualBox/VirtualBox, BIOS VirtualBox 12/01/2006
Feb 5 10:16:49 localhost vmunix: [ 0.000000] Hypervisor detected:
KVM
Feb 5 10:16:49 localhost vmunix: [ 0.000000] kvm-clock: Using msrs
4b564d01 and 4b564d00
Feb 5 10:16:49 localhost shepherd[1]: Service syslogd has been started.
Feb 5 10:16:49 localhost vmunix: [ 0.000001] kvm-clock: cpu 0, msr
13a574001, primary cpu clock
Feb 5 10:16:49 localhost vmunix: [ 0.000001] kvm-clock: using sched
offset of 5879650815 cycles
Feb 5 10:16:49 localhost vmunix: [ 0.000006] clocksource: kvm-clock:
mask: 0xffffffffffffffff max_cycles: 0x1cd42e4dffb, max_idle_ns:
881590591483 ns
Feb 5 10:16:49 localhost vmunix: [ 0.000012] tsc: Detected 2904.004
MHz processor
Feb 5 10:16:49 localhost vmunix: [ 0.004133] last_pfn = 0x1a0000
max_arch_pfn = 0x400000000
Feb 5 10:16:49 localhost vmunix: [ 0.004164] Disabled
Feb 5 10:16:49 localhost vmunix: [ 0.004167] x86/PAT: MTRRs
disabled, skipping PAT initialization too.
Feb 5 10:16:49 localhost vmunix: [ 0.004174] CPU MTRRs all blank -
virtualized system.
Feb 5 10:16:49 localhost vmunix: [ 0.004182] x86/PAT: Configuration
[0-7]: WB WT UC- UC WB WT UC- UC
Feb 5 10:16:49 localhost vmunix: [ 0.004192] last_pfn = 0xdfff0
max_arch_pfn = 0x400000000
Feb 5 10:16:49 localhost shepherd[1]: Service loopback has been
started.
Feb 5 10:16:49 localhost vmunix: [ 0.004273] found SMP MP-table at
[mem 0x0009fff0-0x0009ffff] mapped at [(____ptrval____)]
Feb 5 10:16:49 localhost vmunix: [ 0.140871] check: Scanning 1 areas
for low memory corruption
Feb 5 10:16:49 localhost vmunix: [ 0.141648] RAMDISK: [mem
0x36a51000-0x3751ffff]
Feb 5 10:16:49 localhost vmunix: [ 0.141660] ACPI: Early table
checksum verification disabled
Feb 5 10:16:49 localhost vmunix: [ 0.141686] ACPI: RSDP
0x00000000000E0000 000024 (v02 VBOX )
Feb 5 10:16:49 localhost shepherd[1]: Service virtual-terminal has been
started.
Feb 5 10:16:49 localhost vmunix: [ 0.141695] ACPI: XSDT
0x00000000DFFF0030 00003C (v01 VBOX VBOXXSDT 00000001 ASL 00000061)
Feb 5 10:16:49 localhost vmunix: [ 0.141702] ACPI: FACP
0x00000000DFFF00F0 0000F4 (v04 VBOX VBOXFACP 00000001 ASL 00000061)
Feb 5 10:16:49 localhost vmunix: [ 0.141708] ACPI: DSDT
0x00000000DFFF0470 0021FF (v02 VBOX VBOXBIOS 00000002 INTL 20100528)
Feb 5 10:16:49 localhost vmunix: [ 0.141712] ACPI: FACS
0x00000000DFFF0200 000040
Feb 5 10:16:49 localhost vmunix: [ 0.141716] ACPI: FACS
0x00000000DFFF0200 000040
Feb 5 10:16:49 localhost vmunix: [ 0.141719] ACPI: APIC
0x00000000DFFF0240 00005C (v02 VBOX VBOXAPIC 00000001 ASL 00000061)
Feb 5 10:16:49 localhost vmunix: [ 0.141723] ACPI: SSDT
0x00000000DFFF02A0 0001CC (v01 VBOX VBOXCPUT 00000002 INTL 20100528)
Feb 5 10:16:49 localhost vmunix: [ 0.141963] No NUMA configuration
found
Feb 5 10:16:49 localhost vmunix: [ 0.141966] Faking a node at [mem
0x0000000000000000-0x000000019fffffff]
Feb 5 10:16:49 localhost vmunix: [ 0.141970] NODE_DATA(0) allocated
[mem 0x19fffa000-0x19fffdfff]
Feb 5 10:16:49 localhost vmunix: [ 0.142680] Zone ranges:
Feb 5 10:16:49 localhost vmunix: [ 0.142684] DMA32 [mem
0x0000000000001000-0x00000000ffffffff]
Feb 5 10:16:49 localhost shepherd[1]: Service term-tty6 has been
started.
Feb 5 10:16:49 localhost vmunix: [ 0.142686] Normal [mem
0x0000000100000000-0x000000019fffffff]
Feb 5 10:16:49 localhost vmunix: [ 0.142688] Device empty
Feb 5 10:16:49 localhost vmunix: [ 0.142690] Movable zone start for
each node
Feb 5 10:16:49 localhost vmunix: [ 0.142692] Early memory node
ranges
Feb 5 10:16:49 localhost vmunix: [ 0.142694] node 0: [mem
0x0000000000001000-0x000000000009efff]
Feb 5 10:16:49 localhost vmunix: [ 0.142695] node 0: [mem
0x0000000000100000-0x00000000dffeffff]
Feb 5 10:16:49 localhost vmunix: [ 0.142697] node 0: [mem
0x0000000100000000-0x000000019fffffff]
Feb 5 10:16:49 localhost vmunix: [ 0.143870] Zeroed struct page in
unavailable ranges: 114 pages
Feb 5 10:16:49 localhost vmunix: [ 0.143873] Initmem setup node 0
[mem 0x0000000000001000-0x000000019fffffff]
Feb 5 10:16:49 localhost vmunix: [ 0.225477] ACPI: PM-Timer IO Port:
0x4008
Feb 5 10:16:49 localhost shepherd[1]: Service term-tty5 has been
started.
Feb 5 10:16:49 localhost vmunix: [ 0.225571] IOAPIC[0]: apic_id 2,
version 32, address 0xfec00000, GSI 0-23
Feb 5 10:16:49 localhost vmunix: [ 0.225576] ACPI: INT_SRC_OVR (bus
0 bus_irq 0 global_irq 2 dfl dfl)
Feb 5 10:16:49 localhost vmunix: [ 0.225578] ACPI: INT_SRC_OVR (bus
0 bus_irq 9 global_irq 9 low level)
Feb 5 10:16:49 localhost vmunix: [ 0.225585] Using ACPI (MADT) for
SMP configuration information
Feb 5 10:16:49 localhost vmunix: [ 0.225593] smpboot: Allowing 2
CPUs, 0 hotplug CPUs
Feb 5 10:16:49 localhost vmunix: [ 0.225614] PM: Registered nosave
memory: [mem 0x00000000-0x00000fff]
Feb 5 10:16:49 localhost vmunix: [ 0.225617] PM: Registered nosave
memory: [mem 0x0009f000-0x0009ffff]
Feb 5 10:16:49 localhost vmunix: [ 0.225619] PM: Registered nosave
memory: [mem 0x000a0000-0x000effff]
Feb 5 10:16:49 localhost vmunix: [ 0.225621] PM: Registered nosave
memory: [mem 0x000f0000-0x000fffff]
Feb 5 10:16:49 localhost vmunix: [ 0.225623] PM: Registered nosave
memory: [mem 0xdfff0000-0xdfffffff]
Feb 5 10:16:49 localhost vmunix: [ 0.225625] PM: Registered nosave
memory: [mem 0xe0000000-0xfebfffff]
Feb 5 10:16:49 localhost vmunix: [ 0.225627] PM: Registered nosave
memory: [mem 0xfec00000-0xfec00fff]
Feb 5 10:16:49 localhost shepherd[1]: Service term-tty4 has been
started.
Feb 5 10:16:49 localhost vmunix: [ 0.225629] PM: Registered nosave
memory: [mem 0xfec01000-0xfedfffff]
Feb 5 10:16:49 localhost vmunix: [ 0.225631] PM: Registered nosave
memory: [mem 0xfee00000-0xfee00fff]
Feb 5 10:16:49 localhost vmunix: [ 0.225633] PM: Registered nosave
memory: [mem 0xfee01000-0xfffbffff]
Feb 5 10:16:49 localhost vmunix: [ 0.225635] PM: Registered nosave
memory: [mem 0xfffc0000-0xffffffff]
Feb 5 10:16:49 localhost vmunix: [ 0.225638] [mem
0xe0000000-0xfebfffff] available for PCI devices
Feb 5 10:16:49 localhost vmunix: [ 0.225640] Booting paravirtualized
kernel on KVM
Feb 5 10:16:49 localhost vmunix: [ 0.225645] clocksource:
refined-jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns:
7645519600211568 ns
Feb 5 10:16:49 localhost vmunix: [ 0.225656] random:
get_random_bytes called from start_kernel+0x99/0x51c with crng_init=0
Feb 5 10:16:49 localhost vmunix: [ 0.225662] setup_percpu:
NR_CPUS:256 nr_cpumask_bits:256 nr_cpu_ids:2 nr_node_ids:1
Feb 5 10:16:49 localhost vmunix: [ 0.226183] percpu: Embedded 45
pages/cpu @(____ptrval____) s146840 r8192 d29288 u1048576
Feb 5 10:16:49 localhost shepherd[1]: Service term-tty3 has been
started.
Feb 5 10:16:49 localhost vmunix: [ 0.226218] PV qspinlock hash table
entries: 256 (order: 0, 4096 bytes)
Feb 5 10:16:49 localhost vmunix: [ 0.226224] Built 1 zonelists,
mobility grouping on. Total pages: 1548154
Feb 5 10:16:49 localhost vmunix: [ 0.226226] Policy zone: Normal
Feb 5 10:16:49 localhost vmunix: [ 0.226229] Kernel command line:
BOOT_IMAGE=/gnu/store/fnpq4ndcjyai0rqlgj8x02qwlm88fc9d-linux-libre-4.20.6/bzImage
--root=my-root
--system=/gnu/store/b93pw0x9z120bilhiicics30f5y8fgj6-system
--load=/gnu/store/b93pw0x9z120bilhiicics30f5y8fgj6-system/boot
Feb 5 10:16:49 localhost vmunix: [ 0.252611] Memory:
6090508K/6291000K available (12293K kernel code, 1470K rwdata, 3984K
rodata, 1836K init, 2724K bss, 200492K reserved, 0K cma-reserved)
Feb 5 10:16:49 localhost vmunix: [ 0.253199] SLUB: HWalign=64,
Order=0-3, MinObjects=0, CPUs=2, Nodes=1
Feb 5 10:16:49 localhost vmunix: [ 0.253218] Kernel/User page tables
isolation: enabled
Feb 5 10:16:49 localhost vmunix: [ 0.253238] ftrace: allocating
39556 entries in 155 pages
Feb 5 10:16:49 localhost vmunix: [ 0.286687] rcu: Hierarchical RCU
implementation.
Feb 5 10:16:49 localhost shepherd[1]: Service term-tty2 has been
started.
Feb 5 10:16:49 localhost vmunix: [ 0.286691] rcu: RCU restricting
CPUs from NR_CPUS=256 to nr_cpu_ids=2.
Feb 5 10:16:49 localhost vmunix: [ 0.286694] rcu: RCU calculated
value of scheduler-enlistment delay is 25 jiffies.
Feb 5 10:16:49 localhost vmunix: [ 0.286695] rcu: Adjusting geometry
for rcu_fanout_leaf=16, nr_cpu_ids=2
Feb 5 10:16:49 localhost vmunix: [ 0.291153] NR_IRQS: 16640,
nr_irqs: 440, preallocated irqs: 16
Feb 5 10:16:49 localhost vmunix: [ 0.306506] Console: colour VGA+
80x25
Feb 5 10:16:49 localhost vmunix: [ 0.351776] printk: console [tty0]
enabled
Feb 5 10:16:49 localhost vmunix: [ 0.352163] ACPI: Core revision
20181003
Feb 5 10:16:49 localhost vmunix: [ 0.352640] APIC: Switch to
symmetric I/O mode setup
Feb 5 10:16:49 localhost vmunix: [ 0.353395] x2apic enabled
Feb 5 10:16:49 localhost vmunix: [ 0.354008] Switched APIC routing
to physical x2apic.
Feb 5 10:16:49 localhost vmunix: [ 0.355939] ..TIMER: vector=0x30
apic1=0 pin1=2 apic2=-1 pin2=-1
Feb 5 10:16:49 localhost vmunix: [ 0.356365] clocksource: tsc-early:
mask: 0xffffffffffffffff max_cycles: 0x29dc09beef1, max_idle_ns:
440795310252 ns
Feb 5 10:16:49 localhost vmunix: [ 0.357056] Calibrating delay loop
(skipped) preset value.. 5808.00 BogoMIPS (lpj=11616016)
Feb 5 10:16:49 localhost vmunix: [ 0.357657] pid_max: default: 32768
minimum: 301
Feb 5 10:16:49 localhost vmunix: [ 0.357979] LSM: Security Framework
initializing
Feb 5 10:16:49 localhost shepherd[1]: Service term-tty1 has been
starte
This message was truncated. Download the full message here.