tests/upstream.scm fails on master

  • Done
  • quality assurance status badge
Details
4 participants
  • Chris Marusich
  • Ludovic Courtès
  • Maxim Cournoyer
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Chris Marusich
Severity
normal
C
C
Chris Marusich wrote on 28 Jan 2019 07:49
(address . bug-guix@gnu.org)
871s4x9sze.fsf@gmail.com
Hi,

At v0.16.0-1516-g86228e569 (current master branch head), the
upstream.scm test fails with the following log:

Toggle snippet (36 lines)
FAIL: tests/upstream
====================

test-name: coalesce-sources same version
location: /home/marusich/guix/tests/upstream.scm:27
source:
+ (test-equal
+ "coalesce-sources same version"
+ (list (upstream-source
+ (package "foo")
+ (version "1")
+ (urls '("ftp://example.org/foo-1.tar.xz"
+ "ftp://example.org/foo-1.tar.gz"))
+ (signature-urls
+ '("ftp://example.org/foo-1.tar.xz.sig"
+ "ftp://example.org/foo-1.tar.gz.sig"))))
+ (coalesce-sources
+ (list (upstream-source
+ (package "foo")
+ (version "1")
+ (urls '("ftp://example.org/foo-1.tar.gz"))
+ (signature-urls
+ '("ftp://example.org/foo-1.tar.gz.sig")))
+ (upstream-source
+ (package "foo")
+ (version "1")
+ (urls '("ftp://example.org/foo-1.tar.xz"))
+ (signature-urls
+ '("ftp://example.org/foo-1.tar.xz.sig"))))))
expected-value: (#<<upstream-source> package: "foo" version: "1" urls: ("ftp://example.org/foo-1.tar.xz" "ftp://example.org/foo-1.tar.gz") signature-urls: ("ftp://example.org/foo-1.tar.xz.sig" "ftp://example.org/foo-1.tar.gz.sig") input-changes: #<procedure d8a360 at ice-9/eval.scm:330:13 ()>>)
actual-value: (#<<upstream-source> package: "foo" version: "1" urls: ("ftp://example.org/foo-1.tar.xz" "ftp://example.org/foo-1.tar.gz") signature-urls: ("ftp://example.org/foo-1.tar.xz.sig" "ftp://example.org/foo-1.tar.gz.sig") input-changes: #<procedure db3360 at ice-9/eval.scm:330:13 ()>>)
result: FAIL

random seed for tests: 1548664767

--
Chris
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEy/WXVcvn5+/vGD+x3UCaFdgiRp0FAlxOpgYACgkQ3UCaFdgi
Rp2ozBAAt7yroLoU7qy/seKGH1FEQunUEYbgfyfxZhVL7fknjLYCVhnm6C66Uz1H
U87XTRUf6gYBWf9ESte6wnCteKlUkHHu9ziMOv/qn9OrlOz4d7DFYgM6qMkAP64E
v+5QSY9HBHRzEM29n4tqGE2w8yE6ivUKrug9R7rqVJivDH3Lqi9unAGMM54obUfL
5a03cMjlmOPuYTq8ys+f3XlpX/f3qds/XjbwbgJxQpzeJHhvDtDD7L/fRs2L51na
APPZpCYEgK3/CGhW1UJeV49iq1g9YDrglcyllsCzkQ4IIzkt8o9mmJEjIX/uYxVj
G4SD+HgCcGmwJjjN1HiAR1AGOpTgPNMD/UtDCT3pZIosgZ5by9OzKqAe2fl5iryY
FRQ8zLtXDinzIqmVm4zmlRN1yplvq2NJH9wNEsHEzHPxzpactc+a7pbb0iKFszGa
i4XPMiZRuoJmtpaFDv6QICy0YVFi/lcVQbg8QNBkhWpPOSbdCo/ogHAffS/SMZwF
Db0L9PgYsO/2YJ/5vfjipVpruSLF7Z2dXNN7aHDDyJsbep2YI1wJLtN59U6m8c3Z
dCMt66oUMKw3CtPcD4gRnrZodqtZlY4VEyOUxv2YcQF/W5tnUKW6RxgJ5O6/qZmR
Em4GhBaAOjPNCh0p+AEiQ5I15Kc71mnXf9cy7CxD3NyBIFOw1M4=
=U1Ku
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 28 Jan 2019 13:49
(name . Chris Marusich)(address . cmmarusich@gmail.com)(address . 34229@debbugs.gnu.org)
87o981rloz.fsf@gnu.org
Hello,

Chris Marusich <cmmarusich@gmail.com> skribis:

Toggle quote (36 lines)
> At v0.16.0-1516-g86228e569 (current master branch head), the
> upstream.scm test fails with the following log:
>
> FAIL: tests/upstream
> ====================
>
> test-name: coalesce-sources same version
> location: /home/marusich/guix/tests/upstream.scm:27
> source:
> + (test-equal
> + "coalesce-sources same version"
> + (list (upstream-source
> + (package "foo")
> + (version "1")
> + (urls '("ftp://example.org/foo-1.tar.xz"
> + "ftp://example.org/foo-1.tar.gz"))
> + (signature-urls
> + '("ftp://example.org/foo-1.tar.xz.sig"
> + "ftp://example.org/foo-1.tar.gz.sig"))))
> + (coalesce-sources
> + (list (upstream-source
> + (package "foo")
> + (version "1")
> + (urls '("ftp://example.org/foo-1.tar.gz"))
> + (signature-urls
> + '("ftp://example.org/foo-1.tar.gz.sig")))
> + (upstream-source
> + (package "foo")
> + (version "1")
> + (urls '("ftp://example.org/foo-1.tar.xz"))
> + (signature-urls
> + '("ftp://example.org/foo-1.tar.xz.sig"))))))
> expected-value: (#<<upstream-source> package: "foo" version: "1" urls: ("ftp://example.org/foo-1.tar.xz" "ftp://example.org/foo-1.tar.gz") signature-urls: ("ftp://example.org/foo-1.tar.xz.sig" "ftp://example.org/foo-1.tar.gz.sig") input-changes: #<procedure d8a360 at ice-9/eval.scm:330:13 ()>>)
> actual-value: (#<<upstream-source> package: "foo" version: "1" urls: ("ftp://example.org/foo-1.tar.xz" "ftp://example.org/foo-1.tar.gz") signature-urls: ("ftp://example.org/foo-1.tar.xz.sig" "ftp://example.org/foo-1.tar.gz.sig") input-changes: #<procedure db3360 at ice-9/eval.scm:330:13 ()>>)
> result: FAIL

Ricardo is working on it. ;-)

Ludo’.
R
R
Ricardo Wurmus wrote on 28 Jan 2019 09:42
(name . Chris Marusich)(address . cmmarusich@gmail.com)(address . 34229@debbugs.gnu.org)
87zhrlqiku.fsf@elephly.net
Chris Marusich <cmmarusich@gmail.com> writes:

Toggle quote (3 lines)
> At v0.16.0-1516-g86228e569 (current master branch head), the
> upstream.scm test fails with the following log:

This is due to the changes in #34040 because one of the fields is now a
procedure. We’re discussing at #34040 how to change this.

--
Ricardo
M
M
Maxim Cournoyer wrote on 13 Jul 2022 17:12
(name . Ricardo Wurmus)(address . rekado@elephly.net)
87fsj5yrlb.fsf@gmail.com
Hi,

Ricardo Wurmus <rekado@elephly.net> writes:

Toggle quote (8 lines)
> Chris Marusich <cmmarusich@gmail.com> writes:
>
>> At v0.16.0-1516-g86228e569 (current master branch head), the
>> upstream.scm test fails with the following log:
>
> This is due to the changes in #34040 because one of the fields is now a
> procedure. We’re discussing at #34040 how to change this.

I see this is fixed. Closing.

Thanks!

Maxim
Closed
?