[PATCH python-team] gnu: Add python-tatsu.

  • Open
  • quality assurance status badge
Details
One participant
  • gemmaro
Owner
unassigned
Submitted by
gemmaro
Severity
normal

Debbugs page

gemmaro wrote 5 hours ago
(address . guix-patches@gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
ad5cd69f8b96e289f5e4972e3f1ccc535991b26a.1741941808.git.gemmaro.dev@gmail.com
* gnu/packages/python-xyz.scm (python-tatsu): New variable.

Change-Id: I0868e5ec57bc384b2dad2114671b780c988d77d4
---
gnu/packages/python-xyz.scm | 25 ++++++++++++++++++++++++-
1 file changed, 24 insertions(+), 1 deletion(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 01c6322931..5a4e6455e5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -141,7 +141,7 @@
;;; Copyright © 2023 Dominik Delgado Steuter <d@delgado.nrw>
;;; Copyright © 2023 Ivan Vilata-i-Balaguer <ivan@selidor.net>
;;; Copyright © 2023 Ontje Lünsdorf <ontje.luensdorf@dlr.de>
-;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2023, 2025 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2023 Parnikkapore <poomklao@yahoo.com>
;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
;;; Copyright © c4droid <c4droid@foxmail.com>
@@ -37215,6 +37215,29 @@ (define-public python-taskgroup
@code{asyncio.Runner} and @code{asyncio.timeout}.")
(license license:expat)))
+(define-public python-tatsu
+ (package
+ (name "python-tatsu")
+ (version "5.13.1")
+ (source
+ (origin
+ (method git-fetch) ;for tests
+ (uri (git-reference
+ (url "https://github.com/neogeny/TatSu")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0pdq9d45vbp7j600ig4k21mv2wipvmz05dji91x7kifhzfl5i6w9"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-setuptools python-wheel python-pytest))
+ (home-page "https://tatsu.readthedocs.io/en/stable/")
+ (synopsis "PEG/Packrat Parser generator for Python")
+ (description
+ "TatSu (竜) takes a grammar in a variation of Extended Backus-Naur Form
+(EBNF) as input, and outputs a memoizing Parsing Expression Grammar
+(PEG) or Packrat parser in Python.")
+ (license license:bsd-4)))
+
(define-public python-csb43
(package
(name "python-csb43")

base-commit: f73ece09ab3c1bd0d367eb343426ebc3c8d41190
--
2.48.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 77008@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 77008
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help