King, Spencer wrote 14 hours ago
(name . King, Spencer via Guix-patches via)(address . guix-patches@gnu.org)(name . efraim@flashner.co.il)(address . efraim@flashner.co.il)(name . zimon.toutoune@gmail.com)(address . zimon.toutoune@gmail.com)
From af3c0def53144efd5ad1c3ba4dbb7f5905d77e15 Mon Sep 17 00:00:00 2001
From: Spencer King <spencer.king@wustl.edu>
Date: Sun, 9 Mar 2025 18:54:39 -0500
Subject: [PATCH] gnu: Add julia-clausenfunctions.
* gnu/packages/julia-xyz.scm (julia-clausenfunctions): New variable.
Change-Id: Ifaaafc14e27d6a3ec9ac0fa987b7da048f9325c6
---
gnu/packages/julia-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
Toggle diff (38 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index f875f345dd..03bbb8e70f 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1104,6 +1104,29 @@ (define-public julia-changesofvariables
transformations).")
(license license:expat)))
+(define-public julia-clausenfunctions
+ (package
+ (name "julia-clausenfunctions")
+ (version "1.16.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Expander/ClausenFunctions.jl")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0vwzbx3nykm6zv4hkpwhfhc0x58zafn8s9xlw6xlj4glaf0v11sk"))))
+ (build-system julia-build-system)
+ (propagated-inputs (list julia-polylog))
+ (home-page "https://github.com/Expander/ClausenFunctions.jl")
+ (synopsis "Clausen functions in Julia")
+ (description
+ "This package provides Julia implementations of the
+Standard Clausen functions and Glaisher-Clausen functions of integer
+order for real or complex arguments.")
+ (license license:expat)))
+
(define-public julia-codeczlib
(package
(name "julia-codeczlib")
base-commit: 591d2492e8517220db57098a6c9d1242533a8c8f
--
2.41.0