[PATCH] gnu: Add cxxmatrix.

  • Open
  • quality assurance status badge
Details
One participant
  • Andrew Wong
Owner
unassigned
Submitted by
Andrew Wong
Severity
normal

Debbugs page

Andrew Wong wrote 12 hours ago
(address . guix-patches@gnu.org)(name . Andrew Wong)(address . wongandj@icloud.com)
d610423eef334c7bdd11e49f04786467dcb77151.1741737722.git.wongandj@icloud.com
* gnu/packages/toys.scm (cxxmatrix): New variable.

Change-Id: I3298b90b65f363b56ee32c9e24ce4639e6501e80
---
gnu/packages/toys.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index f0284ad9d6..11699b19ca 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -103,6 +103,34 @@ (define-public cbonsai
creates, colors, and positions a bonsai tree, and is configurable.")
(license license:gpl3+))))
+(define-public cxxmatrix
+ (package
+ (name "cxxmatrix")
+ (version "2024.6.17")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/akinomyoga/cxxmatrix")
+ (commit "c8d4ecfb8b6c22bb93f3e10a9d203209ba193591")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0shlh0kbx5169pk1i72ymyyfadywyzmw4f95hn0lm8irjynizzg5"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list #:tests? #f ;no tests
+ #:make-flags #~(list (string-append "PREFIX=" #$output))
+ #:phases #~(modify-phases %standard-phases (delete 'configure))))
+ (home-page "https://github.com/akinomyoga/cxxmatrix")
+ (synopsis "Configurable \"The Matrix\" digital rain effect and more")
+ (description
+ "This package displays a \"digital rain\" effect from the 1999 film
+\"The Matrix\" in the terminal with authentic hankaku kana characters
+and bloom effects, as well as rotating/zooming mandelbrot set and
+Conway's game of life effects. Title text and color are
+configurable.")
+ (license license:expat)))
+
(define-public daikichi
(package
(name "daikichi")

base-commit: c10ca0d37a640000d09e42766123088041431e6c
--
2.48.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76965@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76965
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help