[PATCH] gnu: python-anyio: Disable keyboardinterrupt for aarch64-linux native builds.

  • Open
  • quality assurance status badge
Details
One participant
  • Zacchaeus Scheffer
Owner
unassigned
Submitted by
Zacchaeus Scheffer
Severity
normal

Debbugs page

Zacchaeus Scheffer wrote 15 hours ago
(address . guix-patches@gnu.org)
87a59ri6ik.fsf@zacchae.us
From c9cc1e2f14034472ddbf6975301e52edb82eee49 Mon Sep 17 00:00:00 2001
From: Zacchaeus <eikcaz@zacchae.us>
Date: Mon, 10 Mar 2025 17:20:57 -0700
Subject: [PATCH] gnu: python-anyio: Disable keyboardinterrupt for
aarch64-linux native builds.

*gnu/packages/python-xyz.scm: (python-anyio): Disable keyboardinterrupt test
during native aarch64-linux builds.

Change-Id: I21a20262fdf6d538fd2deda5c42441695fa24eea
---

The python-anyio package already disables
`test_keyboardinterrupt_during_test` when cross-compiling to
aarch64-linux. This issue is not specific to cross-compilation and also
fails when natively compiling on aarch64-linux machines (--system=
instead of --target=). This patch adds support for natively building
python-anyio on aarch64-linux by disabling that test in such cases.

eikcaz-

gnu/packages/python-xyz.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4cb7c72a82..887bceb53d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -32272,7 +32272,8 @@ (define-public python-anyio
,@(cond
((or (target-aarch64?)
- (target-riscv64?))
+ (target-riscv64?)
+ (string=? "aarch64-linux" (%current-system)))
'(" and not test_keyboardinterrupt_during_test"))
(#t '()))
--
2.48.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76962@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76962
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help