[sysadmin-team PATCH 0/8] Update spdlog.

  • Open
  • quality assurance status badge
Details
3 participants
  • Greg Hogan
  • Maxim Cournoyer
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal

Debbugs page

Greg Hogan wrote 5 days ago
(address . guix-patches@gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
cover.1741724364.git.code@greghogan.com
All dependent packages build except rxcpp, which is broken on master.

Greg Hogan (8):
gnu: spdlog: Update to 1.15.1.
gnu: Add spdlog-1.13.
gnu: gerbera: Pin spdlog.
gnu: gr-satellites: Pin spdlog.
gnu: kddockwidgets: Pin spdlog.
gnu: mtxclient: Pin spdlog.
gnu: nheko: Pin spdlog.
gnu: waybar: Pin spdlog.

gnu/packages/logging.scm | 17 +++++++++++++++--
gnu/packages/messaging.scm | 4 ++--
gnu/packages/qt.scm | 2 +-
gnu/packages/radio.scm | 2 +-
gnu/packages/upnp.scm | 2 +-
gnu/packages/wm.scm | 2 +-
6 files changed, 21 insertions(+), 8 deletions(-)


base-commit: 3bf7a0e8c431abfcba51806ee2a3eea9e0865472
--
2.48.1
Greg Hogan wrote 5 days ago
[sysadmin-team PATCH 1/8] gnu: spdlog: Update to 1.15.1.
(address . 76960@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
fdcf767ae53eebca311f973b52c3af1ef7b62026.1741724364.git.code@greghogan.com
* gnu/packages/logging.scm (spdlog): Update to 1.15.1.

Change-Id: I2458a03792b967fcf6761aa31b302d041a0abe3e
---
gnu/packages/logging.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 9cc28279d7e..53eb94176d2 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -239,7 +239,7 @@ (define-public multitail
(define-public spdlog
(package
(name "spdlog")
- (version "1.13.0")
+ (version "1.15.1")
(source
(origin
(method git-fetch)
@@ -248,7 +248,7 @@ (define-public spdlog
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0zgdmdgnp2y36jrlk85d4fiyjkjd6anly8pambyc3f3v6sg02zyy"))))
+ (base32 "1drpbn7b6iikypdlsvzpcjwyls0rqzl7sz7f7xjbn3d7ic55a1p1"))))
(build-system cmake-build-system)
;; TODO run benchmark. Currently not possible, as adding
;; (gnu packages benchmark) forms a dependency cycle
--
2.48.1
Greg Hogan wrote 5 days ago
[sysadmin-team PATCH 2/8] gnu: Add spdlog-1.13.
(address . 76960@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
615722455ac339e603adaed6ee94c038216bc363.1741724364.git.code@greghogan.com
* gnu/packages/logging.scm (spdlog-1.13): New variable.

Change-Id: I17dead76668a98854f6a5e9b0dc15e0d2016c03c
---
gnu/packages/logging.scm | 13 +++++++++++++
1 file changed, 13 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 53eb94176d2..b5431566fe4 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -268,6 +268,19 @@ (define-public spdlog
;; "include/spdlog/fmt/bundled" is under BSD 2 clause license.
(license (list license:expat license:bsd-2))))
+(define-public spdlog-1.13
+ (package/inherit spdlog
+ (version "1.13.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gabime/spdlog")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name (package-name spdlog) version))
+ (sha256
+ (base32 "0zgdmdgnp2y36jrlk85d4fiyjkjd6anly8pambyc3f3v6sg02zyy"))))))
+
(define-public spdlog-1.10
(package
(inherit spdlog)
--
2.48.1
Greg Hogan wrote 5 days ago
[sysadmin-team PATCH 3/8] gnu: gerbera: Pin spdlog.
(address . 76960@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
905ee4a94e4613186e5f05932f86c52fbae9e498.1741724364.git.code@greghogan.com
* gnu/packages/upnp.scm (gerbera)[inputs]: Replace spdlog with
spdlog-1.13.

Change-Id: Ibfee95b9824aedb9174fa5749ed793dfc56d9b31
---
gnu/packages/upnp.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
index e49c39ef574..035d58344dd 100644
--- a/gnu/packages/upnp.scm
+++ b/gnu/packages/upnp.scm
@@ -213,7 +213,7 @@ (define-public gerbera
libmatroska
libupnp
pugixml
- spdlog
+ spdlog-1.13
sqlite
taglib
`(,util-linux "lib")
--
2.48.1
Greg Hogan wrote 5 days ago
[sysadmin-team PATCH 4/8] gnu: gr-satellites: Pin spdlog.
(address . 76960@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
307218432f614b008acc0c5143f63d878a5ab4be.1741724364.git.code@greghogan.com
* gnu/packages/radio.scm (gr-satellites)[inputs]: Replace spdlog with
spdlog-1.13.

Change-Id: I964c1dc3370eb0c3cec7b433b6611a7143b78c31
---
gnu/packages/radio.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index b0cae57d1de..d39003cf702 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1181,7 +1181,7 @@ (define-public gr-satellites
python-pyaml
python-pyzmq
python-requests
- spdlog
+ spdlog-1.13
volk))
(arguments
`(#:modules ((guix build cmake-build-system)
--
2.48.1
Greg Hogan wrote 5 days ago
[sysadmin-team PATCH 5/8] gnu: kddockwidgets: Pin spdlog.
(address . 76960@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
c0721847df9e2441761c87b1929125814f9b7971.1741724364.git.code@greghogan.com
* gnu/packages/qt.scm (kddockwidgets)[inputs]: Replace spdlog with
spdlog-1.13.

Change-Id: I082e22d50235fbbf92910f07eb66f3cfad5502db
---
gnu/packages/qt.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 13893d29513..e1a3e356dfd 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -332,7 +332,7 @@ (define-public kddockwidgets
nlohmann-json
qtbase
qtdeclarative
- spdlog
+ spdlog-1.13
libxkbcommon))
(home-page "https://github.com/KDAB/KDDockWidgets")
(synopsis "KDAB's Dock Widget Framework for Qt")
--
2.48.1
Greg Hogan wrote 5 days ago
[sysadmin-team PATCH 6/8] gnu: mtxclient: Pin spdlog.
(address . 76960@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
9c21370ae77c607452c2a6e470228e250a0daeb3.1741724364.git.code@greghogan.com
* gnu/packages/messaging.scm (mtxclient)[inputs]: Replace spdlog with
spdlog-1.13.

Change-Id: I686a1640adf7686d5bb260f9f40a8fc965067e70
---
gnu/packages/messaging.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index b8971e436e8..b5b62e8a943 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2448,7 +2448,7 @@ (define-public mtxclient
olm
openssl
re2
- spdlog
+ spdlog-1.13
zlib))
(native-inputs
(list googletest pkg-config))
--
2.48.1
Greg Hogan wrote 5 days ago
[sysadmin-team PATCH 7/8] gnu: nheko: Pin spdlog.
(address . 76960@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
4c2faef5cb303423c2a65e5ed6eeef58089a25a9.1741724364.git.code@greghogan.com
* gnu/packages/messaging.scm (nheko)[inputs]: Replace spdlog with
spdlog-1.13.

Change-Id: I53831319b74e96821c204306657f953b503b4689
---
gnu/packages/messaging.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index b5b62e8a943..755409b6d7f 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2527,7 +2527,7 @@ (define-public nheko
qtwayland
qtsvg
re2
- spdlog
+ spdlog-1.13
vulkan-headers
vulkan-loader
xdg-utils ; xdg-open for opening URLs
--
2.48.1
Greg Hogan wrote 5 days ago
[sysadmin-team PATCH 8/8] gnu: waybar: Pin spdlog.
(address . 76960@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
f2a4e06204c89de11ae43d19ddda39913525e6ec.1741724364.git.code@greghogan.com
* gnu/packages/wm.scm (waybar)[inputs]: Replace spdlog with spdlog-1.13.

Change-Id: I4fb89935b001d468742a07611c71207d7b936ae9
---
gnu/packages/wm.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 1eca2847ce6..2d11d20fa05 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2483,7 +2483,7 @@ (define-public waybar
pipewire
playerctl
pulseaudio
- spdlog
+ spdlog-1.13
wayland
wireplumber))
(native-inputs
--
2.48.1
Maxim Cournoyer wrote 5 days ago
Re: [bug#76960] [sysadmin-team PATCH 0/8] Update spdlog.
(name . Greg Hogan)(address . code@greghogan.com)(address . 76960@debbugs.gnu.org)
8734fifm3g.fsf@gmail.com
Hi Greg,

Greg Hogan <code@greghogan.com> writes:

Toggle quote (12 lines)
> All dependent packages build except rxcpp, which is broken on master.
>
> Greg Hogan (8):
> gnu: spdlog: Update to 1.15.1.
> gnu: Add spdlog-1.13.
> gnu: gerbera: Pin spdlog.
> gnu: gr-satellites: Pin spdlog.
> gnu: kddockwidgets: Pin spdlog.
> gnu: mtxclient: Pin spdlog.
> gnu: nheko: Pin spdlog.
> gnu: waybar: Pin spdlog.

We usually keep one change per patch, but in cases where we know that
there is breakage and how to fix it, it's nicer to combine the changes
in one atomic commit to ensure all the packages remain working on any
give commit (could be useful while travelling with 'guix time-machine'
for example).

Could you squash the series and submit as v2? Thanks!

--
Thanks,
Maxim
Greg Hogan wrote 10 hours ago
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 76960@debbugs.gnu.org)
CA+3U0ZkFau+QrFvf9tF5R4-dFSfeEMZ3baQxK=s37u-HkGmrcQ@mail.gmail.com
On Wed, Mar 12, 2025 at 8:52 AM Maxim Cournoyer
<maxim.cournoyer@gmail.com> wrote:
Toggle quote (29 lines)
>
> Hi Greg,
>
> Greg Hogan <code@greghogan.com> writes:
>
> > All dependent packages build except rxcpp, which is broken on master.
> >
> > Greg Hogan (8):
> > gnu: spdlog: Update to 1.15.1.
> > gnu: Add spdlog-1.13.
> > gnu: gerbera: Pin spdlog.
> > gnu: gr-satellites: Pin spdlog.
> > gnu: kddockwidgets: Pin spdlog.
> > gnu: mtxclient: Pin spdlog.
> > gnu: nheko: Pin spdlog.
> > gnu: waybar: Pin spdlog.
>
> We usually keep one change per patch, but in cases where we know that
> there is breakage and how to fix it, it's nicer to combine the changes
> in one atomic commit to ensure all the packages remain working on any
> give commit (could be useful while travelling with 'guix time-machine'
> for example).
>
> Could you squash the series and submit as v2? Thanks!
>
> --
> Thanks,
> Maxim

Maxim,

Thank you for the recommendation. I can certainly see this as two
multi-package patches:
1) updating a package while leaving the old version pinned (spdlog)
2) the same trivial update to multiple packages (the six dependent packages)

And this would simplify the commit logs and reduce the mailing list
traffic. But it doesn't seem practical to squash all updates into the
original breaking commit. When updating glibc or gcc the core-packages
team fixes hundreds of packages, and the kde and gnome updates
similarly make changes across dozens of packages. More useful than
random hopping with time-machine would be scheduled releases (or
marking the span or end of each patchset with the patch ID).

Greg
Greg Hogan wrote 9 hours ago
[PATCH 1/2] gnu: spdlog: Update to 1.15.1.
(address . 76960@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
4afc3dd190b07fc719ba218adfacceb6f7ba1214.1742145224.git.code@greghogan.com
* gnu/packages/logging.scm (spdlog): Update to 1.15.1.
(spdlog-1.13): New variable.

Change-Id: I2458a03792b967fcf6761aa31b302d041a0abe3e
---
gnu/packages/logging.scm | 17 +++++++++++++++--
1 file changed, 15 insertions(+), 2 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 9cc28279d7e..b5431566fe4 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -239,7 +239,7 @@ (define-public multitail
(define-public spdlog
(package
(name "spdlog")
- (version "1.13.0")
+ (version "1.15.1")
(source
(origin
(method git-fetch)
@@ -248,7 +248,7 @@ (define-public spdlog
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0zgdmdgnp2y36jrlk85d4fiyjkjd6anly8pambyc3f3v6sg02zyy"))))
+ (base32 "1drpbn7b6iikypdlsvzpcjwyls0rqzl7sz7f7xjbn3d7ic55a1p1"))))
(build-system cmake-build-system)
;; TODO run benchmark. Currently not possible, as adding
;; (gnu packages benchmark) forms a dependency cycle
@@ -268,6 +268,19 @@ (define-public spdlog
;; "include/spdlog/fmt/bundled" is under BSD 2 clause license.
(license (list license:expat license:bsd-2))))
+(define-public spdlog-1.13
+ (package/inherit spdlog
+ (version "1.13.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gabime/spdlog")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name (package-name spdlog) version))
+ (sha256
+ (base32 "0zgdmdgnp2y36jrlk85d4fiyjkjd6anly8pambyc3f3v6sg02zyy"))))))
+
(define-public spdlog-1.10
(package
(inherit spdlog)

base-commit: 8a565a8ff1c2150b778b5fdf8aa3a5f59a3fce9d
--
2.48.1
Greg Hogan wrote 9 hours ago
[PATCH 2/2] gnu: Pin spdlog.
(address . 76960@debbugs.gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
9c4759568295cbc4d7332b423cf75c5350d38298.1742145224.git.code@greghogan.com
* gnu/packages/messaging.scm (mtxclient, nheko),
* gnu/packages/qt.scm (kddockwidgets),
* gnu/packages/radio.scm (gr-satellites),
* gnu/packages/upnp.scm (gerbera),
* gnu/packages/wm.scm (waybar)
[inputs]: Replace spdlog with spdlog-1.13.

Change-Id: Ibfee95b9824aedb9174fa5749ed793dfc56d9b31
---
gnu/packages/messaging.scm | 4 ++--
gnu/packages/qt.scm | 2 +-
gnu/packages/radio.scm | 2 +-
gnu/packages/upnp.scm | 2 +-
gnu/packages/wm.scm | 2 +-
5 files changed, 6 insertions(+), 6 deletions(-)

Toggle diff (76 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index fa8aa13fbf1..6a1ae0fb7af 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2446,7 +2446,7 @@ (define-public mtxclient
olm
openssl
re2
- spdlog
+ spdlog-1.13
zlib))
(native-inputs
(list googletest pkg-config))
@@ -2525,7 +2525,7 @@ (define-public nheko
qtwayland
qtsvg
re2
- spdlog
+ spdlog-1.13
vulkan-headers
vulkan-loader
xdg-utils ; xdg-open for opening URLs
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 13893d29513..e1a3e356dfd 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -332,7 +332,7 @@ (define-public kddockwidgets
nlohmann-json
qtbase
qtdeclarative
- spdlog
+ spdlog-1.13
libxkbcommon))
(home-page "https://github.com/KDAB/KDDockWidgets")
(synopsis "KDAB's Dock Widget Framework for Qt")
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index b0cae57d1de..d39003cf702 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1181,7 +1181,7 @@ (define-public gr-satellites
python-pyaml
python-pyzmq
python-requests
- spdlog
+ spdlog-1.13
volk))
(arguments
`(#:modules ((guix build cmake-build-system)
diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
index e49c39ef574..035d58344dd 100644
--- a/gnu/packages/upnp.scm
+++ b/gnu/packages/upnp.scm
@@ -213,7 +213,7 @@ (define-public gerbera
libmatroska
libupnp
pugixml
- spdlog
+ spdlog-1.13
sqlite
taglib
`(,util-linux "lib")
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 1eca2847ce6..2d11d20fa05 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2483,7 +2483,7 @@ (define-public waybar
pipewire
playerctl
pulseaudio
- spdlog
+ spdlog-1.13
wayland
wireplumber))
(native-inputs
--
2.48.1
Greg Hogan wrote 9 hours ago
Re: [bug#76960] [sysadmin-team PATCH 0/8] Update spdlog.
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 76960@debbugs.gnu.org)
CA+3U0ZkikoGd0HgY3JTrLXUqQhPEDBt-=XP+KgE+P340cHKzOA@mail.gmail.com
On Sun, Mar 16, 2025 at 12:44 PM Greg Hogan <code@greghogan.com> wrote:
Toggle quote (49 lines)
>
> On Wed, Mar 12, 2025 at 8:52 AM Maxim Cournoyer
> <maxim.cournoyer@gmail.com> wrote:
> >
> > Hi Greg,
> >
> > Greg Hogan <code@greghogan.com> writes:
> >
> > > All dependent packages build except rxcpp, which is broken on master.
> > >
> > > Greg Hogan (8):
> > > gnu: spdlog: Update to 1.15.1.
> > > gnu: Add spdlog-1.13.
> > > gnu: gerbera: Pin spdlog.
> > > gnu: gr-satellites: Pin spdlog.
> > > gnu: kddockwidgets: Pin spdlog.
> > > gnu: mtxclient: Pin spdlog.
> > > gnu: nheko: Pin spdlog.
> > > gnu: waybar: Pin spdlog.
> >
> > We usually keep one change per patch, but in cases where we know that
> > there is breakage and how to fix it, it's nicer to combine the changes
> > in one atomic commit to ensure all the packages remain working on any
> > give commit (could be useful while travelling with 'guix time-machine'
> > for example).
> >
> > Could you squash the series and submit as v2? Thanks!
> >
> > --
> > Thanks,
> > Maxim
>
> Maxim,
>
> Thank you for the recommendation. I can certainly see this as two
> multi-package patches:
> 1) updating a package while leaving the old version pinned (spdlog)
> 2) the same trivial update to multiple packages (the six dependent packages)
>
> And this would simplify the commit logs and reduce the mailing list
> traffic. But it doesn't seem practical to squash all updates into the
> original breaking commit. When updating glibc or gcc the core-packages
> team fixes hundreds of packages, and the kde and gnome updates
> similarly make changes across dozens of packages. More useful than
> random hopping with time-machine would be scheduled releases (or
> marking the span or end of each patchset with the patch ID).
>
> Greg

And immediately after sending a v2 I realized that I forgot to add the
v2 tag to the subject-prefix.
Sharlatan Hellseher wrote 6 hours ago
[sysadmin-team PATCH 0/8] Update spdlog.
(address . 76960@debbugs.gnu.org)(address . code@greghogan.com)
8734fcvha7.fsf@gmail.com
Hi Greg,

Just a question of interest (not a review as the patches look quite
trivial), why we need to pin lower version of spdlog? Is there any
option to try to refresh dependent packages if it helps keep away from
lower version?

--
Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQJKBAEBCgA0FiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmfXN8AWHHNoYXJsYXRh
bnVzQGdtYWlsLmNvbQAKCRB21ye/9izStfWwD/4lK8rURLC1iS40v3jfpVjWeLrn
sF8SWMrkUiYTDAvsBQVkdp/ejQNkuGjoeOlbBBVIpk5HMiMTDAxIvzl8uxNVQIFb
3FAcqDYQqCKpqpYf5Fbbe9G4sWZLWUvKEklwXkS7XTt8UZ5l6DoZzJ82yGrT+dwe
3c3FSGFRgSi/j+ycxGtOqX+iUZlQLXpmV6NBAMy3kdKDUsshZcBskyp/QIFklg28
zz9ny00dAa1gTc1JHXFVvO8nC1IJP/caYHpQpAKMUoWSj0Nt8VQHS8t9FRyw1/Fi
bG244wTmffznEXfRkHqVoADGJ68zJArw8N+zllIXZ3JYOa5eGDszwGcdOo98qfJn
oIsm1nzCGjwtLrF7DZBNY4KBdUwMe8WIjBJ2InqazKreVlEOSiQLoefF/yHttt15
MdZNC/XX+AOQNGNcJIxdxa8CsRt+ThcfCfd+YqIf7Hgf+Y7fy+AHy3e1zkJiVOWf
HMfrCIJJhAiKLbfPrJM1UH08VPrTFc1N+r7Ph6spV9VvlfQpvG6Yw9173oHowghQ
Jlz3T0m7jzs6iHLrIyQtqFaoBUAi6UXvRCnJvliL/R3gfhet0zsqOxn22JU8nC3U
g5ptNjEfhNtvP51gJPnLcQuoaeolMrFiXywyXU9kEzaLWViK2IhFLzE+JGlnsd0K
5VCSXzybp92KFgmkKg==
=wS3X
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76960@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76960
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help