[PATCH] updated j4-dmenu-desktop to 3.2

  • Open
  • quality assurance status badge
Details
One participant
  • Jodi D.
Owner
unassigned
Submitted by
Jodi D.
Severity
normal

Debbugs page

Jodi D. wrote 20 hours ago
(address . guix-patches@gnu.org)(name . Jodi D.)(address . jodijodingtondev@gmail.com)
20250311155241.15426-2-jodijodingtondev@gmail.com
Change-Id: I5b01b9171c5a977c3167b1a9139b1c7667975163
---
note: when cross-compiling, three checks seem to fail on both aarch64-linux and armhf-linux and I don't know how to fix it nor if the issue is caused by the tests running via qemu
I am hoping someone can help me figure out how to fix that

relevant check phase output:
The following tests FAILED:
50 - Test FileFinder (Failed)
59 - Test I3Exec (Subprocess aborted)
67 - Test detection of file creation and deletion of a subdirectory of watched directory (Failed)

gnu/packages/xdisorg.scm | 49 +++++++++++++++++++++-------------------
1 file changed, 26 insertions(+), 23 deletions(-)

Toggle diff (73 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 5fd0685c7c..df145a2e0e 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -161,6 +161,8 @@ (define-module (gnu packages xdisorg)
#:use-module (gnu packages wm)
#:use-module (gnu packages webkit)
#:use-module (gnu packages xorg)
+ #:use-module (gnu packages logging)
+ #:use-module (gnu packages pretty-print)
#:use-module (gnu packages)
#:use-module (ice-9 match))
@@ -3496,31 +3498,32 @@ (define-public kbdd
(define-public j4-dmenu-desktop
(package
(name "j4-dmenu-desktop")
- (version "2.18")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/enkore/j4-dmenu-desktop")
- (commit (string-append "r" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1gxpgifzy0hnpd0ymw3r32amzr32z3bgb90ldjzl438p6h1q0i26"))))
+ (version "3.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/enkore/j4-dmenu-desktop")
+ (commit "fb7ba9e3ee6de575377c295b54474049e399b5ac")))
+ (sha256
+ (base32 "15jlb0si77sndnl5annys0dq2gkwwvzn1d2jwjay9i3xdivzmfb2"))))
(build-system cmake-build-system)
- (native-inputs
- (list catch2))
+ (native-inputs (list catch2-3 spdlog fmt))
(arguments
- `(#:configure-flags '("-DWITH_GIT_CATCH=off")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'find-catch
- (lambda _
- (substitute* "CMakeLists.txt"
- (("PATH_SUFFIXES catch") "PATH_SUFFIXES catch2"))
- #t))
- (replace 'check
- (lambda _
- (invoke "./j4-dmenu-tests" "exclude:SearchPath/XDG_DATA_HOME"))))))
+ (list
+ #:configure-flags '(list "-DNO_DOWNLOAD=ON")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-shell-path-in-tests
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((sh-path (string-append #$bash "/bin/sh")))
+ (begin
+ (substitute* "tests/ShellUnquote.cc"
+ (("/bin/sh")
+ sh-path))
+ (substitute* "tests/TestFieldCodes.cc"
+ (("/bin/sh")
+ sh-path)))))))))
(synopsis "Fast desktop menu")
(description
"j4-dmenu-desktop is a replacement for i3-dmenu-desktop. Its purpose

base-commit: 7b9cd0b4293041fdbfa065b019cea589cc316060
--
2.48.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76951@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76951
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help