[PATCH] gnu: gambas: Update to 3.20.2.

  • Open
  • quality assurance status badge
Details
One participant
  • iyzsong
Owner
unassigned
Submitted by
iyzsong
Severity
normal

Debbugs page

iyzsong wrote 25 hours ago
(address . guix-patches@gnu.org)(name . 宋文武)(address . iyzsong@member.fsf.org)
6390bef80e6e6eff7c3b7d3e2146370fb75533d2.1741693405.git.iyzsong@member.fsf.org
From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/gambas.scm (gambas): Update to 3.20.2.
[source]: Remove snippet.
[arguments]: Fix install-desktop-file phase.

Change-Id: I38884d0d0fc16d7ebcf97de9ab17e316251f11dc
---
gnu/packages/gambas.scm | 16 ++++------------
1 file changed, 4 insertions(+), 12 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/gambas.scm b/gnu/packages/gambas.scm
index caa5d0b31d..76a8b0cc9e 100644
--- a/gnu/packages/gambas.scm
+++ b/gnu/packages/gambas.scm
@@ -55,7 +55,7 @@ (define-module (gnu packages gambas)
(define-public gambas
(package
(name "gambas")
- (version "3.20.1")
+ (version "3.20.2")
(source
(origin
(method git-fetch)
@@ -64,13 +64,7 @@ (define-public gambas
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1fw3nark7vaw4vbmdvaaqb0an4838k0hhwwvc3dqd7f2033d41xq"))
- (modules '((guix build utils)))
- (snippet
- ;; Fix desktop file creation, upstream commit bbaa7b40.
- '(substitute* "comp/src/gb.gui.base/.src/_Gui.class"
- (("If sDir Begins [(]User\\.Home & \"/\"[)]" all)
- (string-append all " And If Access(sDir, gb.Write)"))))))
+ (base32 "060f8w19jf78mappqgy11873ss3h97gi47ga3c1ws1bazix9x7rk"))))
(build-system gnu-build-system)
(arguments
(list
@@ -122,10 +116,8 @@ (define-public gambas
(let* ((out (assoc-ref outputs "out"))
(appdir (string-append out "/share/applications"))
(icondir (string-append out "/share/pixmaps")))
- (install-file "app/desktop/gambas3.desktop"
- (string-append appdir "/gambas3.desktop"))
- (install-file "app/desktop/gambas3.png"
- (string-append icondir "/gambas3.png"))))))))
+ (install-file "app/desktop/gambas3.desktop" appdir)
+ (install-file "app/desktop/gambas3.png" icondir)))))))
(native-inputs
(list autoconf
automake

base-commit: 7b9cd0b4293041fdbfa065b019cea589cc316060
--
2.48.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76939@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76939
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help