[PATCH] gnu: supertuxkart: Keep 'supertuxkart.desktop' file.

  • Open
  • quality assurance status badge
Details
One participant
  • Nigko Yerden
Owner
unassigned
Submitted by
Nigko Yerden
Severity
normal

Debbugs page

Nigko Yerden wrote 26 hours ago
(address . guix-patches@gnu.org)(name . Nigko Yerden)(address . nigko.yerden@gmail.com)
f5ac094e724aece36b255f0e6a09453b002a1772.1741684979.git.nigko.yerden@gmail.com
* gnu/packages/games.scm (supertuxkart)[arguments]: Fix regexp in
'disable-data-install' phase so that the line in CMakeList.txt that installs
'supertuxkart.desktop' file is not commented out.

Change-Id: I408cdfeb9425c39228d38df4c15aee326e19dc34
---
gnu/packages/games.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index fd22b0243f..89e06a3a81 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4845,7 +4845,7 @@ (define-public supertuxkart
(add-before 'configure 'disable-data-install
(lambda _
(substitute* "CMakeLists.txt"
- (("^install\\(.*STK_DATA_DIR" &)
+ (("^install\\(DIRECTORY.*STK_DATA_DIR" &)
(string-append "# " &))))))))
(inputs
(list curl

base-commit: f70ad6267bf2bbafbf5eb0a1d04e2d624af796c5
--
2.48.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76936@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76936
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help