[mumi] [PATCH] README: Add instructions for initializing nested git submodules

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Rostislav Svoboda
Owner
unassigned
Submitted by
Rostislav Svoboda
Severity
normal

Debbugs page

Rostislav Svoboda wrote 2 days ago
(name . Rostislav Svoboda)(address . Rostislav.Svoboda@gmail.com)
20250310144601.17376-2-Rostislav.Svoboda@gmail.com
---
README.org | 9 +++++++--
1 file changed, 7 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/README.org b/README.org
index d36585c..66b7b13 100644
--- a/README.org
+++ b/README.org
@@ -5,8 +5,13 @@ frontend to Debbugs.
* Hacking
-To enter a development environment with all dependencies installed,
-run
+To initialize, fetch and checkout any nested submodules run
+
+#+BEGIN_SRC shell
+ $ git submodule update --init --recursive
+#+END_SRC
+
+To enter a development environment run
#+BEGIN_SRC shell
$ guix shell -D mumi
--
2.48.1
Rostislav Svoboda wrote 2 days ago
(address . 76919@debbugs.gnu.org)
CAEtmmeza+OeGW=9VaMQfgUxmnzVKz3-=MV5R-4oQ+BjHM-fzYg@mail.gmail.com
Hello,

For the record and for the sake of search engines: without the
assets/pico submodule, the build fails with the error below.

The run.sh script is something I wrote myself to automate the
instructions provided in the "Running a local instance of mumi"
section of README.org. Its contents are as follows:

```
#!/bin/sh

set -e # stop the script after any error
set -x # debug / trace execution steps

# 1. Copy some test mail data to be indexed:
cp -a tests/data data
# 2. Build mumi:
./bootstrap.sh
./configure
make
# 3. Have the test mail data indexed:
./pre-inst-env mumi fetch
# 4. Start the mumi instance:
./pre-inst-env mumi web --address=127.0.0.1
```

Cheers,
Bost


guix shell -D mumi
bost@ecke ~/dev/mumi [env]$ ./run.sh
+ cp -a tests/data data
+ ./bootstrap.sh
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force
autoreconf: configure.ac: tracing
autoreconf: configure.ac: not using Libtool
autoreconf: running:
/gnu/store/yx5k2gnkwpfaw3wc64f8b9bak9wd5cgr-autoconf-2.69/bin/autoconf
--force
autoreconf: configure.ac: not using Autoheader
autoreconf: running: automake --add-missing --copy --force-missing
autoreconf: Leaving directory `.'
+ ./configure
checking for a BSD-compatible install...
/gnu/store/0xmx7p8x5jymzm3fhdsl8qa02s1w7zx7-profile/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p...
/gnu/store/0xmx7p8x5jymzm3fhdsl8qa02s1w7zx7-profile/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether make supports nested variables... (cached) yes
checking for sassc...
/gnu/store/0xmx7p8x5jymzm3fhdsl8qa02s1w7zx7-profile/bin/sassc
checking for xdg-open...
/gnu/store/0xmx7p8x5jymzm3fhdsl8qa02s1w7zx7-profile/bin/xdg-open
checking for pkg-config...
/gnu/store/0xmx7p8x5jymzm3fhdsl8qa02s1w7zx7-profile/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
configure: checking for guile 3.0
configure: found guile 3.0
checking for guile-3.0... no
checking for guile3.0... no
checking for guile-3... no
checking for guile3... no
checking for guile...
/gnu/store/0xmx7p8x5jymzm3fhdsl8qa02s1w7zx7-profile/bin/guile
checking for Guile version >= 3.0... 3.0.9
checking for guild...
/gnu/store/0xmx7p8x5jymzm3fhdsl8qa02s1w7zx7-profile/bin/guild
checking for guile-config...
/gnu/store/0xmx7p8x5jymzm3fhdsl8qa02s1w7zx7-profile/bin/guile-config
checking if (email email) is available... yes
checking if (mailutils mailutils) is available... yes
checking if (gcrypt base64) is available... yes
checking if (redis) is available... yes
checking if (webutils sessions) is available... yes
checking if (xapian xapian) is available... yes
checking if (kolam graphql) is available... yes
checking if (avatar url) is available... yes
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating Makefile
config.status: creating mumi/config.scm
config.status: creating scripts/mumi
config.status: creating pre-inst-env
+ make
/gnu/store/0xmx7p8x5jymzm3fhdsl8qa02s1w7zx7-profile/bin/sassc
assets/mumi.scss assets/css/mumi.css
Error: File to import not found or unreadable: pico/scss/pico.
on line 9:1 of assets/mumi.scss
Toggle quote (2 lines)
>> @import "pico/scss/pico";

^
make: *** [Makefile:1306: assets/css/mumi.css] Error 65
Arun Isaac wrote 2 days ago
Manipulate bug 76919
(address . control@debbugs.gnu.org)
87jz8wrj7y.fsf@systemreboot.net
reassign 76919 mumi
tags 76919 + easy
thanks
Arun Isaac wrote 2 days ago
Re: [mumi] [PATCH] README: Add instructions for initializing nested git submodules
(address . 76919-done@debbugs.gnu.org)(name . Rostislav Svoboda)(address . rostislav.svoboda@gmail.com)
87frjkriyt.fsf@systemreboot.net
Thank you, Bost! Applied and pushed! :-)

Next time, send mumi patches to bug-mumi@gnu.org, instead of
guix-patches@gnu.org. Otherwise, all good.
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76919@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76919
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help