"dialect" package crashes gnome

  • Open
  • quality assurance status badge
Details
One participant
  • Ada Stevenson
Owner
unassigned
Submitted by
Ada Stevenson
Severity
normal

Debbugs page

Ada Stevenson wrote 2 days ago
(address . bug-guix@gnu.org)
349bc225-0df3-4dfd-83d3-4b58c5c52ef9@gmail.com
Hi Guix,

Including `dialect` in any of your profiles causes Gnome 46 to crash. I
believe this is due to the propagated inputs it puts into the profile it
is installed in. Attached is a minimal working config that reproduces
the issue.

--
Warmly,
Ada Stevenson
;; -*- mode: scheme; -*- ;; This is an operating system configuration for a VM image. ;; Modify it as you see fit and instantiate the changes by running: ;; ;; guix system reconfigure /etc/config.scm ;; (use-modules (gnu) (guix) (srfi srfi-1) (gnu home) (gnu home services) (gnu home services symlink-manager) (gnu home services shepherd) (gnu home services xdg) (gnu home services fontutils) (gnu home services admin) (gnu home services guix) (gnu home services shells) (gnu home services desktop)) (use-service-modules desktop mcron networking spice ssh xorg guix) (use-package-modules bootloaders fonts admin package-management xdisorg xorg gnome) (operating-system (host-name "gnu") (timezone "Etc/UTC") (locale "en_US.utf8") (keyboard-layout (keyboard-layout "us")) (firmware '()) ;; Below we assume /dev/vda is the VM's hard disk. ;; Adjust as needed. (bootloader (bootloader-configuration (bootloader grub-bootloader) (targets '("/dev/vda")))) (file-systems (cons (file-system (mount-point "/") (device "/dev/vda1") (type "ext4")) %base-file-systems)) (users (cons (user-account (name "guest") (comment "GNU Guix Live") (password (crypt "test" "$6$abc")) ;no password (group "users") (supplementary-groups '("wheel" "netdev" "audio" "video"))) %base-user-accounts)) (packages (append (specifications->packages (list "dialect")) %base-packages)) (services (cons* (service gnome-desktop-service-type) (service guix-home-service-type `(("guest" ,home-config))) ;; Add support for the SPICE protocol, which enables dynamic ;; resizing of the guest screen resolution, clipboard ;; integration with the host, etc. (service spice-vdagent-service-type) %desktop-services)) ;; Allow resolution of '.local' host names with mDNS. (name-service-switch %mdns-host-lookup-nss))
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76914@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76914
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help