Ada Stevenson wrote 2 days ago
(address . bug-guix@gnu.org)
Hi Guix,
Including `dialect` in any of your profiles causes Gnome 46 to crash. I
believe this is due to the propagated inputs it puts into the profile it
is installed in. Attached is a minimal working config that reproduces
the issue.
--
Warmly,
Ada Stevenson
;; -*- mode: scheme; -*-
;; This is an operating system configuration for a VM image.
;; Modify it as you see fit and instantiate the changes by running:
;;
;; guix system reconfigure /etc/config.scm
;;
(use-modules (gnu) (guix) (srfi srfi-1)
(gnu home)
(gnu home services)
(gnu home services symlink-manager)
(gnu home services shepherd)
(gnu home services xdg)
(gnu home services fontutils)
(gnu home services admin)
(gnu home services guix)
(gnu home services shells)
(gnu home services desktop))
(use-service-modules desktop mcron networking spice ssh xorg guix)
(use-package-modules bootloaders fonts admin
package-management xdisorg xorg gnome)
(operating-system
(host-name "gnu")
(timezone "Etc/UTC")
(locale "en_US.utf8")
(keyboard-layout (keyboard-layout "us"))
(firmware '())
;; Below we assume /dev/vda is the VM's hard disk.
;; Adjust as needed.
(bootloader (bootloader-configuration
(bootloader grub-bootloader)
(targets '("/dev/vda"))))
(file-systems (cons (file-system
(mount-point "/")
(device "/dev/vda1")
(type "ext4"))
%base-file-systems))
(users (cons (user-account
(name "guest")
(comment "GNU Guix Live")
(password (crypt "test" "$6$abc")) ;no password
(group "users")
(supplementary-groups '("wheel" "netdev"
"audio" "video")))
%base-user-accounts))
(packages (append (specifications->packages (list
"dialect"))
%base-packages))
(services
(cons* (service gnome-desktop-service-type)
(service guix-home-service-type
`(("guest" ,home-config)))
;; Add support for the SPICE protocol, which enables dynamic
;; resizing of the guest screen resolution, clipboard
;; integration with the host, etc.
(service spice-vdagent-service-type)
%desktop-services))
;; Allow resolution of '.local' host names with mDNS.
(name-service-switch %mdns-host-lookup-nss))