[PATCH] gnu: Add python-vsg.

  • Open
  • quality assurance status badge
Details
One participant
  • Cayetano Santos
Owner
unassigned
Submitted by
Cayetano Santos
Severity
normal

Debbugs page

Cayetano Santos wrote 2 days ago
(address . guix-patches@gnu.org)(name . Cayetano Santos)(address . csantosb@inventati.org)
ecc24b08bdfb53e8425eb163f3ede7454d288c12.1741603691.git.csantosb@inventati.org
* gnu/packages/electronics.scm (python-vsg): New variable.

Change-Id: I373fa187e7af7ad79e5d885574ee124183d37f9b
---
gnu/packages/electronics.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (57 lines)
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
index 93e37cf9ee..c4a70565cc 100644
--- a/gnu/packages/electronics.scm
+++ b/gnu/packages/electronics.scm
@@ -31,6 +31,7 @@ (define-module (gnu packages electronics)
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system pyproject)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
@@ -53,6 +54,8 @@ (define-module (gnu packages electronics)
#:use-module (gnu packages m4)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
+ #:use-module (gnu packages python-check)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages serialization)
#:use-module (gnu packages swig)
@@ -566,3 +569,31 @@ (define-public uhdm
"UHDM is a complete modeling of the IEEE SystemVerilog Object Model with
VPI Interface, Elaborator, Serialization, Visitor and Listener.")
(license license:asl2.0)))
+
+(define-public python-vsg
+ (package
+ (name "python-vsg")
+ (version "3.30.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jeremiah-c-leary/vhdl-style-guide/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0kgknd491s4ldmcw9s5j38frcfs55kxfifl52svy5q0vgg1qixq1"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-setuptools
+ python-wheel
+ ;; tests
+ python-coverage
+ python-pytest
+ python-pytest-cov
+ python-pytest-html
+ python-pytest-xdist))
+ (propagated-inputs (list python-pyyaml))
+ (home-page "https://github.com/jeremiah-c-leary/vhdl-style-guide/")
+ (synopsis "VHDL Style Guide")
+ (description "Style guide enforcement for VHDL.")
+ (license license:gpl3+)))

base-commit: 9866d32e173050ba99dc520b0a4d5aacb85e3fa0
--
2.48.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76913@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76913
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help