[PATCH 0/2] Improve senpai package integration and cleanup

  • Open
  • quality assurance status badge
Details
One participant
  • Luis Guilherme Coelho
Owner
unassigned
Submitted by
Luis Guilherme Coelho
Severity
normal

Debbugs page

Luis Guilherme Coelho wrote 3 days ago
(address . guix-patches@gnu.org)(name . Luis Guilherme Coelho)(address . lgcoelho@disroot.org)
cover.1741537589.git.lgcoelho@disroot.org
This patch series improves the senpai package by adding a desktop
file for better integration with desktop environments and cleaning
up redundant mkdir-p calls in the package definition.

Luis Guilherme Coelho (2):
gnu: senpai: Install desktop file.
gnu: senpai: Remove redundant mkdir-p calls.

gnu/packages/messaging.scm | 21 +++++++++++----------
1 file changed, 11 insertions(+), 10 deletions(-)


base-commit: a5256944a35e91be71b1348e805a341fe06cbb8d
--
2.48.1
Luis Guilherme Coelho wrote 3 days ago
[PATCH 1/2] gnu: senpai: Install desktop file.
(address . 76895@debbugs.gnu.org)(name . Luis Guilherme Coelho)(address . lgcoelho@disroot.org)
76c483d4e73abe4417ae9021ef7e79180746cb22.1741537589.git.lgcoelho@disroot.org
* gnu/packages/messaging.scm (senpai)[arguments]<#:phases>: Add
'install-desktop-file phase.

Change-Id: Ib2b84639a3bfa5ff211eda794a99370a1c39061c
---
gnu/packages/messaging.scm | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)

Toggle diff (20 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index d2bc9fcfac..a19673a463 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3722,7 +3722,12 @@ (define-public senpai
man1)
(install-file
(string-append "src/" unpack-path "/doc/senpai.5")
- man5)))))))
+ man5))))
+ (add-after 'install 'install-desktop-file
+ (lambda* (#:key unpack-path #:allow-other-keys)
+ (install-file
+ (string-append "src/" unpack-path "/contrib/senpai.desktop")
+ (string-append #$output "/share/applications")))))))
(native-inputs
(list go-git-sr-ht-emersion-go-scfg
go-github-com-delthas-go-libnp
--
2.48.1
Luis Guilherme Coelho wrote 3 days ago
[PATCH 2/2] gnu: senpai: Remove redundant mkdir-p calls.
(address . 76895@debbugs.gnu.org)(name . Luis Guilherme Coelho)(address . lgcoelho@disroot.org)
03f6bea456e6cd8303ad69df74b25bacac758f8d.1741537589.git.lgcoelho@disroot.org
* gnu/packages/messaging.scm (senpai)[arguments]<#:phases>:
{install-doc}: Remove unecessary mkdir-p calls.

Change-Id: I819561888579e86fc9f8e534d54fb79240fe2f09
---
gnu/packages/messaging.scm | 16 ++++++----------
1 file changed, 6 insertions(+), 10 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index a19673a463..04dd0afbc8 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3713,16 +3713,12 @@ (define-public senpai
"-C" (string-append "src/" unpack-path))))
(add-after 'install 'install-doc
(lambda* (#:key unpack-path #:allow-other-keys)
- (let ((man1 (string-append #$output "/share/man/man1"))
- (man5 (string-append #$output "/share/man/man5")))
- (mkdir-p man1)
- (mkdir-p man5)
- (install-file
- (string-append "src/" unpack-path "/doc/senpai.1")
- man1)
- (install-file
- (string-append "src/" unpack-path "/doc/senpai.5")
- man5))))
+ (install-file
+ (string-append "src/" unpack-path "/doc/senpai.1")
+ (string-append #$output "/share/man/man1"))
+ (install-file
+ (string-append "src/" unpack-path "/doc/senpai.5")
+ (string-append #$output "/share/man/man5"))))
(add-after 'install 'install-desktop-file
(lambda* (#:key unpack-path #:allow-other-keys)
(install-file
--
2.48.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76895@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76895
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help