[PATCH ruby-team] gnu: Add ruby-readline-ext.

  • Open
  • quality assurance status badge
Details
One participant
  • gemmaro
Owner
unassigned
Submitted by
gemmaro
Severity
normal

Debbugs page

gemmaro wrote 3 days ago
(address . guix-patches@gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
b24dcb734f95dc39c686c9315ae0e4eb2d12aa01.1741495781.git.gemmaro.dev@gmail.com
* gnu/packages/ruby-xyz.scm (ruby-readline-ext): New variable.

Change-Id: I89d8acc679d3fd4173298996386f25fa765789ae
---
gnu/packages/ruby-xyz.scm | 36 +++++++++++++++++++++++++++++++++++-
1 file changed, 35 insertions(+), 1 deletion(-)

Toggle diff (66 lines)
diff --git a/gnu/packages/ruby-xyz.scm b/gnu/packages/ruby-xyz.scm
index 688bf33459..c2f7b224b6 100644
--- a/gnu/packages/ruby-xyz.scm
+++ b/gnu/packages/ruby-xyz.scm
@@ -1,4 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2025 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18,10 +19,14 @@
(define-module (gnu packages ruby-xyz)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system ruby)
+ #:use-module (guix download)
#:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix packages)
- #:use-module (gnu packages))
+ #:use-module (gnu packages)
+ #:use-module (gnu packages ncurses)
+ #:use-module (gnu packages readline)
+ #:use-module (gnu packages ruby))
;;; Commentary:
;;;
@@ -30,6 +35,35 @@ (define-module (gnu packages ruby-xyz)
;;; Code:
+(define-public ruby-readline-ext
+ (package
+ (name "ruby-readline-ext")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "readline-ext" version))
+ (sha256
+ (base32 "1a7aqd7cgrd5j8v639wzfnjawqac6vfz5djxn1acahs2afjx82j9"))))
+ (build-system ruby-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'compile
+ (lambda _
+ (invoke "rake" "compile"))))))
+ (native-inputs (list ruby-rake-compiler))
+ (inputs (list ncurses readline))
+ (synopsis "Ruby interface for GNU Readline")
+ (description
+ "The @samp{readline-ext} gem provides an interface to the GNU Readline
+library. This gem allows Ruby programs to use line-editing and
+history capabilities for interactive programs with a command-line
+interface, enhancing user input handling.")
+ (home-page "https://github.com/ruby/readline-ext")
+ (license (list license:ruby license:bsd-2))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above in alphabetic order.

base-commit: ba768e5a27feb6316afa5c4995cefd244e0f0e4b
--
2.48.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76880@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76880
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help