tests/pack.scm failure (AppImage)

  • Open
  • quality assurance status badge
Details
One participant
  • Reepca Russelstein
Owner
unassigned
Submitted by
Reepca Russelstein
Severity
normal

Debbugs page

Reepca Russelstein wrote 4 days ago
(address . bug-guix@gnu.org)
87v7sk5god.fsf@russelstein.xyz
Or perhaps it would be more accurate to say that it is nondeterministic.
This is because it currently succeeds more or less by accident: the
AppRun symlink points to ./gnu/store/...-profile/bin/hello, which points
to /gnu/store/...-hello-2.12.1/bin/hello (note: absolute path!). There
shouldn't be any reason for that to exist inside the chroot, except that
the daemon's reference scanner has noticed that some of the inputs to
the appimage-building derivation *may* have their hashes visible in the
built appimage. I say "may" because the appimage is compressed with
squashfs, so it's a matter of luck whether a hash is actually directly
visible. Currently, in the master branch, it happens to be visible, but
in my local repository it isn't, and so it fails for me.

To demonstrate this without relying on the fickle compression, find the
store path of the appimage built during the tests/pack.scm "appimage"
test case after running "make check TESTS=tests/pack.scm" (the
"check-appimage" derivation is printed into tests/pack.log, from there
you can find the appimage derivation and its output path), and call it
$IMAGE. Then:

$ IMAGE=/gnu/store/2c8m9in2pkgkf8p9qgv17dqz19jfxmmm-hello-appimage.AppImage
$ mkdir test-root
$ mkdir test-root/proc
$ mkdir test-root/tmp
$ cp "$IMAGE" test-root/test-image
$ unshare --user --mount --map-root-user

then, in the subshell spawned by unshare:

$ mount --bind /proc test-root/proc
$ chroot ./test-root /test-image --appimage-extract-and-run

you should see "Failed to run
/tmp/appimage_extracted_e331827d4eb2f579cccf6fb79143c261/AppRun: No such
file or directory" or something like it.

- reepca
-----BEGIN PGP SIGNATURE-----

iQFLBAEBCAA1FiEEdNapMPRLm4SepVYGwWaqSV9/GJwFAmfLvVMXHHJlZXBjYUBy
dXNzZWxzdGVpbi54eXoACgkQwWaqSV9/GJwm5wf9HT4HQ90TjsGF5VaOn4zZsMxK
cISgL2HKpUXeaBknMsx8v6KUrb9r45h9As2f5NYV8otX1U14H6HjccfJoNOaGHeC
vWPRUkM/aBhikEcJuN+YcN2J6mgQ8e+ZUYX//sDtNQevuBHmxbTTj0Sf3yR4+JGa
fL77ap8UK77CBKtIZkzV5B48lw4u9gWVv6yQeGmdenqTzGq8z9dtXU94mqE7pURR
lNza+ZS52peqzAoePIH4Kq3LwmOf7GvP7Tt+p+RVEd9JmLUS3/KDZVJ/RD9A3Q/c
nD1S81n/vYr8FzYNWrOcH73ti22J7ynIhbOd65M+Cxe+GAe6Dvg2VRxjGiNBeQ==
=vJM5
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76850@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76850
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help