Fwd: Help with packaging go-github-com-charmbracelet-x-exp-teatest on Guix?

  • Open
  • quality assurance status badge
Details
One participant
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 4 days ago
(address . guix-patches@gnu.org)
CAO+9K5rA7VVuuCnwPxOHtqFekyAtzpU+cEi5Hn6je6YwtSqpOg@mail.gmail.com
---------- Forwarded message ---------
From: Sharlatan Hellseher <sharlatanus@gmail.com>
Date: Fri, 7 Mar 2025 at 20:36
Subject: Re: Help with packaging
go-github-com-charmbracelet-x-exp-teatest on Guix?
To: <ashvithshetty0010@zohomail.in>, <gnu-patches@gnu.org>



Hi Ashvith,

The issue you experience is due to fact that Golang projects started
practiced Workspaces or monorepor e.g. source code for verity of
modules distributed from the single repository but tagged individually.
It make live for go-build-system harder as it symlinks inputs from the
store by the #:import-path and if any path is intersecting it rise
"Permission Denied" issue.

Do you really need this package (that is a working variant)? It stands as
a testing library for already packaged go-github-com-charmbracelet-bubbletea :

Toggle snippet (93 lines)
(define-public go-github-com-charmbracelet-x-exp-teatest
;; No version tag, use commit from Golang pseudo version:
;; 0.0.0-20250303111204-ce812b082f54
(let ((commit "ce812b082f548a1a39b1a2bab82d931514ee89d8")
(revision "0"))
(package
(name "go-github-com-charmbracelet-x-exp-teatest")
(version (git-version "0.0.0" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/charmbracelet/x")
(commit commit)))
(file-name (git-file-name name version))
(sha256
(base32 "0l748wpw689k79hnwh905hslqdg31nlh80xabs72b3yjqvxxpr1x"))
(modules '((guix build utils)))
(snippet
#~(begin
;; Submodules with their own go.mod files and packed as separated
;; packages:
;;
;; - github.com/charmbracelet/x/ansi
;; - github.com/charmbracelet/x/cellbuf
;; - github.com/charmbracelet/x/colors
;; - github.com/charmbracelet/x/conpty
;; - github.com/charmbracelet/x/editor
;; - github.com/charmbracelet/x/errors
;; - github.com/charmbracelet/x/examples
;; - github.com/charmbracelet/x/exp/golden
;; - github.com/charmbracelet/x/exp/higherorder
;; - github.com/charmbracelet/x/exp/maps
;; - github.com/charmbracelet/x/exp/open
;; - github.com/charmbracelet/x/exp/ordered
;; - github.com/charmbracelet/x/exp/slice
;; - github.com/charmbracelet/x/exp/strings
;; - github.com/charmbracelet/x/exp/teatest/v2
;; - github.com/charmbracelet/x/input
;; - github.com/charmbracelet/x/json
;; - github.com/charmbracelet/x/sshkey
;; - github.com/charmbracelet/x/term
;; - github.com/charmbracelet/x/termios
;; - github.com/charmbracelet/x/vt
;; - github.com/charmbracelet/x/wcwidth
;; - github.com/charmbracelet/x/windows
;; - github.com/charmbracelet/x/xpty
(for-each delete-file-recursively
(list "ansi"
"cellbuf"
"colors"
"conpty"
"editor"
"errors"
"examples"
"exp/golden"
"exp/higherorder"
"exp/maps"
"exp/open"
"exp/ordered"
"exp/slice"
"exp/strings"
"exp/teatest/v2"
"input"
"json"
"sshkey"
"term"
"termios"
"vt"
"wcwidth"
"windows"
"xpty"))))))
(build-system go-build-system)
(arguments
(list
#:import-path "github.com/charmbracelet/x/exp/teatest"
#:unpack-path "github.com/charmbracelet/x"
#:test-flags
;; XXX: Two tests with not matching escape character, check
with upstream.
#~(list "-skip" "TestApp|TestAppSendToOtherProgram")))
(propagated-inputs
(list go-github-com-charmbracelet-bubbletea
go-github-com-charmbracelet-x-exp-golden))
(home-page "https://github.com/charmbracelet/x")
(synopsis "Golang library for testing Bubble Tea programs")
(description
"Package teatest provides helper functions to test
@code{https://github.com/charmbracelet/bubbletea, Bubble Tea}'s
@code{tea.Model}.")
(license license:expat))))

Let me know if you might need more help and take a look at go-team branch
which is in a queue to master it contains 100+ new packages and some updates.

---
Oleg


--
VCS: https://github.incerto.xyz/;https://git.sr.ht/~hellseher/
GPG: 9847 81DE 689C 21C2 6418 0867 76D7 27BF F62C D2B5

… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
-----BEGIN PGP SIGNATURE-----
iQJKBAEBCgA0FiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmfLWMcWHHNoYXJsYXRh
bnVzQGdtYWlsLmNvbQAKCRB21ye/9izStbTTEADDWDCXpvDhY0RRGOP85r6Q8Lvk
MB5Ez/TO3x9QKfNfHRjNRnyPLmeZi0xjf543i7M0RIBUVSvW+c1588QJhGtHxhza
FXfYuHWkpUMmJmb6HAoOJh/nD1EPY7tHO9Ha4tl88OBYIVCrwzI3fhOIxYQzErbU
WY0qCfImWFWwad6EEB0GPUdi8O1dqQg9rwmChW7BjxNKADvf4WPdTV9yJQz+LWOI
JSDWeTsccgwxB4gYDrVIWG6vH7HNUKIH1Cyy823o5LBoiApVdoqZLrfBDOjsp3pz
+PGdLM8OWcxEEIfrbbtvbmkwqbyyjaKl/YD0fe7IdKSA8qz3HQZbK84bM3gDAr+4
oakBdhx0CWlNDECPa2J+MPv+n5Qbpp4J3F+sBeQPraIP7Dm45oTXEn+dEIdcYdLW
Ait8YmaG53Og0dN9F7rRP4MpqcMUH8s4LjE92exmrLEDbiyjJ/LY+rlR1xtwqozX
3VThoec3ZvgTABTSeb3HLpqYPO1xzQQ3qutN5EsrVk0VpCZtF9Sp4G0SfjpYB+EB
OV1CR70xlpwCC341G8oehlAe4vsEaOFypMSUEf4oeSCIHhsEJRywwkhlndJZKbjv
HBxUm/xsaN/Ci7HqUsy2KiB9r0OB6pp9y+GaGzL3a5ddmdjpFj57hKv1X4FMZbxh
VHyySr5KT1zsrdubaQ==
=hvJQ
-----END PGP SIGNATURE-----
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76843@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76843
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help