[PATCH] gnu: icu4c: Fix uri procedure.

  • Done
  • quality assurance status badge
Details
2 participants
  • Greg Hogan
  • Ian Eure
Owner
unassigned
Submitted by
Greg Hogan
Severity
normal

Debbugs page

Greg Hogan wrote 6 days ago
(address . guix-patches@gnu.org)(name . Greg Hogan)(address . code@greghogan.com)
2c3b35978dc9a06fac074829c2ec79c0509fdf46.1741378663.git.code@greghogan.com
This is a small fix for #76750. No rebuilds.

* gnu/packages/icu4c.scm (icu4?-uri, icu4c-uri, icu4j-uri):
Revert to distinct release file suffixes.

Change-Id: Icd1fd03c7147c3ee77111bb815294f654053c203
---
gnu/packages/icu4c.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/icu4c.scm b/gnu/packages/icu4c.scm
index 5209f2f19b1..89546751bd1 100644
--- a/gnu/packages/icu4c.scm
+++ b/gnu/packages/icu4c.scm
@@ -43,19 +43,19 @@ (define-module (gnu packages icu4c)
#:use-module (guix build-system ant)
#:use-module (guix build-system gnu))
-(define (icu4?-uri variant version)
+(define (icu4?-uri variant suffix version)
(string-append
"https://github.com/unicode-org/icu/releases/download/release-"
(string-map (lambda (x) (if (char=? x #\.) #\- x)) version)
"/icu4" variant "-"
(string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
- "-src.tgz"))
+ suffix))
(define (icu4c-uri version)
- (icu4?-uri "c" version))
+ (icu4?-uri "c" "-src.tgz" version))
(define (icu4j-uri version)
- (icu4?-uri "j" version))
+ (icu4?-uri "j" ".tgz" version))
(define-public icu4c
(package

base-commit: c8bde3c6725be4eb0743a153a3cf8de453d9e448
--
2.47.1
Ian Eure wrote 6 days ago
(name . Greg Hogan)(address . code@greghogan.com)(address . 76841@debbugs.gnu.org)
87senod1jo.fsf@retrospec.tv
Hi Greg,

I just pushed #76841, which duplicates this fix.
Ian Eure wrote 6 days ago
control message for bug #76841
(address . control@debbugs.gnu.org)
87r038d1jk.fsf@retrospec.tv
close 76841
quit
Greg Hogan wrote 6 days ago
Re: bug#76841: Acknowledgement ([PATCH] gnu: icu4c: Fix uri procedure.)
(address . 76841-done@debbugs.gnu.org)
CA+3U0Z=OM3+tddZkphA8Np7BabJ6ZSgCpaAK1KDdZtk0ySuB2A@mail.gmail.com
On Fri, Mar 7, 2025 at 3:23 PM GNU bug Tracking System
<help-debbugs@gnu.org> wrote:
Toggle quote (23 lines)
>
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
> guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 76841@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
> --
> 76841: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=76841
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems

Fixed by 57171c3243eb30f87a0583e3f554c3cc6c3dd2d0
Closed
Greg Hogan wrote 6 days ago
Re: [bug#76841] [PATCH] gnu: icu4c: Fix uri procedure.
(name . Ian Eure)(address . ian@retrospec.tv)(address . 76841@debbugs.gnu.org)
CA+3U0ZkGQVdGSaa_Wd4mU6v05v5xqqD+m5FA_eq=eKugNLQazQ@mail.gmail.com
On Fri, Mar 7, 2025 at 3:32 PM Ian Eure <ian@retrospec.tv> wrote:
Toggle quote (5 lines)
>
> Hi Greg,
>
> I just pushed #76841, which duplicates this fix.

I saw it. Thanks!
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76841@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76841
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help