[PATCH] gnu: java-icu4j: Restore the correct uri for source.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ian Eure
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal

Debbugs page

Tomas Volf wrote 4 days ago
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
6a18057affc26b865dcc5ca95c1a6a3cfa26f12b.1741378888.git.~@wolfsden.cz
The refactoring was wrong, so restore the original way for java-icu4j. Since
that package is just in a single version, the benefit for DRYing is not that
large.

* gnu/packages/icu4c.scm (java-icu4j): Restore the source uri.
(icu4j-uri): Delete procedure.
(icu4?-uri): Rename this...
(icu4c-uri): ... to this.

Change-Id: If157fa2bcb2aca675edd5d2abfbb7f541a241c7c
---
gnu/packages/icu4c.scm | 17 ++++++++---------
1 file changed, 8 insertions(+), 9 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/icu4c.scm b/gnu/packages/icu4c.scm
index 5209f2f19b..2c836a8622 100644
--- a/gnu/packages/icu4c.scm
+++ b/gnu/packages/icu4c.scm
@@ -43,20 +43,14 @@ (define-module (gnu packages icu4c)
#:use-module (guix build-system ant)
#:use-module (guix build-system gnu))
-(define (icu4?-uri variant version)
+(define (icu4c-uri version)
(string-append
"https://github.com/unicode-org/icu/releases/download/release-"
(string-map (lambda (x) (if (char=? x #\.) #\- x)) version)
- "/icu4" variant "-"
+ "/icu4c-"
(string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
"-src.tgz"))
-(define (icu4c-uri version)
- (icu4?-uri "c" version))
-
-(define (icu4j-uri version)
- (icu4?-uri "j" version))
-
(define-public icu4c
(package
(name "icu4c")
@@ -218,7 +212,12 @@ (define-public java-icu4j
(version "70.1")
(source (origin
(method url-fetch)
- (uri (icu4j-uri version))
+ (uri (string-append
+ "https://github.com/unicode-org/icu/releases/download/release-"
+ (string-map (lambda (x) (if (char=? x #\.) #\- x)) version)
+ "/icu4j-"
+ (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
+ ".tgz"))
(sha256
(base32 "0qrs75iyzn19kf54q55jn8wf6xjlpkrihdwqpxm39jdh2hz4cgvj"))))
(build-system ant-build-system)
--
2.48.1
Ian Eure wrote 4 days ago
control message for bug #76840
(address . control@debbugs.gnu.org)
87zfhwd1m0.fsf@retrospec.tv
close 76840
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76840@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76840
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help