[PATCH 14/15] gnu: python-numpy-documentation: Update python-sphinx native-input.

  • Done
  • quality assurance status badge
Details
One participant
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal

Debbugs page

Nicolas Graves wrote 6 days ago
(address . 76835@debbugs.gnu.org)(name . Nicolas Graves via Guix-patches via)(address . guix-patches@gnu.org)
20250307191522.22228-14-ngraves@ngraves.fr
From: Nicolas Graves via Guix-patches via <guix-patches@gnu.org>

* gnu/packages/python-xyz.scm (python-numpy-documentation):
[arguments]{phases}: Add phase 'avoid-external-deps. Adapt phase
'install by removing sphinx.ext.autodoc extension.
[native-inputs]: Replace python-sphinx-4 by python-sphinx. Add
python-sphinx-design.
---
gnu/packages/python-xyz.scm | 14 +++++++++++++-
1 file changed, 13 insertions(+), 1 deletion(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bacfac6c42..6054a88562 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9684,6 +9684,16 @@ (define-public python-numpy-documentation
#:tests? #f ;we're only generating the documentation
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'avoid-external-deps
+ (lambda _
+ ;; XXX: Avoid theme-switcher to avoid sphinx error
+ ;; TemplateNotFound('theme-switcher.html')
+ ;; XXX: Avoid version-switcher because it depends on the value
+ ;; of external https://numpy.org/doc/_static/versions.json
+ (substitute* "doc/source/conf.py"
+ (("\
+\"navbar_end\": \\[\"theme-switcher\", \"version-switcher\", ")
+ "\"navbar_end\": ["))))
(add-before 'build 'add-gnu-freefont-to-texmf
(lambda _
;; XXX: The Sphinx-generated tex output specifies the GNU
@@ -9729,6 +9739,7 @@ (define-public python-numpy-documentation
(("\"contents\"") "'index'")
;; Disable Sphinx extensions that produce broken Texinfo.
((".*'numpydoc'.*") "")
+ ((".*'sphinx.ext.autodoc'.*") "")
((".*'sphinx.ext.autosummary'.*") ""))
(invoke "make" "info" sphinxopts)
;; Install the HTML documentation.
@@ -9752,7 +9763,8 @@ (define-public python-numpy-documentation
python-pandas
python-pydata-sphinx-theme
python-scipy ;used by matplotlib
- python-sphinx-4
+ python-sphinx
+ python-sphinx-design
python-sphinx-panels
texinfo
(texlive-updmap.cfg
--
2.48.1
Nicolas Graves wrote 6 days ago
control message for bug #76837
(address . control@debbugs.gnu.org)
f81c3265a91f0f72ceab16753169e721@ngraves.fr
close 76837
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76837@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76837
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help