[PATCH v7 14/35] gnu: dex: Update to 0.10.1.

  • Done
  • quality assurance status badge
Details
One participant
  • Nicolas Graves
Owner
unassigned
Submitted by
Nicolas Graves
Severity
normal

Debbugs page

Nicolas Graves wrote 6 days ago
(address . 76819@debbugs.gnu.org)(name . Nicolas Graves via Guix-patches via)(address . guix-patches@gnu.org)
20250307183914.8825-14-ngraves@ngraves.fr
From: Nicolas Graves via Guix-patches via <guix-patches@gnu.org>

* gnu/packages/xdisorg.scm (dex): Update to 0.10.1.
[arguments]: Improve style.
[properties]: Add lint-hidden-cpe-vendors property.
---
gnu/packages/xdisorg.scm | 17 ++++++++++-------
1 file changed, 10 insertions(+), 7 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 5fd0685c7c..0e56a9e3bd 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3644,7 +3644,7 @@ (define-public nwg-launchers
(define-public dex
(package
(name "dex")
- (version "0.9.0")
+ (version "0.10.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -3652,15 +3652,16 @@ (define-public dex
(commit (string-append "v" version))))
(sha256
(base32
- "03aapcywnz4kl548cygpi25m8adwbmqlmwgxa66v4156ax9dqs86"))
+ "1d7fqy63i4q0mw316i5ws1sgdq3f7h3bsf3avvmy0nzshz7i5y6m"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure))
- #:tests? #f))
+ (list
+ #:make-flags #~(list (string-append "PREFIX=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))
+ #:tests? #f)) ; No tests.
(inputs
(list python))
(native-inputs
@@ -3670,6 +3671,8 @@ (define-public dex
(description
"@command{dex}, @dfn{DesktopEntry Execution}, is a program to generate
and execute @file{.desktop} files of the Application type.")
+ (properties
+ '((lint-hidden-cpe-vendors . ("samsung" "linuxfoundation"))))
(license license:gpl3+)))
(define-public sx
--
2.48.1
Nicolas Graves wrote 6 days ago
control message for bug #76834
(address . control@debbugs.gnu.org)
b34daf03fdedea1b8b424908fe2ab2ce@ngraves.fr
close 76834
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76834@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76834
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help