Christopher Baines wrote 5 days ago
(address . guix-patches@gnu.org)
I'm not sure where invoke is coming from here, but it could be from (guix
build utils), that uses system* which uses waitpid, which might cause problems
with recent versions of the shepherd?
At least I'm seeing issues on multiple machines where attempting to restart
the nginx service sometimes causes the shepherd to hang.
* gnu/services/web.scm (nginx-shepherd-service): Replace invoke with
spawn-command.
Change-Id: Ie9ce4be9a4df121465b28148612b4fbc45fb5126
---
gnu/services/web.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
Toggle diff (18 lines)
diff --git a/gnu/services/web.scm b/gnu/services/web.scm
index 7593cd2eaa..b46a4db73f 100644
--- a/gnu/services/web.scm
+++ b/gnu/services/web.scm
@@ -870,7 +870,8 @@ (define (nginx-shepherd-service config)
(nginx-action
(lambda args
#~(lambda _
- (invoke #$nginx-binary "-c" #$config-file #$@args)
+ (spawn-command
+ (list #$nginx-binary "-c" #$config-file #$@args))
(match '#$args
(("-s" . _) #t)
(_
base-commit: 9bc4c9f521caab8aa8d88aa948a650945bb55838
--
2.48.1