Nicolas Graves wrote 6 days ago
(address . guix-patches@gnu.org)
* gnu/packages/emacs-xyz.scm (emacs-password-store): Update to 2.3.2.
[arguments]{phases}: Improve phase 'extract-el-file.
[propagated-inputs]: Remove emacs-s.
---
gnu/packages/emacs-xyz.scm | 16 +++++++---------
1 file changed, 7 insertions(+), 9 deletions(-)
Toggle diff (56 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 86c8d70fc1..0463ba5372 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -24756,17 +24756,17 @@ (define-public emacs-password-store
;; The emacs package version does not match the password-store version,
;; even though it is part of the same repository. When updating, look at
;; the version declared in password-store.el.
- (version "2.3.0")
+ (version "2.3.2")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "git://git.zx2c4.com/password-store")
- (commit "26d2dae04bb76a87be6960861c10432820cd5d55")))
+ (url "https://git.zx2c4.com/password-store")
+ (commit "b5e965a838bb68c1227caa2cdd874ba496f10149")))
(file-name (git-file-name name version))
(sha256
(base32
- "1pkx6pgkkpddxrshzq3x8ilfwqjw9gawnbbskcbssxc88wrpbcjb"))))
+ "0hb5zm7hdp7vmqk39a9s1iyncx4swmwfq30dnnzkjk2y08lnb7ac"))))
(build-system emacs-build-system)
(arguments
(list
@@ -24776,10 +24776,8 @@ (define-public emacs-password-store
(lambda _
(copy-file "contrib/emacs/password-store.el"
"password-store.el")
- (delete-file-recursively "contrib")
- (delete-file-recursively "man")
- (delete-file-recursively "src")
- (delete-file-recursively "tests")))
+ (for-each delete-file-recursively
+ '("contrib" "man" "src" "tests"))))
(add-after 'extract-el-file 'patch-executables
(lambda* (#:key inputs #:allow-other-keys)
(emacs-substitute-variables "password-store.el"
@@ -24788,7 +24786,7 @@ (define-public emacs-password-store
(inputs
(list password-store))
(propagated-inputs
- (list emacs-s emacs-with-editor))
+ (list emacs-with-editor))
(home-page "https://git.zx2c4.com/password-store/tree/contrib/emacs")
(synopsis "Password store (pass) support for Emacs")
(description
--
2.48.1
--
Best regards,
Nicolas Graves