[PATCH core-packages-team 0/2] Update libpng & libpng-apng to 1.6.46.

  • Open
  • quality assurance status badge
Details
One participant
  • Ian Eure
Owner
unassigned
Submitted by
Ian Eure
Severity
normal

Debbugs page

Ian Eure wrote 5 days ago
(address . guix-patches@gnu.org)(name . Ian Eure)(address . ian@retrospec.tv)
20250307043831.20870-1-ian@retrospec.tv
While updating LibreWolf to 136.0-2, I found that it needs newer libpng than
is currently in Guix, and with this package low in the graph, it needs to go
on a branch before hitting master. Patches are straightforward. libpng
1.6.47 is already out, but the apng patch is only available for 1.6.46, so I
opted to keep the versions aligned.

I'm going to add libpng-1.6.46 / libpng-apng-1.6.46 to master to unblock
LibreWolf, those can get removed when core-packages-team merges.

Ian Eure (2):
gnu: libpng: Update to 1.6.46.
gnu: libpng-apng: Update to 1.6.46.

gnu/packages/image.scm | 34 +++++++++++++++++-----------------
1 file changed, 17 insertions(+), 17 deletions(-)

--
2.48.1
Ian Eure wrote 5 days ago
[PATCH core-packages-team 2/2] gnu: libpng-apng: Update to 1.6.46.
(address . 76798@debbugs.gnu.org)(name . Ian Eure)(address . ian@retrospec.tv)
20250307045131.21874-2-ian@retrospec.tv
* gnu/packages/image.scm (libpng-apng): Update to 1.6.46.

Change-Id: Ib20d09c8937278311fd5cc31f8d8c3245d40692b
---
gnu/packages/image.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 7fcd073cd2..5ba5648ca8 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -232,7 +232,7 @@ (define-public libpng-apng
;; The APNG patch is maintained separately and may lag behind upstream libpng.
(package
(name "libpng-apng")
- (version "1.6.39")
+ (version "1.6.46")
(source
(origin
(method url-fetch)
@@ -245,7 +245,7 @@ (define-public libpng-apng
"ftp://ftp.simplesystems.org/pub/libpng/png/src/history"
"/libpng16/libpng-" version ".tar.xz")))
(sha256
- (base32 "0dv90dxvmqpk7mbywyjbz8lh08cv4b0ksqp1y62mzvmlf379cihz"))))
+ (base32 "1cbwf20zlm4gcv8rpjivkngrjgl5366w21lr9qmbk2lr0dq8papk"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)
@@ -277,7 +277,7 @@ (define (apply-patch file)
version "/libpng-" version "-apng.patch.gz"))
(sha256
(base32
- "1z8cx011a2c7vagwgi92rbmky1wi8awmrdldqh9f5k80pbmbdi2a"))))))
+ "00ykl1bzb79xsjwrq7dl0yz9dz5g3zwj0lry5zam3vs6s3gw5gi9"))))))
(native-inputs
(list libtool))
;; libpng.la says "-lz", so propagate it.
--
2.48.1
Ian Eure wrote 5 days ago
[PATCH core-packages-team 1/2] gnu: libpng: Update to 1.6.46.
(address . 76798@debbugs.gnu.org)(name . Ian Eure)(address . ian@retrospec.tv)
20250307045131.21874-1-ian@retrospec.tv
* gnu/packages/image.scm (libpng): Update to 1.6.46.

Change-Id: Icb1b91a658b613f633f2c96ea2307bd41fa0241c
---
gnu/packages/image.scm | 28 ++++++++++++++--------------
1 file changed, 14 insertions(+), 14 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index efae0544dd..7fcd073cd2 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -200,20 +200,20 @@ (define-public iqa
(define-public libpng
(package
(name "libpng")
- (version "1.6.39") ; Remember to also update libpng-apng if possible!
- (source (origin
- (method url-fetch)
- (uri (list (string-append "mirror://sourceforge/libpng/libpng16/"
- version "/libpng-" version ".tar.xz")
- (string-append
- "ftp://ftp.simplesystems.org/pub/libpng/png/src"
- "/libpng16/libpng-" version ".tar.xz")
- (string-append
- "ftp://ftp.simplesystems.org/pub/libpng/png/src/history"
- "/libpng16/libpng-" version ".tar.xz")))
- (sha256
- (base32
- "0dv90dxvmqpk7mbywyjbz8lh08cv4b0ksqp1y62mzvmlf379cihz"))))
+ (version "1.6.46") ; Remember to also update libpng-apng if possible!
+ (source
+ (origin
+ (method url-fetch)
+ (uri (list (string-append "mirror://sourceforge/libpng/libpng16/"
+ version "/libpng-" version ".tar.xz")
+ (string-append
+ "ftp://ftp.simplesystems.org/pub/libpng/png/src"
+ "/libpng16/libpng-" version ".tar.xz")
+ (string-append
+ "ftp://ftp.simplesystems.org/pub/libpng/png/src/history"
+ "/libpng16/libpng-" version ".tar.xz")))
+ (sha256
+ (base32 "1cbwf20zlm4gcv8rpjivkngrjgl5366w21lr9qmbk2lr0dq8papk"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--disable-static")))
--
2.48.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76798@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76798
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help