[PATCH] gnu: fish: Add support for guix home profile.

  • Done
  • quality assurance status badge
Details
2 participants
  • Luis Guilherme Coelho
  • Ludovic Courtès
Owner
unassigned
Submitted by
Luis Guilherme Coelho
Severity
normal

Debbugs page

Luis Guilherme Coelho wrote 7 days ago
(address . guix-patches@gnu.org)(name . Luis Guilherme Coelho)(address . lgcoelho@disroot.org)
31435aaacaceddc8a2baa176e431393a10446ed1.1741306684.git.lgcoelho@disroot.org
* gnu/packages/shells.scm (fish)[arguments]<#:phases>
{patch-fish-extra-paths}: Add `~/.guix-home/profile' to `__guix_profile_paths'.

Change-Id: If896cfc4f948d86c52073235a6f4a2c1d085e7a6
---
Currently, the completions, configurations and functions installed in
~/.guix-home/profile/etc/fish/{completions,conf.d,functions} are ignored,
as these directories aren't listed under __fish_vendor_completionsdirs,
__fish_vendor_confdirs and __fish_vendor_functionsdirs. This patch
addresses, and fixes, this issue.

gnu/packages/shells.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 63bdf69705..e177a90de0 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -223,10 +223,10 @@ (define-public fish
(string-append
"\n\n"
"# Patched by Guix.\n"
- "# Enable completions, functions and configurations in user's"
- " and system's guix profiles by adding them to __extra_*"
+ "# Enable completions, functions and configurations in user's,"
+ " home's and system's guix profiles by adding them to __extra_*"
" variables.\n"
- "set -l __guix_profile_paths ~/.guix-profile"
+ "set -l __guix_profile_paths ~/.guix-profile ~/.guix-home/profile"
" /run/current-system/profile\n"
"set __extra_completionsdir"
" $__guix_profile_paths\"/etc/fish/completions\""

base-commit: 310adf4ce70cbb864859274fcc7842bd519bbddc
--
2.48.1
Ludovic Courtès wrote 4 days ago
(name . Luis Guilherme Coelho)(address . lgcoelho@disroot.org)(address . 76796-done@debbugs.gnu.org)
87msdtq426.fsf@gnu.org
Luis Guilherme Coelho <lgcoelho@disroot.org> skribis:

Toggle quote (5 lines)
> * gnu/packages/shells.scm (fish)[arguments]<#:phases>
> {patch-fish-extra-paths}: Add `~/.guix-home/profile' to `__guix_profile_paths'.
>
> Change-Id: If896cfc4f948d86c52073235a6f4a2c1d085e7a6

Applied, thanks!
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76796@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76796
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help