Navid Afkhami wrote 6 days ago
(address . guix-patches@gnu.org)(name . Navid Afkhami)(address . navid.afkhami@mdc-berlin.de)
* gnu/packages/bioinformatics.scm (sickle): New variable.
Change-Id: Ib74974b0ee887753d6ead5b5b388e7163abb11f8
---
gnu/packages/bioinformatics.scm | 34 +++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)
Toggle diff (49 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f7f39f525d..0129b9ebeb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14542,6 +14542,40 @@ (define-public shorah
frequency of the different genetic variants present in a mixed sample.")
(license license:gpl3+)))
+(define-public sickle
+ (package
+ (name "sickle")
+ (version "1.33")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/najoshi/sickle")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1bnq480lpylq9sfsa1y71b4qz0ipi2zjnp8ds48fh10ijlwmwmdc"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ;There are no tests
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'install
+ (lambda _
+ (install-file "sickle"
+ (string-append #$output "/bin")))))))
+ (propagated-inputs (list zlib))
+ (home-page "https://github.com/najoshi/sickle")
+ (synopsis "Adaptive trimming tool for FASTQ files using quality")
+ (description
+ "Sickle is a tool that trims reads based on quality and length thresholds.
+It uses sliding windows to detect low-quality bases at the 3'-end and
+high-quality bases at the 5'-end. Additionally, it discards reads based
+on the length threshold.")
+ (license license:expat)))
+
(define-public ruby-bio-kseq
(package
(name "ruby-bio-kseq")
base-commit: 1f26b0eec83b5dc949900a743ed01088cb093c65
--
2.43.0