King, Spencer wrote 1 weeks ago
(name . King, Spencer via Guix-patches via)(address . guix-patches@gnu.org)(name . efraim@flashner.co.il)(address . efraim@flashner.co.il)(name . zimon.toutoune@gmail.com)(address . zimon.toutoune@gmail.com)
From 0ca9aa40a2dfb28c5855e8429690f0e5c61d23d8 Mon Sep 17 00:00:00 2001
From: Spencer King <spencer.king@wustl.edu>
Date: Thu, 6 Mar 2025 00:12:36 -0600
Subject: [PATCH] gnu: Add julia-polylog.
* gnu/packages/julia-xyz.scm (julia-polylog): New variable.
Change-Id: I0ec8cec07552ef297fc1ecb086678fe9edfd051c
---
gnu/packages/julia-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
Toggle diff (36 lines)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index e1722c0fba..f875f345dd 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -5218,6 +5218,27 @@ (define-public julia-plotutils
plotting components.")
(license license:expat)))
+(define-public julia-polylog
+ (package
+ (name "julia-polylog")
+ (version "2.5.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Expander/PolyLog.jl")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1rfmlh5rvgh84qvvachqgvy0ra5yym28vj09xlw9cq19bkyids64"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/Expander/PolyLog.jl")
+ (synopsis "Implementation of polylogarithms in Julia")
+ (description
+ "This package implements real and complex polylogarithms,
+including the real and complex dilogarithm and trilogarithm in Julia.")
+ (license license:expat)))
+
(define-public julia-pooledarrays
(package
(name "julia-pooledarrays")
base-commit: 310adf4ce70cbb864859274fcc7842bd519bbddc
--
2.41.0