[PATCH] gnu: guile-for-guile-emacs: Fix build.

  • Done
  • quality assurance status badge
Details
2 participants
  • Morgan Smith
  • Z572
Owner
unassigned
Submitted by
Morgan Smith
Severity
normal

Debbugs page

Morgan Smith wrote 1 weeks ago
(address . guix-patches@gnu.org)(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
CH3PR84MB3424F0C1CA74CA2C7E3AE49FC5CB2@CH3PR84MB3424.NAMPRD84.PROD.OUTLOOK.COM
Got broken in commit 98f894e05fdbc6bc90887820b0abc2a443a8b676 which updated
guile-next and removed a no longer needed phase. This package still needed
that phase though.

* gnu/packages/guile.scm (guile-for-guile-emacs): Add phase to disable a
failing test.

Change-Id: Ia45e33f65187e3fdb02dc6a9560d04479e32a017
---

Also fixes dependent build of guile-emacs

gnu/packages/guile.scm | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index cb4ddc8a2d..787cf4a50e 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -625,7 +625,14 @@ (define-public guile-for-guile-emacs
(file-name (git-file-name name version))
(sha256
(base32
- "0fgkcv29581kqkxqq6y48xly72970qs7016qhs6c4ilygg0gyfqb")))))))
+ "0fgkcv29581kqkxqq6y48xly72970qs7016qhs6c4ilygg0gyfqb"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments guile-next)
+ ((#:phases phases '%standard-phases)
+ #~(modify-phases #$phases
+ (add-before 'check 'skip-failing-tests
+ (lambda _
+ (delete-file "test-suite/tests/version.test"))))))))))
;;;

base-commit: f785ff154c08e842b89145d9d47b20203d797e33
--
2.48.1
Z572 wrote 5 days ago
(name . Morgan Smith)(address . Morgan.J.Smith@outlook.com)
87o6ycewbw.fsf@z572.online
Morgan Smith <Morgan.J.Smith@outlook.com> writes:

Toggle quote (5 lines)
> Got broken in commit 98f894e05fdbc6bc90887820b0abc2a443a8b676 which updated
> guile-next and removed a no longer needed phase. This package still needed
> that phase though.
>
> * gnu/packages/guile.scm (guile-for-guile-emacs): Add phase to disable a
add [arguments]
Toggle quote (32 lines)
> failing test.
>
> Change-Id: Ia45e33f65187e3fdb02dc6a9560d04479e32a017
> ---
>
> Also fixes dependent build of guile-emacs
>
> gnu/packages/guile.scm | 9 ++++++++-
> 1 file changed, 8 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
> index cb4ddc8a2d..787cf4a50e 100644
> --- a/gnu/packages/guile.scm
> +++ b/gnu/packages/guile.scm
> @@ -625,7 +625,14 @@ (define-public guile-for-guile-emacs
> (file-name (git-file-name name version))
> (sha256
> (base32
> - "0fgkcv29581kqkxqq6y48xly72970qs7016qhs6c4ilygg0gyfqb")))))))
> + "0fgkcv29581kqkxqq6y48xly72970qs7016qhs6c4ilygg0gyfqb"))))
> + (arguments
> + (substitute-keyword-arguments (package-arguments guile-next)
> + ((#:phases phases '%standard-phases)
> + #~(modify-phases #$phases
> + (add-before 'check 'skip-failing-tests
> + (lambda _
> + (delete-file "test-suite/tests/version.test"))))))))))
>
>
> ;;;
>
> base-commit: f785ff154c08e842b89145d9d47b20203d797e33
adjust and pushed, closing.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmfLBdMACgkQO1qpk+Gi
3/CQJg/5AbXTQP1EWBWI2lxWSIVQ/5sW78u7C9gzS78xrl61JlLQ9+O2r80gJI5k
YdKshnzZ8/Y2x44lafZCuA+ThH13nT1GUeD5Mi8n0yCwtP0/oV8FhXrecQ82goXI
mEm2NrffitT3Nf+AeG/QQgh0r3eF79tH4aqybfwCKK7g1zoW5qVnlH2k3+sz3mHM
bKrtkIIdj1sjDzwyP9w8YQrbSPH+WgVMOhmHQ5WeTrkgGfwfNmqIq5LF8Pg4D07a
LP0xJRFtd+BCmojjB1/Ea8W5aqLBgNJs1r0qdocCemX9WnmO9Mf+pOriJ47K8cGB
b9W3B+g5261FTpNrZ9Km4m2v9IOQTYObVX/Dx+aVQtKF3DX2OHsO/es9N0JB/lWA
xlGqVoHXO2ratzNWxudZhgfMDRcXNjNu+NXwilthX0UVkvd9PUZFkaBJHCYVXnTK
fFsdct+EOYJl2sTvlitIxcxKoJAlm+LQKqtkFWQbtKwZlrQehOLkBc8S/+H0JC07
ZbA0Pid2dCyEB5hZc7Xn88fyjZc9EgvG1L/6sIVmzf7MGJ+sIdtDmYKK3grUePME
gwGgcIyn6y23GpZhXJZuMpE7qUWAa73LU3bnLt8yFTLNiAPhbVnUk2Cj1l2drg0o
gZsoqTIvla8ye0PZs6nlKBv2SqjixFHpSsjL6zmW5uoonRcgnX8=
=9vAE
-----END PGP SIGNATURE-----

Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76752@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76752
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help