[PATCH 0/2] Add icu4c-76.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ian Eure
  • Tomas Volf
Owner
unassigned
Submitted by
Tomas Volf
Severity
normal

Debbugs page

Tomas Volf wrote 1 weeks ago
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
cover.1741125868.git.~@wolfsden.cz
Refactor the icu4c module to reduce copy&paste and add version 76.1

Tomas Volf (2):
gnu: icu4c: Extract uri into a separate procedure.
gnu: Add icu4c-76.

gnu/packages/icu4c.scm | 68 ++++++++++++++++++++----------------------
1 file changed, 32 insertions(+), 36 deletions(-)

--
2.48.1
Tomas Volf wrote 1 weeks ago
[PATCH 1/2] gnu: icu4c: Extract uri into a separate procedure.
(address . 76750@debbugs.gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
67bbb55f08889d7b782f2c074f538404dae581d7.1741125868.git.~@wolfsden.cz
* gnu/packages/icu4c.scm (icu4?-uri, icu4c-uri, icu4j-uri): New procedures.
(icu4c, icu4c-73, icu4c-75, icu4c-70, icu4c-69)[source]: Use icu4c-uri.
(java-icu4j)[source]: Use icu4j-uri.

Change-Id: Iad114631de530e32e4691bc88421d70f015f31d0
---
gnu/packages/icu4c.scm | 56 +++++++++++++++---------------------------
1 file changed, 20 insertions(+), 36 deletions(-)

Toggle diff (110 lines)
diff --git a/gnu/packages/icu4c.scm b/gnu/packages/icu4c.scm
index 0ca917305d..fadea0bbdb 100644
--- a/gnu/packages/icu4c.scm
+++ b/gnu/packages/icu4c.scm
@@ -43,18 +43,27 @@ (define-module (gnu packages icu4c)
#:use-module (guix build-system ant)
#:use-module (guix build-system gnu))
+(define (icu4?-uri variant version)
+ (string-append
+ "https://github.com/unicode-org/icu/releases/download/release-"
+ (string-map (lambda (x) (if (char=? x #\.) #\- x)) version)
+ "/icu4" variant "-"
+ (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
+ "-src.tgz"))
+
+(define (icu4c-uri version)
+ (icu4?-uri "c" version))
+
+(define (icu4j-uri version)
+ (icu4?-uri "j" version))
+
(define-public icu4c
(package
(name "icu4c")
(version "71.1")
(source (origin
(method url-fetch)
- (uri (string-append
- "https://github.com/unicode-org/icu/releases/download/release-"
- (string-map (lambda (x) (if (char=? x #\.) #\- x)) version)
- "/icu4c-"
- (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
- "-src.tgz"))
+ (uri (icu4c-uri version))
(sha256
(base32 "1gqywaqj9jmdwrng9lm6inyqmi5j2cz36db9dcqg3yk13zjyd9v7"))))
(build-system gnu-build-system)
@@ -117,12 +126,7 @@ (define-public icu4c-73
(version "73.1")
(source (origin
(method url-fetch)
- (uri (string-append
- "https://github.com/unicode-org/icu/releases/download/release-"
- (string-map (lambda (x) (if (char=? x #\.) #\- x)) version)
- "/icu4c-"
- (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
- "-src.tgz"))
+ (uri (icu4c-uri version))
(sha256
(base32
"0iccpdvc0kvpww5a31k9gjkqigyz016i7v80r9zamd34w4fl6mx4"))
@@ -140,12 +144,7 @@ (define-public icu4c-75
(version "75.1")
(source (origin
(method url-fetch)
- (uri (string-append
- "https://github.com/unicode-org/icu/releases/download/release-"
- (string-map (lambda (x) (if (char=? x #\.) #\- x)) version)
- "/icu4c-"
- (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
- "-src.tgz"))
+ (uri (icu4c-uri version))
(sha256
(base32
"1vya31v549pq89kgr02jajwi7gc7qw0mv6n4265pxs6jwkrqv5nb"))))))
@@ -156,12 +155,7 @@ (define-public icu4c-70
(version "70.1")
(source (origin
(method url-fetch)
- (uri (string-append
- "https://github.com/unicode-org/icu/releases/download/release-"
- (string-map (lambda (x) (if (char=? x #\.) #\- x)) version)
- "/icu4c-"
- (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
- "-src.tgz"))
+ (uri (icu4c-uri version))
(sha256
(base32
"1m9zgkaf5lyh65nyc6n0n5bs2f5k53nnj1ih6nskpwbvq4l5884d"))))
@@ -186,12 +180,7 @@ (define-public icu4c-69
(version "69.1")
(source (origin
(method url-fetch)
- (uri (string-append
- "https://github.com/unicode-org/icu/releases/download/release-"
- (string-map (lambda (x) (if (char=? x #\.) #\- x)) version)
- "/icu4c-"
- (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
- "-src.tgz"))
+ (uri (icu4c-uri version))
(sha256
(base32
"0icps0avkwy5df3wwc5kybxcg63hcgk4phdh9g244g0xrmx7pfjc"))))))
@@ -219,12 +208,7 @@ (define-public java-icu4j
(version "70.1")
(source (origin
(method url-fetch)
- (uri (string-append
- "https://github.com/unicode-org/icu/releases/download/release-"
- (string-map (lambda (x) (if (char=? x #\.) #\- x)) version)
- "/icu4j-"
- (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
- ".tgz"))
+ (uri (icu4j-uri version))
(sha256
(base32 "0qrs75iyzn19kf54q55jn8wf6xjlpkrihdwqpxm39jdh2hz4cgvj"))))
(build-system ant-build-system)
--
2.48.1
Tomas Volf wrote 1 weeks ago
[PATCH 2/2] gnu: Add icu4c-76.
(address . 76750@debbugs.gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
54a7b2a6fe52f2775fb524743cbc3ad68b8c0488.1741125868.git.~@wolfsden.cz
* gnu/packages/icu4c.scm (icu4c-76): New variable.

Change-Id: I7620a28fd87d075efa49b31506218239913cd895
---
gnu/packages/icu4c.scm | 12 ++++++++++++
1 file changed, 12 insertions(+)

Toggle diff (25 lines)
diff --git a/gnu/packages/icu4c.scm b/gnu/packages/icu4c.scm
index fadea0bbdb..6462a4230a 100644
--- a/gnu/packages/icu4c.scm
+++ b/gnu/packages/icu4c.scm
@@ -149,6 +149,18 @@ (define-public icu4c-75
(base32
"1vya31v549pq89kgr02jajwi7gc7qw0mv6n4265pxs6jwkrqv5nb"))))))
+(define-public icu4c-76
+ (package
+ (inherit icu4c)
+ (name "icu4c")
+ (version "76.1")
+ (source (origin
+ (method url-fetch)
+ (uri (icu4c-uri version))
+ (sha256
+ (base32
+ "0gjg1zrnqk4vmidqgqx4xbz05898px212gnff8242is7zrmv9b6z"))))))
+
(define-public icu4c-70
(package
(inherit icu4c)
--
2.48.1
Ian Eure wrote 6 days ago
Re: [bug#76750] [PATCH 0/2] Add icu4c-76.
(name . Tomas Volf)(address . ~@wolfsden.cz)(address . 76750@debbugs.gnu.org)
875xkmemi6.fsf@retrospec.tv
Hi Tomas,

Pushed, thank you for the patches! I was just about to add icu4c
76.1, I’m glad I thought to look for open patches first.

Thanks,
-- Ian
Ian Eure wrote 6 days ago
control message for bug #76750
(address . control@debbugs.gnu.org)
874j06emhw.fsf@retrospec.tv
close 76750
quit
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76750@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76750
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help