Hyprlock addition

  • Open
  • quality assurance status badge
Details
One participant
  • Josep Bigorra
Owner
unassigned
Submitted by
Josep Bigorra
Severity
normal

Debbugs page

Josep Bigorra wrote 1 weeks ago
(address . guix-patches@gnu.org)
CAM_04A2kLwJNRFDktbULQNYLyDvSKhVOngeh=FfBMWTJt3ynUw@mail.gmail.com
I got hyprlock building nice in Guix, care to check and upstream?
Thanks in advance!

```

(define-public hyprlock
(package
(name "hyprlock")
(version "0.7.0")
(source
(origin
(method git-fetch)
(uri (git-reference
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32 "03ivr5nsjwiwvpdxpjnldwawy8sx8qgwhs57242xkb0zz0w0gvsk"))))
(build-system cmake-build-system)
(arguments
(list
#:tests? #f
#:cmake cmake-3.30)) ;No tests.
(native-inputs (list gcc-14 pkg-config))
(inputs (list hyprlang
hyprutils
hyprgraphics
sdbus-c++
wayland
wayland-protocols
mesa
libwebp
libjpeg
libxkbcommon
hyprwayland-scanner
egl-wayland
cairo
linux-pam
pango))
(synopsis "Hyprland's lock screen")
(description
"Hyprland's simple, yet multi-threaded and GPU-accelerated screen
locking utility.")
(license license:bsd-3)))

```
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76737@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76737
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help