Simon Josefsson wrote 1 weeks ago
(address . bug-guix@gnu.org)
Hi
I got the build error below. Presumably it happens because the jobs to
create the tools has not finished before the help2man jobs has started.
I will patch around this in the Debian packaging to serialize the build:
override_dh_auto_build:
# build tools that help2man needs first
dh_auto_build $(DH_BUILD_OPTS) -- shepherd herd halt reboot
dh_auto_build $(DH_BUILD_OPTS)
But it seems like a upstream problem. I know how annoying these kind of
bugs are, sorry for another report of this type :)
/Simon
dh_auto_build
make -j42
make[1]: Entering directory '/build/reproducible-path/shepherd-1.0.2'
/usr/bin/mkdir -p "`dirname modules/shepherd/config.scm`"
/usr/bin/sed -e 's,%PREFIX%,/usr,g' -e 's,%modsrcdir%,/build/reproducible-path/shepherd-1.0.2/modules,g' -e 's,%modbuilddir%,/build/reproducible-path/shepherd-1.0.2/modules,g' -e 's,%localstatedir%,/var,g' -e 's,%runstatedir%,/run,g' -e 's,%pkglibdir%,/usr/lib/x86_64-linux-gnu/shepherd,g' -e 's,%sysconfdir%,/etc,g' -e 's,%localedir%,/usr/share/locale,g' -e 's,%VERSION%,1.0.2,g' -e 's,%PACKAGE_BUGREPORT%,bug-guix@gnu.org,g' -e 's,%PACKAGE_NAME%,GNU Shepherd,g' -e 's,%PACKAGE_URL%,https://www.gnu.org/software/shepherd/,g'-e 's,%FIBERS_SOURCE_DIRECTORY%,/usr/share/guile/site/3.0,g' -e 's,%FIBERS_OBJECT_DIRECTORY%,/usr/lib/x86_64-linux-gnu/guile/3.0/site-ccache,g' -e 's,%GUILE%,/usr/bin/guile-3.0,g' modules/shepherd/config.scm.in modules/shepherd/config.scm
make all-recursive
make[2]: Entering directory '/build/reproducible-path/shepherd-1.0.2'
Making all in po
make[3]: Entering directory '/build/reproducible-path/shepherd-1.0.2/po'
make[3]: Nothing to be done for 'all'.
make[3]: Leaving directory '/build/reproducible-path/shepherd-1.0.2/po'
make[3]: Entering directory '/build/reproducible-path/shepherd-1.0.2'
/usr/bin/mkdir -p "`dirname shepherd`" ; \
/usr/bin/sed -e 's,%PREFIX%,/usr,g' -e 's,%modsrcdir%,/build/reproducible-path/shepherd-1.0.2/modules,g' -e 's,%modbuilddir%,/build/reproducible-path/shepherd-1.0.2/modules,g' -e 's,%localstatedir%,/var,g' -e 's,%runstatedir%,/run,g' -e 's,%pkglibdir%,/usr/lib/x86_64-linux-gnu/shepherd,g' -e 's,%sysconfdir%,/etc,g' -e 's,%localedir%,/usr/share/locale,g' -e 's,%VERSION%,1.0.2,g' -e 's,%PACKAGE_BUGREPORT%,bug-guix@gnu.org,g' -e 's,%PACKAGE_NAME%,GNU Shepherd,g' -e 's,%PACKAGE_URL%,https://www.gnu.org/software/shepherd/,g'-e 's,%FIBERS_SOURCE_DIRECTORY%,/usr/share/guile/site/3.0,g' -e 's,%FIBERS_OBJECT_DIRECTORY%,/usr/lib/x86_64-linux-gnu/guile/3.0/site-ccache,g' -e 's,%GUILE%,/usr/bin/guile-3.0,g' shepherd.in shepherd ; \
chmod +x shepherd
/usr/bin/mkdir -p "`dirname herd`" ; \
/usr/bin/sed -e 's,%PREFIX%,/usr,g' -e 's,%modsrcdir%,/build/reproducible-path/shepherd-1.0.2/modules,g' -e 's,%modbuilddir%,/build/reproducible-path/shepherd-1.0.2/modules,g' -e 's,%localstatedir%,/var,g' -e 's,%runstatedir%,/run,g' -e 's,%pkglibdir%,/usr/lib/x86_64-linux-gnu/shepherd,g' -e 's,%sysconfdir%,/etc,g' -e 's,%localedir%,/usr/share/locale,g' -e 's,%VERSION%,1.0.2,g' -e 's,%PACKAGE_BUGREPORT%,bug-guix@gnu.org,g' -e 's,%PACKAGE_NAME%,GNU Shepherd,g' -e 's,%PACKAGE_URL%,https://www.gnu.org/software/shepherd/,g'-e 's,%FIBERS_SOURCE_DIRECTORY%,/usr/share/guile/site/3.0,g' -e 's,%FIBERS_OBJECT_DIRECTORY%,/usr/lib/x86_64-linux-gnu/guile/3.0/site-ccache,g' -e 's,%GUILE%,/usr/bin/guile-3.0,g' herd.in herd ; \
chmod +x herd
/usr/bin/mkdir -p "`dirname halt`" ; \
/usr/bin/sed -e 's,%PREFIX%,/usr,g' -e 's,%modsrcdir%,/build/reproducible-path/shepherd-1.0.2/modules,g' -e 's,%modbuilddir%,/build/reproducible-path/shepherd-1.0.2/modules,g' -e 's,%localstatedir%,/var,g' -e 's,%runstatedir%,/run,g' -e 's,%pkglibdir%,/usr/lib/x86_64-linux-gnu/shepherd,g' -e 's,%sysconfdir%,/etc,g' -e 's,%localedir%,/usr/share/locale,g' -e 's,%VERSION%,1.0.2,g' -e 's,%PACKAGE_BUGREPORT%,bug-guix@gnu.org,g' -e 's,%PACKAGE_NAME%,GNU Shepherd,g' -e 's,%PACKAGE_URL%,https://www.gnu.org/software/shepherd/,g'-e 's,%FIBERS_SOURCE_DIRECTORY%,/usr/share/guile/site/3.0,g' -e 's,%FIBERS_OBJECT_DIRECTORY%,/usr/lib/x86_64-linux-gnu/guile/3.0/site-ccache,g' -e 's,%GUILE%,/usr/bin/guile-3.0,g' halt.in halt ; \
chmod +x halt
/usr/bin/mkdir -p "`dirname reboot`" ; \
/usr/bin/sed -e 's,%PREFIX%,/usr,g' -e 's,%modsrcdir%,/build/reproducible-path/shepherd-1.0.2/modules,g' -e 's,%modbuilddir%,/build/reproducible-path/shepherd-1.0.2/modules,g' -e 's,%localstatedir%,/var,g' -e 's,%runstatedir%,/run,g' -e 's,%pkglibdir%,/usr/lib/x86_64-linux-gnu/shepherd,g' -e 's,%sysconfdir%,/etc,g' -e 's,%localedir%,/usr/share/locale,g' -e 's,%VERSION%,1.0.2,g' -e 's,%PACKAGE_BUGREPORT%,bug-guix@gnu.org,g' -e 's,%PACKAGE_NAME%,GNU Shepherd,g' -e 's,%PACKAGE_URL%,https://www.gnu.org/software/shepherd/,g'-e 's,%FIBERS_SOURCE_DIRECTORY%,/usr/share/guile/site/3.0,g' -e 's,%FIBERS_OBJECT_DIRECTORY%,/usr/lib/x86_64-linux-gnu/guile/3.0/site-ccache,g' -e 's,%GUILE%,/usr/bin/guile-3.0,g' reboot.in reboot ; \
chmod +x reboot
LANGUAGE= /bin/bash '/build/reproducible-path/shepherd-1.0.2/build-aux/missing' help2man --source=GNU --info-page=shepherd --output="doc/shepherd.1" "./`basename "doc/shepherd.1" .1`"
LANGUAGE= /bin/bash '/build/reproducible-path/shepherd-1.0.2/build-aux/missing' help2man --source=GNU --info-page=shepherd --output="doc/herd.1" "./`basename "doc/herd.1" .1`"
make[4]: Entering directory '/build/reproducible-path/shepherd-1.0.2'
help2man: can't get `--help' info from ./herd
Try `--no-discard-stderr' if option outputs to stderr
help2man: can't get `--help' info from ./shepherd
Try `--no-discard-stderr' if option outputs to stderr
WARNING: 'help2man' is missing on your system.
You should only need it if you modified a dependency of a man page.
You may want to install the GNU Help2man package:
WARNING: 'help2man' is missing on your system.
You should only need it if you modified a dependency of a man page.
You may want to install the GNU Help2man package:
make[3]: *** [Makefile:2252: doc/shepherd.1] Error 127
make[3]: *** Waiting for unfinished jobs....
make[3]: *** [Makefile:2255: doc/herd.1] Error 127
make[4]: Leaving directory '/build/reproducible-path/shepherd-1.0.2'
Updating ./doc/version.texi
make[3]: Leaving directory '/build/reproducible-path/shepherd-1.0.2'
make[2]: *** [Makefile:1470: all-recursive] Error 1
make[2]: Leaving directory '/build/reproducible-path/shepherd-1.0.2'
make[1]: *** [Makefile:871: all] Error 2
make[1]: Leaving directory '/build/reproducible-path/shepherd-1.0.2'
dh_auto_build: error: make -j42 returned exit code 2
-----BEGIN PGP SIGNATURE-----
iQNoBAEWCAMQFiEEo8ychwudMQq61M8vUXIrCP5HRaIFAmfGqicUHHNpbW9uQGpv
c2Vmc3Nvbi5vcmfCHCYAmDMEXJLOtBYJKwYBBAHaRw8BAQdACIcrZIvhrxDBkK9f
V+QlTmXxo2naObDuGtw58YaxlOu0JVNpbW9uIEpvc2Vmc3NvbiA8c2ltb25Aam9z
ZWZzc29uLm9yZz6IlgQTFggAPgIbAwULCQgHAgYVCAkKCwIEFgIDAQIeAQIXgBYh
BLHSvRN1vst4TPT4xNc89jjFPAa+BQJl/YgIBQkLehFUAAoJENc89jjFPAa+CboA
+wUa06RD5e5VTCxvSWtPS75Wq2qBeYGZnf0jvUMxa2n4AP4xkUeAPPnNuMsTm2fs
FCDIGaEM2Yn6Vb2huzzT1Fw/BLgzBFySz4EWCSsGAQQB2kcPAQEHQOxTCIOaeXAx
I2hIX4HK9bQTpNVei708oNr1Klm8qCGKiPUEGBYIACYCGwIWIQSx0r0Tdb7LeEz0
+MTXPPY4xTwGvgUCZf2IKwUJC3oQqgCBdiAEGRYIAB0WIQSjzJyHC50xCrrUzy9R
cisI/kdFogUCXJLPgQAKCRBRcisI/kdFoqdMAQCgH45aseZgIrwKOvUOA9QfsmeE
8GZHYNuFHmM9FEQS6AD6A4x5aYvoY6lo98pgtw2HPDhmcCXFItjXCrV4A0GmJA4J
ENc89jjFPAa+GcYA/26YQY05bLtnXiIjTiAzrGQrRXxTHPA8Av7TDFHvIetWAP9s
HSoU8OfTwmTiEnGwLlsV7QJclZg3YNz/Ypcp9TqQBrg4BFySz2oSCisGAQQBl1UB
BQEBB0AxlRumDW6nZY7A+VCfek9VpEx6PJmdJyYPt3lNHMd6HAMBCAeIfgQYFggA
JgIbDBYhBLHSvRN1vst4TPT4xNc89jjFPAa+BQJl/YgwBQkLehDGAAoJENc89jjF
PAa+phoA/jrDqIrl/55vUMBhIQv+TP635d2iCTEnyFmbUcP9+gh6APoDsXalVd2c
OGxQtSC+TF8PkZMn1TLkJKAjVxr+xx40AgAKCRBRcisI/kdFojplAP46u4PP5uqS
umvREUF0Mc/0MJCKp6nWk0hM1T6Bi/iauAD/cHxmuTSvmq6MUd11E25bCguENGas
gBOXcZ8aQ+PYOgY=
=GF8z
-----END PGP SIGNATURE-----