[PATCH] gnu: avogadro2: fix open babel input

  • Open
  • quality assurance status badge
Details
2 participants
  • Jakob Kirsch
  • Z572
Owner
unassigned
Submitted by
Jakob Kirsch
Severity
normal

Debbugs page

Jakob Kirsch wrote 1 weeks ago
(address . guix-patches@gnu.org)
Z8ZNlSc-d6XXvY6_@kernelpanicroom
avogadro2 needs open babel at runtime so we should add this to the propagated inputs.
From b353ae32e3b160b47ae1b34fe65e79b141caf05f Mon Sep 17 00:00:00 2001
Message-ID: <b353ae32e3b160b47ae1b34fe65e79b141caf05f.1741049088.git.jakob.kirsch@web.de>
From: Jakob Kirsch <jakob.kirsch@web.de>
Date: Tue, 4 Mar 2025 01:44:43 +0100
Subject: [PATCH v1] gnu: avogadro2: Update to 1.93.0.

* gnu/packages/chemistry.scm (avogadro2): Update to 1.93.0.
[propagated-inputs]: Add openbabel.

Change-Id: Ia7f02e66d9caced61a6a206076513806bb7b29a9
---
gnu/packages/chemistry.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index bd27bfad7a..46728bb407 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -130,6 +130,8 @@ (define-public avogadro2
(list eigen pkg-config))
(inputs
(list avogadrolibs hdf5 molequeue qtbase-5))
+ (propagated-inputs
+ (list openbabel))
;; TODO: Enable tests with "-DENABLE_TESTING" configure flag.
(arguments
'(#:tests? #f))

base-commit: 72923a75af53a819f2be9dc4ae3c096aa3147d3f
--
2.48.1
Z572 wrote 1 weeks ago
(name . Jakob Kirsch via Guix-patches via)(address . guix-patches@gnu.org)
87wmd5jxf9.fsf@z572.online
Jakob Kirsch via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (4 lines)
> avogadro2 needs open babel at runtime so we should add this to the propagated inputs.
>
> [2. text/plain; v1-0001-gnu-avogadro2-Update-to-1.93.0.patch]...

I think wrapper might be better, if it's just an application.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfr6klGDOXiwIdX/bO1qpk+Gi3/AFAmfGcQoACgkQO1qpk+Gi
3/DgWQ/9F9LG/GzBAUAem54hKcG67foMG3d/Npmejh7Lf5Bv/5FC/98mrOeatxjC
FfbShhMx5zZ4SVwX0lCKc6ff1kjEFffsd+jfFZmHgsgB/BVarf9gv0W5zQaFjvwg
VMmot4jtDf68fGFVT/kOXh+JfEWL0SCKREeUChAskik01y1rrNGQ2rI5gvyzMfBq
rSXF9a/YKMuG0SiDmhriADQC1NMKyX8kzKDUpWIjMq88dRSOr16k6ObMqZqAt7rP
nns+3GZ+ewtNzJjLA0613cftl+X77DCyq0QpPoDmqcuP/krRetgkncL1j5kizP5A
yDiBWWdRW1Ah1YN5GhOYda27m29RI56LBFFOvmfR06HVa6qVbLE2+RtpXniLOTPK
0A/M626MQyB8Dr6IUVhCNIGAKrWrPeXA4XUVQCBG2yR7vcPTdAuy3Ef5GnGcWiW9
3DMjcreQpmZUo+kWg2AVSjoK14awRTv1viUh8Alf2cPCSoOjcK2Ur6Da9bJqulc9
wHXqohqbN88VEIunVU+vR/nmQIFiccevXn8J6Ov8Q95ofFH/f37Egr/59kVB4CzH
cjX8/rk8o4XYgTD5iHmmPIXXe+OM98uSe4yJZN5qVvFNvU25ea+l0eZaZVdq/zVh
zogqImwIWrWbIEp9MoZf+FrSXYz+3q/JvpkU/T/1YekSive4yvM=
=Keha
-----END PGP SIGNATURE-----

Jakob Kirsch wrote 1 weeks ago
[PATCH] v2
(address . 76728@debbugs.gnu.org)
Z8dRinHG_7y54YUj@kernelpanicroom
This is the v2 with wrap-program instead of propagated-inputs.
From 5608c37f14b7b5d46f6ac0a31b4f0c073bd186aa Mon Sep 17 00:00:00 2001
Message-ID: <5608c37f14b7b5d46f6ac0a31b4f0c073bd186aa.1741115763.git.jakob.kirsch@web.de>
From: Jakob Kirsch <jakob.kirsch@web.de>
Date: Tue, 4 Mar 2025 20:15:05 +0100
Subject: [PATCH v2] gnu: avogadro2: Update to 1.93.0.

* gnu/packages/chemistry.scm (avogadro2): Update to 1.93.0.

Change-Id: Ic133ed59aac11d9f48443c1d297d69060514d01f
---
gnu/packages/chemistry.scm | 20 +++++++++++++-------
1 file changed, 13 insertions(+), 7 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index bd27bfad7a..78fedfd34f 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -122,17 +122,23 @@ (define-public avogadro2
(url "https://github.com/OpenChemistry/avogadroapp")
(commit version)))
(sha256
- (base32
- "1z3pjlwja778a1dmvx9aqz2hlw5q9g3kqxhm9slz08452600jsv7"))
+ (base32 "1z3pjlwja778a1dmvx9aqz2hlw5q9g3kqxhm9slz08452600jsv7"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
- (native-inputs
- (list eigen pkg-config))
- (inputs
- (list avogadrolibs hdf5 molequeue qtbase-5))
+ (native-inputs (list eigen pkg-config))
+ (inputs (list avogadrolibs hdf5 molequeue qtbase-5))
;; TODO: Enable tests with "-DENABLE_TESTING" configure flag.
(arguments
- '(#:tests? #f))
+ (list
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda _
+ (wrap-program (string-append #$output "/bin/avogadro2")
+ (list "PATH"
+ 'suffix
+ (list (string-append #$openbabel "/bin")))))))))
(home-page "https://www.openchemistry.org/projects/avogadro2/")
(synopsis "Advanced molecule editor")
(description

base-commit: c1ec9e8d53da209ba1d6f8466d03180d195d7334
--
2.48.1
Jakob Kirsch wrote 6 days ago
New patch
(address . 76728@debbugs.gnu.org)
Z8m25VAAhrH0Q9wk@kernelpanicroom
Since we're rebuilding avogadro2, we might as well update it to the new version.
Btw etc/committer.scm is broken with this patch so the merger would have to properly format the commits or fix the committer.
Jakob Kirsch wrote 6 days ago
(no subject)
(address . 76728@debbugs.gnu.org)
Z8m38lf3HmYHkpJJ@kernelpanicroom
This is still WIP as some things are broken like:
* icons don't render
* openbabel optimization is broken with DNA
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76728@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76728
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help