[PATCH 0/7] Refactor and update libvips-related packages

  • Open
  • quality assurance status badge
Details
One participant
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal

Debbugs page

Vinicius Monego wrote 1 weeks ago
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
cover.1741010255.git.monego@posteo.net
Vinicius Monego (7):
gnu: vips: Build with OpenEXR 3.
gnu: vips: Update to 8.16.0.
gnu: vips: Propagate inputs to satisfy vips.pc.
gnu: nip2: Remove inputs propagated from vips.
gnu: nip2: Update to 8.9.1.
gnu: python-pyvips: Update to 2.2.3.
gnu: python-scooby: Update to 0.10.0.

gnu/packages/image-processing.scm | 52 +++-----------
gnu/packages/python-xyz.scm | 112 +++++++++++++-----------------
2 files changed, 59 insertions(+), 105 deletions(-)


base-commit: e7b87dcde25b5ef278441d6ea42a7f662fe6d53f
--
2.48.1
Vinicius Monego wrote 1 weeks ago
[PATCH 1/7] gnu: vips: Build with OpenEXR 3.
(address . 76712@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
06d641635020158f92e009ad1a58b2f1830a9709.1741010255.git.monego@posteo.net
* gnu/packages/image-processing.scm (vips)[inputs]: Replace openexr-2 by
openexr.

Change-Id: I47fe672a7f9f27abe8e8b5d286ea00c1643e5c9f
---
gnu/packages/image-processing.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 405f90ca9a..2f865e7192 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -810,7 +810,7 @@ (define-public vips
libwebp
matio
niftilib
- openexr-2
+ openexr
orc
pango
poppler))
--
2.48.1
Vinicius Monego wrote 1 weeks ago
[PATCH 2/7] gnu: vips: Update to 8.16.0.
(address . 76712@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
4c3aa9ec2f5979f45180f165028acca620a6ad2a.1741010255.git.monego@posteo.net
* gnu/packages/image-processing.scm (vips): Update to 8.16.0.

Change-Id: I53e0caeba41bc674adb2f264ce55775ffc27029f
---
gnu/packages/image-processing.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 2f865e7192..89324f3a08 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -778,7 +778,7 @@ (define-public opencv
(define-public vips
(package
(name "vips")
- (version "8.15.3")
+ (version "8.16.0")
(source
(origin
(method git-fetch)
@@ -787,7 +787,7 @@ (define-public vips
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0nxzhs4gwhpm4j9hlca8s97xh1b1p1cawnwdc69rmxkrf714hlgj"))))
+ (base32 "0vy0jxm4nz5wdswirra8fp71pwjixs749ki2cx5479yd2cp511nr"))))
(build-system meson-build-system)
(native-inputs
(list gobject-introspection pkg-config))
--
2.48.1
Vinicius Monego wrote 1 weeks ago
[PATCH 3/7] gnu: vips: Propagate inputs to satisfy vips.pc.
(address . 76712@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
6accabe7976d17873ea43033f720133ab4522db5.1741010255.git.monego@posteo.net
* gnu/packages/image-processing.scm (vips)[inputs]: Remove giflib,
niftilib. Move expat, fftw, lcms, libexif, libgsf, libjpeg-turbo,
libpng, librsvg-for-system, libtiff, libxml2, libwebp, matio, openexr,
orc, pango to ...
[propagated-inputs]: ... here.

Change-Id: I96783e51bb0618befba38e7a521d3d6182913fe0
---
gnu/packages/image-processing.scm | 12 +++---------
1 file changed, 3 insertions(+), 9 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 89324f3a08..9def124674 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -791,14 +791,10 @@ (define-public vips
(build-system meson-build-system)
(native-inputs
(list gobject-introspection pkg-config))
- (inputs
+ (inputs (list glib (list glib "bin") hdf5 imagemagick poppler))
+ (propagated-inputs
(list expat
fftw
- giflib
- glib
- (list glib "bin")
- hdf5
- imagemagick
lcms
libexif
libgsf
@@ -809,11 +805,9 @@ (define-public vips
libxml2
libwebp
matio
- niftilib
openexr
orc
- pango
- poppler))
+ pango))
(home-page "https://libvips.github.io/libvips/")
(synopsis "Multithreaded image processing system with low memory needs")
(description
--
2.48.1
Vinicius Monego wrote 1 weeks ago
[PATCH 4/7] gnu: nip2: Remove inputs propagated from vips.
(address . 76712@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
b4d2bed242a4a57c4ecfc10e1ebd3744528eedd5.1741010255.git.monego@posteo.net
* gnu/packages/image-processing.scm (nip2)[inputs]: Remove fftw, glib,
imagemagick, lcms, libexif, libgsf, libjpeg-turbo, librsvg-for-system,
libtiff, libwebp, libxml2, matio, openexr-2, orc, poppler.

Change-Id: Ifeae1ae6b6d41dd89e73edcf3c6963b3a03fdd81
---
gnu/packages/image-processing.scm | 23 ++---------------------
1 file changed, 2 insertions(+), 21 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 9def124674..de172eb5ea 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -922,27 +922,8 @@ (define-public nip2
(add-before 'check 'set-home
(lambda _
(setenv "HOME" "/tmp") #t)))))
- (inputs
- (list vips
- glib
- libtiff
- gtk+-2
- libxml2
- libexif
- libjpeg-turbo ;required by vips.pc
- (librsvg-for-system)
- fftw
- libgsf
- imagemagick
- orc
- matio
- lcms
- libwebp
- openexr-2
- poppler
- gsl))
- (native-inputs
- (list flex bison pkg-config))
+ (inputs (list gsl gtk+-2 vips))
+ (native-inputs (list bison flex pkg-config))
(home-page "https://github.com/libvips/nip2")
(synopsis "Spreadsheet-like GUI for libvips")
(description "This package provide a graphical user interface (GUI) for
--
2.48.1
Vinicius Monego wrote 1 weeks ago
[PATCH 5/7] gnu: nip2: Update to 8.9.1.
(address . 76712@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
a992bbb7563901af10c890b4a3de2d2a5048d518.1741010255.git.monego@posteo.net
* gnu/packages/image-processing.scm (nip2): Update to 8.9.1.
[arguments]<#:phases>: Delete the 'disable-test-conv phase. Remove
trailing #t from 'set-home.

Change-Id: If6a96c4cc83880634110efaa99a58b2e475e3687
---
gnu/packages/image-processing.scm | 11 +++--------
1 file changed, 3 insertions(+), 8 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index de172eb5ea..8313ead848 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -902,26 +902,21 @@ (define-public gmic-qt-gimp
(define-public nip2
(package
(name "nip2")
- (version "8.7.1")
+ (version "8.9.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/libvips/nip2/releases/download/v"
version "/nip2-" version ".tar.gz" ))
(sha256
- (base32 "0l7n427njif53npqn02gfjjly8y3khbrkzqxp10j5vp9h97psgiw"))))
+ (base32 "1kbndn37m0cfjvrvw25b5if9d962r8v79q78i2lzm55r7zmjcpmp"))))
(build-system gnu-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- ;; test_conv.ws keep failing so disabling for now.
- (add-after 'unpack 'disable-test-conv
- (lambda _
- (delete-file "test/workspaces/test_conv.ws")
- #t))
(add-before 'check 'set-home
(lambda _
- (setenv "HOME" "/tmp") #t)))))
+ (setenv "HOME" "/tmp"))))))
(inputs (list gsl gtk+-2 vips))
(native-inputs (list bison flex pkg-config))
(home-page "https://github.com/libvips/nip2")
--
2.48.1
Vinicius Monego wrote 1 weeks ago
[PATCH 6/7] gnu: python-pyvips: Update to 2.2.3.
(address . 76712@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
3989c574eb737b67cff25b1d8f72beda4f7dfc6c.1741010255.git.monego@posteo.net
* gnu/packages/python-xyz.scm (python-pyvips): Update to 2.2.3.
[source]: Fetch from GitHub.
[build-system]: Use pyproject-build-system.
[arguments]<:phases>: Delete the now unnecessary 'fix-build, 'fix-paths
and custom 'check phase. Also build in API mode.
[native-inputs]: Add pkg-config, python-setuptools, python-wheel. Remove
python-pytest-flake8, python-pytest-runner.
[propagated-inputs]: Add python-pkgconfig.
* gnu/packages/python-xyz.scm (python-pyvips-for-python-scooby): Do not
delete the phase that was deleted in the parent package.

Change-Id: I8b3ac54f5b118a565f7297cf455698e690197e78
---
gnu/packages/python-xyz.scm | 58 +++++++++----------------------------
1 file changed, 14 insertions(+), 44 deletions(-)

Toggle diff (87 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c15671b53f..7a3dcc0c76 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12071,56 +12071,27 @@ (define-public python-imageio
(define-public python-pyvips
(package
(name "python-pyvips")
- (version "2.2.1")
+ (version "2.2.3")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "pyvips" version))
+ (method git-fetch) ; PyPI does not include test helpers
+ (uri (git-reference
+ (url "https://github.com/libvips/pyvips")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1dfbwwvnnsk4g2kj1pw654z9jq3mb72l1m8ma29858jpn12vn7dm"))))
- (build-system python-build-system)
- (arguments
- (list #:phases
- #~(modify-phases %standard-phases
- ;; Maybe switch to API mode (i.e., build the C extension)?
- ;; It is advertised as faster to start up and run.
- ;; However, even with ‘pkg-config’ and ‘python-pkgconfig’ in
- ;; ‘native-inputs’, the API mode build fails with:
- ;;
- ;; Falling back to ABI mode. Details: unable to find pkg-config package "vips"
- ;;
- ;; The build doesn't actually fail without the below
- ;; substitution, it's just slower because ‘setup.py’ tries
- ;; (unsuccessfully) to download the Python ‘pkgconfig’ module.
- (add-after 'unpack 'fix-build
- (lambda _
- (substitute* "setup.py"
- (("^( +setup_)API\\(\\)\n" _ prefix)
- (string-append prefix "ABI()\n")))))
- (add-after 'unpack 'fix-paths
- (lambda _
- (substitute* "pyvips/__init__.py"
- (("^( +_vips_libname) = '(libvips.so.42)'"
- _ var libname)
- (format #f "~a = '~a/lib/~a'"
- var #$(this-package-input "vips") libname))
- (("^( +_gobject_libname) = '(libgobject-2.0.so.0)'"
- _ var libname)
- (format #f "~a = '~a/lib/~a'"
- var #$(this-package-input "glib") libname)))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "setup.py" "test")))))))
+ (base32 "1ddk9njjc1kqjdmf95mwij83gjg0wg9d8qrl3abm19bmwiq7aq0h"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-pyperf
+ (list pkg-config
+ python-pyperf
python-pytest
- python-pytest-flake8
- python-pytest-runner))
+ python-setuptools
+ python-wheel))
(inputs
(list glib vips))
(propagated-inputs
- (list python-cffi))
+ (list python-cffi python-pkgconfig))
(home-page "https://github.com/libvips/pyvips")
(synopsis "Python bindings for VIPS")
(description "The @code{pyvips} package provides Python bindings for VIPS,
@@ -39096,9 +39067,8 @@ (define python-pyvips-for-python-scooby
(name "python-pyvips-for-python-scooby")
(arguments
(substitute-keyword-arguments (package-arguments python-pyvips)
- ((#:phases phases)
+ ((#:phases phases '%standard-phases)
#~(modify-phases #$phases
- (delete 'fix-paths)
;; The checks won't succeed without VIPS.
(delete 'check)
(delete 'sanity-check)))))
--
2.48.1
Vinicius Monego wrote 1 weeks ago
[PATCH 7/7] gnu: python-scooby: Update to 0.10.0.
(address . 76712@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
46b9ebe0a3d12946531d376fcfafce11df5c9ad4.1741010255.git.monego@posteo.net
* gnu/packages/python-xyz.scm (python-scooby): Update to 0.10.0.
[build-system]: Use pyproject-build-system.
[native-inputs]: Add python-no-version, python-pytest-console-scripts,
python-setuptools, python-wheel, python-time.
[arguments]: Move below build-system. Remove 'fix-tests and custom
'check phase. Skip a failing test.
* gnu/packages/python-xyz.scm (python-no-version): New variable.

Change-Id: Idbab8d0eaedd5f0fcbaa71de052de7c5c74c0da1
---
gnu/packages/python-xyz.scm | 54 +++++++++++++++++++++++--------------
1 file changed, 34 insertions(+), 20 deletions(-)

Toggle diff (89 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7a3dcc0c76..4b3468348a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -39080,7 +39080,7 @@ (define python-pyvips-for-python-scooby
(define-public python-scooby
(package
(name "python-scooby")
- (version "0.5.12")
+ (version "0.10.0")
(source
;; The PyPI tarball does not contain the tests.
(origin
@@ -39090,33 +39090,27 @@ (define-public python-scooby
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1gkpmz8wl3jg8ylf1na35308sznw2g9wx33zqlyq5i2gpy2ml9mw"))))
- (build-system python-build-system)
+ (base32 "10d9j9anhgfhqg7rs34pld7ivyja2plz7z4bzdjsvkwgq8vlny19"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; FIXME: This test uses pytest-console-scripts in subprocess mode to
+ ;; call the 'scooby' executable. Check why this failed.
+ #:test-flags #~(list "-k" "not test_cli")))
(native-inputs
(list python-beautifulsoup4
+ python-no-version
python-numpy
python-pytest
+ python-pytest-console-scripts
python-pytest-cov
python-pyvips-for-python-scooby
- python-scipy))
+ python-scipy
+ python-setuptools
+ python-wheel
+ time))
(propagated-inputs
(list python-psutil))
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-tests
- (lambda _
- (substitute* "tests/test_scooby.py"
- ;; The test suite uses the no-version PyPI package
- ;; (https://pypi.org/project/no-version/),
- ;; but it doesn't seem worth packaging in Guix just for this.
- (("scooby\\.report\\.VERSION_NOT_FOUND")
- "scooby.report.MODULE_NOT_FOUND")
- (("^ +import no_version # noqa.*") ""))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest")))))))
(home-page "https://github.com/banesullivan/scooby")
(synopsis "Report hardware information and Python package versions")
(description
@@ -39239,6 +39233,26 @@ (define-public python-catalogue
Pickle for serialization, which has many drawbacks.")
(license license:expat)))
+(define python-no-version
+ (package
+ (name "python-no-version")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "no_version" version))
+ (sha256
+ (base32 "1y58fkwg4s96hbz3hnqj2nd8a0pimrmpk4ry1z5pwzxlyx0k66rf"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f)) ; this is a dummy package
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://github.com/prisae/no_version")
+ (synopsis "Package without __version__ number")
+ (description "This is a dummy package that does not contain a version
+number, only useful for testing purposes.")
+ (license license:cc0)))
+
(define-public python-wasabi
(package
(name "python-wasabi")
--
2.48.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76712@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76712
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help