[PATCH 0/1] Add guix AppStream catalog generation

  • Open
  • quality assurance status badge
Details
One participant
  • Noé Lopez
Owner
unassigned
Submitted by
Noé Lopez
Severity
normal
Merged with

Debbugs page

Noé Lopez wrote 2 weeks ago
(address . guix-patches@gnu.org)(name . Noé Lopez)(address . noelopez@free.fr)
cover.1740845771.git.noelopez@free.fr
From: Noé Lopez <noelopez@free.fr>

Hi,

This patch adds a new “guix appstream” command that generates an AppStream
catalog out of all packages contained in the current guix (channels included).

This patch is part of my work on PackageKit integration and is needed for
Gnome Software and Discover to recognise packages. The installation of the
xml file is intentionaly left out for now, but I imagine it could be done
using a (home) service. Similarly, the xml file presents some shortcomings:

– It contains too many packages, and does not take into account the different
package outputs.

– It does not respect packages’ metainfo files or desktop entries, as you need
a built package for that. This means no icons, wrong rDNS ids, and only the
metainfo guix knows.

It doesn’t need to be merged in this version but I am posting to get some
reviews on what I currently have :)

If you want to try out the command, the resulting xml file should be placed in
/var/lib/swcatalog/xml/ and can be tested using appstreamcli:

noe@lignux ~/src/guix-appstream [env]$ ./pre-inst-env guix appstream
[…]
Created guix-1.4.0-31.121e96d.xml with 33125 packages
noe@lignux ~/src/guix-appstream [env]$ sudo cp guix-1.4.0-31.121e96d.xml /var/lib/swcatalog/xml/
noe@lignux ~/src/guix-appstream [env]$ guix shell appstream -- appstreamcli search openttd
Identifier: openttd [desktop-application]
Name: openttd
Summary: Transportation economics simulator game
Package: openttd
\---
Identifier: catcodec [desktop-application]
Name: catcodec
Summary: Encode/decode OpenTTD sounds
Package: catcodec

Noé Lopez (1):
guix appstream: New script.

Makefile.am | 1 +
guix/import/utils.scm | 14 +++++
guix/scripts/appstream.scm | 125 +++++++++++++++++++++++++++++++++++++
3 files changed, 140 insertions(+)
create mode 100644 guix/scripts/appstream.scm


base-commit: d1e3c41abdda9f8e9f1283376feb853670393793
--
2.48.1
Noé Lopez wrote 2 weeks ago
(no subject)
87ikosk7xt.fsf@xn--no-cja.eu
merge 76661 76662
thanks
-----BEGIN PGP SIGNATURE-----

iQHGBAEBCAAwFiEEXVTPJVeyOOiNwYCiLSIyQQq3QEMFAmfDO84SHG5vZUB4bi0t
bm8tY2phLmV1AAoJEC0iMkEKt0BD2i8L/jyVEwciT1pIEsd+vBAFT3b7yqje+CU2
tvTX/BSQS2lzINbwCyVtnPTIucLfjjYFrLe3N5rNy9Nyfo52UzqNp5BZ06ZoBERP
fclbK8zO1JA8ETdqvjNylL0UwRTOmNZgnnOwkzUMNoOMTTzy2Jc/cJmsCiPxfn/G
KCDU5ODYLjkqsZJOVsushuJnanes3TcrLrO9FLlsvbuisKx9jLzh3mIr1aaVwHeE
DFmIKKNn6KcMbbU9tQcSkaxw6+rdtSLNeIN7GU+w/JOoHeBPpevRJ6jwaE2tvU4B
LJdwYTjRnrzUl2w6cOKAzQ2m9uSu2S98/rr97/p8kRq0gEkWCyGdP+CAcYNaxVW2
YUHWxbxS82e7pmzK7Stq4ikILnFWCGdIZHornhaLXXhPqeWnKeesQ8O9O1qs4ofp
xQ1a+Bq8nwCTY7qodrK1sXAUotV9UFuIBulPUbVjmV+OoJlgCmdlBDtrvEYSuBRJ
+hrtxe2/t0VTpIE0pyeGqZK1Tu6Er0tCgA==
=DGgu
-----END PGP SIGNATURE-----

?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 76662@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 76662
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help